Announcement

Collapse
No announcement yet.

Setup Issues

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Setup Issues

    Hi there, hope someone can help..

    I installed just before xmas, and have been having database issues, probably caused by the fact that I tried to manually install when the installer crashed.

    So I figured I'd try to reinstall the plugin and do it the correct way. However I get a log file after restart that looks like this...

    26/12/2007 16:43:17 - Startup -
    26/12/2007 16:43:17 - Startup - ************************************************************ ********************
    26/12/2007 16:43:17 - Startup - HomeSeer version 2.2.0.11 (Service Mode) Starting Now (Standard Build)
    26/12/2007 16:43:17 - Startup - ************************************************************ ********************
    26/12/2007 16:43:17 - Startup -
    26/12/2007 16:43:17 - Startup - Using system's regional settings
    26/12/2007 16:43:18 - Info - Remote Admin client connected from: 127.0.0.1
    26/12/2007 16:43:24 - Startup - Loading Settings
    26/12/2007 16:43:25 - Warning - HomeSeer was not shut down successfully the previous time it was started.
    26/12/2007 16:43:29 - Info - HomeSeer is performing database maintenance on sample.mdb
    26/12/2007 16:43:32 - Info - Database maintenance Completed Successfully.
    26/12/2007 16:43:32 - Startup - Settings Loaded.
    26/12/2007 16:43:32 - Startup - Loading configuration file ...
    26/12/2007 16:43:33 - Info - Loading device types file...
    26/12/2007 16:43:33 - Database - Opening up HomeSeer database C:\Program Files\HomeSeer 2\config\sample.mdb
    26/12/2007 16:43:34 - Database - HomeSeer configuration database C:\Program Files\HomeSeer 2\config\sample.mdb has been closed.
    26/12/2007 16:43:34 - Info - Loading Devices...
    26/12/2007 16:43:35 - Load Config - 61 total devices loaded.
    26/12/2007 16:43:35 - Load Config - Checking device type settings for all devices...
    26/12/2007 16:43:35 - Load Config - Finished checking device type settings.
    26/12/2007 16:43:35 - Load Config - Loading Events...
    26/12/2007 16:43:35 - Load Config - 25 total events loaded.
    26/12/2007 16:43:35 - Info - Loading TV Timers...
    26/12/2007 16:43:35 - Info - HomeSeer version is: 2.2.0.11
    26/12/2007 16:43:35 - Info - Initializing phone interface...
    26/12/2007 16:43:37 - Warning - No mailboxes.xml file exists, creating default
    26/12/2007 16:43:37 - HSPhone - HomeSeer Phone Web Interface initializing.
    26/12/2007 16:43:37 - Updater - Starting installation of updates
    26/12/2007 16:43:37 - Updater - Applying update: mcsTemperature
    26/12/2007 16:43:41 - Updater - Executing installer: C:\Program Files\HomeSeer 2\updates2\mcsTemperature5.7.0.3\setup_mcsTemperature.exe

    That was 20 minutes ago and I'm still waiting for it to finish :-(

    Is there a way to manually install the plugin without relying on the automatic installer? I can get the addin running, but getting the .mdb files in the correct format and the right places (..\homeseer2 I presume) seems to be trickier.

    I previously tried a clear and replace from the mcsTemp page, but it complains about file formats.

    Help!

    Cheers in advance,

    Hugh

    #2
    You can get the file from the local updater subfolder or from http://mcsSprinklers.com/mcsTemperature_5_7_0_3.zip.

    The setup_mcsTemperature.exe file from this zip is run to install the files. I would suggest doing this when HS is not running.

    The database used by mcsTemperature are created by the plugin based upon the names and paths on the setup pages of mcsTemperature. Some have had problems with an incomplete creation of the forecast table. The 5 min and 5 max forecast temperature fields were not created (e.g. F1MIN). A database template for the forecast database has been posted and should be available via search if you run into this problem.

    Can you give a more specific example of the database-related problems that you are having?

    Comment


      #3
      Hi Michael,

      Thanks again for the quick reply.

      I've reinstalled the plugin manually... all seems ok until I try and select the 3145 interface and save the settings. Nothing much happens, and the log page comes back with..

      26/12/2007 18:07:00 Info Finished initializing plug-in mcsTemperature
      26/12/2007 18:07:03 mcsTemperature FormatTemperatureScreen on line 1900 Unrecognized database format 'C:\Program Files\HomeSeer 2\mcsTemperature.mdb'.


      Have I missed out a step in the installation?

      Also... If I try and select another page with the temp plugin, after I've tried to save the interface settings, I get this in the log file

      26/12/2007 18:21:03 mcsTemperature Maximum simultaneous ASP requests now = 2
      26/12/2007 18:21:13 mcsTemperature TemperatureASP 10 second Timeout On Pending ASP Request with pending level 2
      26/12/2007 18:22:45 mcsTemperature TemperatureASP 10 second Timeout On Pending ASP Request with pending level 2

      :-(

      Hugh

      Comment


        #4
        For the unrecognized database format I suggest that you delete the Homeseer 2\mcsTemperature.mdb and let the plugin recreate it. You can also zip it up and email to mcsSolutions at centurytel dot net, so I can see if it is a valid file.

        The timeout messages indicate that a HTML page was not returned to the browser in 10 seconds and a second request for a page was made. It is not a specific error, but an indication of unexpected behavior. Does the HS computer have limited RAM or CPU resources?

        Comment

        Working...
        X