Announcement

Collapse
No announcement yet.

mcsTemperature v5.12.7 and Ocelot with SECU16 & LM34

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    mcsTemperature v5.12.7 and Ocelot with SECU16 & LM34

    I'm just totally not understanding something here.

    I have mcsTemperature v5.12.7 installed and enabled in HS2.

    I have connected an Ocelot with a SECU16i and a working LM34. HS2 is actively showing the temperature on that device. HS2 is reading a variable from the Ocelot where I have a program running to do the math and get the right temperature value in there.

    How do I get mcsTemperature to store and ultimately graph that value over time?

    There is nothing listed on the Sensors config page. If I try to add something, it creates device but it doesn't do anything after that since that device is not associated with the Ocelot in any way.

    From what I've read, it sounds like mcsTemperature should see that and allow me to map that to a database field.

    At the moment, I'm just trying to get a running table of temperatures in my server room.

    Thanks for the help. I'm sure it's something that I'm missing in the setup somewhere...

    #2
    You have to explicitly specify the desired device code (DC) you want to map on the mcsTemperature\sensors page. "Sensors" is the first link on the mcsTemperature page. Also make sure the name you specify in the DB field is compatible w/ the database naming rules. Using spaces is a common mistake.

    Comment


      #3
      Where do I find the device code? I've tried "Basement LM34" which is the [Location] & [Name].

      Originally posted by hgys View Post
      You have to explicitly specify the desired device code (DC) you want to map on the mcsTemperature\sensors page. "Sensors" is the first link on the mcsTemperature page. Also make sure the name you specify in the DB field is compatible w/ the database naming rules. Using spaces is a common mistake.

      Comment


        #4
        The Homeseer Device Status page shows the device code, device locations, and device name.

        Comment


          #5
          I think I just figured it out. The "DC" field is for "DeviceCode"? That's where I wasn't entering the right information.

          I entered the Device Name "Basement LM34" followed by nothing for the Bias and Avg fields, "#1" for the DC field and gave it the DB Field name of "LM34Test01". I checked the database and it created the field and is correctly populating it.

          Thanks for all your help!

          Originally posted by Michael McSharry View Post
          The Homeseer Device Status page shows the device code, device locations, and device name.

          Comment

          Working...
          X