Announcement

Collapse
No announcement yet.

Database not Collecting info

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Database not Collecting info

    I just installed a new copy of XP, Homeseer, and mcsTemp... the Database for some reason is not collecting any data but after a few hours all 11 of my Temp Sensors now appear in HS as Devices (House Hodes R1-R11) My main problem now is that I have been monitoring the status of the Temp Devices and not all of them update at the same time, some of them are a few hrs behind, some of them are a few minutes behind.... I have them set up in the mcsTemp to poll every 5 minutes, and the Temp08 is set up to poll every 2 minutes.... I looked at the data using the "I/O Stream" it looks fine and the data is definately changing every 2 minutes, I looked at the .mdb file in access and there is no data in there, but the file was created in HS, just not peing populated with data....

    If anyone can help me I would really appreciate it big time.... The is one of my main reasons I want to continue using HS.... (Not to mention I have alot of money wraped up in it)..

    Thanks,
    Charles

    #2
    If the update time you set then Temp08 is 2 minutes, then also set mcsTemperature to the same value in the line were Temp08 polling rate is shown.

    There is also checkbox to move data to the database from HS virtual devices as some rate. Make certain this is setup.

    mcsTemperature will only update the HS devices when there is a change in value from the Temp08. Data that is received, but unchanged will be discarded. The database will continue to write at the specified interval.

    Comment


      #3
      "There is also checkbox to move data to the database from HS virtual devices as some rate. Make certain this is setup."

      Mike,
      I looked everywhere in the mcsTemp plugin menus and couldnt find this. Which tab could I find this under ?

      Comment


        #4
        Nevermind I found it

        Nevermind I found it

        But it didn't seem to make a difference, I'll try getting a dbug from the log file for ya...

        Thank you so far....

        Comment


          #5
          Here's my log file

          Here's a copy of my log file, I gave the last 15 minutes of the day because that's about when i captured the dbug data....
          Please let me know if you can make heads or tails from this... Also the forecast data is not working, would you mind pointing me in the right direction for that as well ?

          Thanks
          Charles
          Attached Files
          Last edited by definityone2002; July 13, 2008, 11:16 PM. Reason: Attachment didn't attach

          Comment


            #6
            You have no internet data because the msinet.ocx control is not loaded on your computer. It is availalbe from Microsoft download. I've also attached what I believe to be the current version of this control. It needs to be registered once installed with regsvr32.exe. It normally goes into the Windows\System32 folder or whereever your OS is installed.

            Your Temp08 looks to be configured in a debug mode as the data stream is not normal

            Code:
            tae 0=028
            Vta #[000071F6]=4.V048V
            Vta #[D5000870]=.01121,000V2.V
            Tp 1[0005232=755F
            mp02D0806F01]=755
            Tp 3[D0806D107455F
            Tp 4[000B5A109.F
            Tmp0510806FB107200F
            Tp 6[080600105.F
            Tmp0710806BC=890
            Tp 8[00007C1071F
            Tp 9[00004109.F
            mp1020809121=767F
            Temp #11[3A000800B5DE1010]=74.90F
            >
            SUN 23:eading Sensors...
            Attached Files

            Comment


              #7
              Hey Mike Thank you so Far,


              The problem with the delay was a tricky one because I could see the data comming into the I/O diag utility with my own eyes, but after reading through your mcsTemp Doccument from the eairlier versions I noticed that this could be a buffering problem, therefore I changed COM ports on the PC from a USB to Serial Adapter to the motherboard Serial Port. Now it works like it should, I get the updates every minute (for now until I change it again)

              I loaded the msinet.OCX file and registered it for the forecasting but I'm still having problems getting that working, here's the error I get in the Log......


              Thanks Again..

              Charles
              Attached Files

              Comment


                #8
                The log error indicates that the HS is being requested to serve the file _w.gif and it does not exist. This is likely no data yet downloaded for whatever is being requested. The Temp05/08 relatead messages reflect what the Temp08 is sending vs. what the setup is for the devices. For example, a DS2423 is a general purpose counter and it can count many different things such as Lightning strikes or wind speed revolutions. The message is indicating that what the Temp08 returns from a DIS command is different than what is setup on the Sensor page in mcsTemperature.

                The forecast download, per Weather.com agreement is every 4 hours maximum. I forget if mcsTemperature tries to enforce this or not. I dont have your setup information and this log snapshot is very short so there is not much to work with to give you other ideas.

                Comment


                  #9
                  As far as the Forecasting goes, I'm not as concerned about that as much as this most recient error I'm getting, It has seemed to be preventing and data collection.... I was very pleased with all my data collection at 1 minute intervals. All was going well then this popped up...

                  Please take a look and let me know if there is anything I can do to correct this...
                  Attached Files

                  Comment


                    #10
                    The following message is typically associated with Event Trigger or Event Actions where the capabilty exists to enter scripting expression to specific the event parameters. This seems to indicate that the parameter you entered was blank (such as using a upper limit trigger then leaving the upper limit field blank). It should have nothing to directly do with data collection and should only prevent the event you are trying to setup from operating.

                    7/18/2008 5:22:11 PM ~!~mcsTemperature~!~Expression / on line 320 Syntax error

                    Comment


                      #11
                      I disabled all of my events that are related to mcsTemperature, I am still getting that same error every minute, I think it may have something to do with the way it is collecting the data, plus I get another msg that has some foward slashes where there may need to be some back slashes, but I'm not sure where that need to be corrected, I tried to fix it in the C:\Program Files\HomeSeer 2\Config\settings.ini file but it kept going back to its origional settings... I'm not even sure if I was in the right place... I Googled that error "Expression / on line 320 Syntax error" and you had mentioned something about upgrading to the next release, but that was in Oct of '06 and we are now on a much later release... Although that was the solution that fixed the problem at that time, I'm thinking thats probally not where the problem is this time... Is there any log or report that I can produce to make it easier for you to understand what is going on with this issue ? Please let me know what will make this easier for you...


                      Charles
                      Last edited by definityone2002; July 20, 2008, 11:01 PM.

                      Comment


                        #12
                        Expression is a utility function that is used only in evaluating Temperature Triggers and Temperature Actions. If you are getting that message then you have one of the two enabled in an HS event. If you enable the general debug is should provide some context where the error is being generated.

                        Comment


                          #13
                          I've included the debug file to see if you can make sence of it, just do a "Find" for the word "Expression"... I also put the Raw Data Log in here as well.

                          I made sure I disabled all events that used mcsTemp,

                          I'm hoping it's something simple for ya...

                          Charles
                          Attached Files

                          Comment


                            #14
                            You have multiple Temperature Action running. It looks as if one is based on R6. There is one with limits of 0 to 89. One with 90 to 150 limits. Another with 55 and 60 limits. One of these has a limit that appears to resolve to a null.
                            Code:
                            7/27/2008 12:02:43 PM   mcsTemperature Debug  SendQueue= 
                            7/27/2008 12:03:05 PM   mcsTemperature Debug  (0) InsideBand Current=102.2, Lower=0, Upper=89, Compare1=0, Compare2=89,trueConditions=0 
                            7/27/2008 12:03:05 PM   mcsTemperature Debug  (0) Reset Trigger States 
                            7/27/2008 12:03:05 PM   mcsTemperature Debug  (2) InsideBand Current=102.2, Lower=90, Upper=150, Compare1=90, Compare2=150,trueConditions=1 
                            7/27/2008 12:03:05 PM   mcsTemperature Debug  (2) SampleEventTriggered=True, Trigger Repeat Time=7/27/2008 10:42:36 AM, TriggerDwell=5, DwellStart=7/27/2008 10:37:03 AM 
                            7/27/2008 12:03:05 PM   mcsTemperature Debug  (1) InsideBand Current=74.9, Lower=90, Upper=100, Compare1=90, Compare2=100,trueConditions=0 
                            7/27/2008 12:03:05 PM   mcsTemperature Debug  (1) Reset Trigger States 
                            7/27/2008 12:03:05 PM   mcsTemperature  Expression / on line 320 Syntax error 
                            7/27/2008 12:03:05 PM   mcsTemperature Debug  (4) Trigger Device R6, Compare Device 0 { }, Lower Delta Compare 90 vs Delta Value=74.9, event Started=True 
                            7/27/2008 12:03:05 PM   mcsTemperature Debug  (4) True Condition Found, Current True Count=1, needed=2 
                            7/27/2008 12:03:05 PM   mcsTemperature Debug  (4) SampleEventTriggered=True, Trigger Repeat Time=7/26/2008 2:31:43 PM, TriggerDwell=0, DwellStart=7/26/2008 2:31:11 PM 
                            7/27/2008 12:03:05 PM   mcsTemperature Debug  (3) InsideBand Current=66.1, Lower=55, Upper=60, Compare1=55, Compare2=60,trueConditions=0 
                            7/27/2008 12:03:05 PM   mcsTemperature Debug  (3) Reset Trigger States

                            Comment


                              #15
                              Hmmm, I know I disabled all of the Temp Events before, I erased all of them this time. That did the trick, then I added back the more crucial ones, one at a time with different parameters, Everything is working as it should.

                              Thank you so much for all of your help !!

                              Charles

                              Comment

                              Working...
                              X