Announcement

Collapse
No announcement yet.

NWS Forecast not working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    NWS Forecast not working

    OK, I've got all the local sensors properly recognized and graphs setup. It was a challenge, as outlined in this thread... Thanks Michael for sticking with me on it.

    It's been interesting watching the approaching Santa Anna condition in San Diego on the temperature and humidity inside and outside my house.

    Regarding the Weather page, a few things are still not working. I'm using NWS for forecast and current conditions, and they are not working. Weather.com never replied to my repeated requests for XML licensing.

    What is preventing my NWS forecast and current conditions from working? Do I have a setting wrong or has the NWS site formatting changed?

    Screen shots of Weather page and Forecast page are below.
    Attached Files

    #2
    It is hard to read being small, but it looks as if GetWebFile rather than Inet is selected as the download method. I also cannot recognize the site code. What is it? Also confirm your Zip is 92129.

    Comment


      #3
      I tried GetWebFile and INET methods. Same results. I was sure to Save, GetForecastNow, and Save again after each change.

      Site code is KNKX for San Diego. The WeatherXML settings are Get from NWS site and location ID is 92129. Others are left blank.

      Comment


        #4
        I selected on Interface Page to do forecast update every 1 minute for ease of testing. I set my location in HS Setup to be San Diego and the station code you gave. After about 5 minutes I was able to show both current conditions and forecast. I did no change the radar source as that is not related to NWS.

        There are two sites that are queried. One for forecast based upon Lat/Lon and current conditions based upon station ID. The software will toggle between these two each time a download is done.
        Attached Files

        Comment


          #5
          I've confirmed my longitude and latitude are correct in homeseer. Enclosed are my database and ini files.

          In looking at my ini files over time I see that they seem to get extra characters in them after a save sometimes. Often an extra carriage return or several extra "" will appear on some lines. For example the ForecastVDCode6 entry often gets several extra "" added to it over time. It does not seem to hurt anything, but still strange. The ini files attached have been cleaned of this.

          EDIT:
          I'm getting these two messages in the HS log everytime it tries to get the forcast.

          TCPClient GetURL0 http://www.weather.gov/forecasts/xml...ebust=03122607 on line 40 Component 'msinet.ocx' or one of its dependencies not correctly registered: a file is missing or invalid

          and

          TCPClient GetURL1 http://weather.unisys.com/satellite/sat_ir_rad.gif on line 40 Component 'msinet.ocx' or one of its dependencies not correctly registered: a file is missing or invalid
          Attached Files
          Last edited by Mr Spock; April 20, 2009, 08:10 PM.

          Comment


            #6
            I ran your files and after about 5 minutes both the forecast and current conditions are showing up. I put a hard-coded debug where the NWS data is being processed. When I'm running it I get the attached .txt which is the URL and the first 100 characters of XML returned.

            The attached is the hspi_mcsTemperature.exe that has this debug hard-coded if you want to see what you are getting over your internet connection. Rename the file of the same name in the Homeseer folder and replace it with the attached for testing. Reverse when testing is done.

            I also attached my Homeseer \Config\settings.ini that contains the lat and lon that are being used by HS. You will see these in the URL in the attached log output too.

            When I did this test I made no changes to the files you provided.
            Last edited by Michael McSharry; May 10, 2009, 08:02 AM.

            Comment


              #7
              I followed your instructions: shutdown HS, removed old .exe file, installed your custom .exe file, restarted HS. I then issued a GetForecastNow and checked the HS log. The returned string is very similar to yours, except for the very last part. I also get the warning message about missing msinet.ocx that I was getting before (see previous post). I confirmed my settings.ini has the right longitude and latitude.

              See enclosed text file from my HS log.
              Attached Files

              Comment


                #8
                If you look at your output you will see the message below which is why you are not downloading.

                "Component 'msinet.ocx' or one of its dependencies not correctly registered: a file is missing or invalid"

                I have attached one from XP dated 5/22/2000. It should work with Vista too. Unzip it into Windows\System32 folder and then register it with regsvr32 (dos prompt, navigate to windows\system32, regsvr32 msinet.ocx)
                Attached Files

                Comment


                  #9
                  Success! That did it. I had to restart homeseer to get the changes to fully take effect. Now everything in mcsTemperature is working correctly.

                  Thanks for your excellent support. I'm now going to buy mcsTemperature and start my trial of mcsSprinklersPro.

                  Comment

                  Working...
                  X