Announcement

Collapse
No announcement yet.

McsTemp rev:5.16.2 ds2408 relay problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #31
    Finally got back to this. See if the attached works through a HS shutdown. That is all I tried to address at this time. If not then the debug log is of interest.
    Last edited by Michael McSharry; July 18, 2009, 12:17 AM.

    Comment


      #32
      Hello Michael,

      Nice to hear from you and thank you for your response.

      I installed your new version and it seems to be working now with the shutdown and start of the program HS2.
      I set the ds2408 to 8x relay outputs and I can control these outputs to ON and OFF.
      See the log files for more info.

      The last issue are the icons of the relays 1-7 (output 1 to 7).
      Only the output Y0 (R13)icon is working correct (like the ds2406 icon relay).
      If the R13 icon is off, all other 7 can change to off (not ON)
      If the R13 icon is on, all other 7 can change to on (not OFF)
      The R13 icon is leading !!

      I will do some more testing to be sure.

      piever.
      Last edited by piever; September 14, 2010, 01:16 PM.

      Comment


        #33
        I posted V5.17.16 at the normal update location at the top of the mcsSprinklers V5 subforum. It should take care of the icon/status only working for the first channel.

        Comment


          #34
          Hello Michael,

          I installed the version v5.17.16 (not from the mcsSprinkers V5 subforum but mcstemp forum) and I have the same icon situation now with R20 output instead of R13.

          Only the output Y7 (R20)-icon is now working correct (like the ds2406 icon relay).
          If the R20 icon is off, all other 7 can change to off (not ON)
          If the R20 icon is on, all other 7 can change to on (not OFF)
          The R20 icon is leading !!

          piever

          Comment


            #35
            Found another problem. Try 5.17.17. If there is still a problem then post a debug output where you change one of the middle relays.

            Comment


              #36
              Hello Michael,

              Great. it sees to work now. I will do some more testing.
              I let you known aboud the results.

              Thanks.

              piever

              Comment


                #37
                Hello Michael,

                I add a 2e ds2408 to the 1-wire bus, all outputs set to relay.

                If I set all outputs to off and I do a refresh of the page then all 8 icons goes to the on state.
                Sometimes only the 4 upper outputs but also sometime to lower outputs.
                I also see that the hardware is changed from off to on!!

                The 1e ds2408 icons are working fine now.

                Something is wrong with the 2e ds2408 programming.

                Piever

                Comment


                  #38
                  Just need the debug data to see what is happening.

                  Comment


                    #39
                    Hello Michael,

                    See the debug log file for info. The new ds2408 is ...DA29. DCR21...R28
                    The hardware-outputs are changing from off to on after a refresh of the page. (also the icons goes fron off to on !!)

                    piever
                    Last edited by piever; September 14, 2010, 01:17 PM.

                    Comment


                      #40
                      Hello Michael,

                      The 2e ds2408 works also fine now. There was a bad connection on the MR reset resistor and that caurses intermittend output an icon results.
                      (I found this out when I was using the OnewireView program from maxim)

                      I will do some more testing and let you known the results.

                      Thanks so for. Great support for MCS Temperature plug-in.

                      Regards Piever

                      Comment

                      Working...
                      X