Announcement

Collapse
No announcement yet.

mcsTemperature Version 6

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #61
    Have you ever seen it report 100%. It could be the 1-wire drivers not dealing with the saturation if you only observe it 0 when it should be at 100%. Similar logic could be applied to all humidity sensors so the software would treat 0 as 100.

    Comment


      #62
      I don't remember ever seeing 100%, but then I probably wouldn't have noted such a thing if it were raining at the time.
      It probably is the case however as this only seems to happen when we get sustained heavy rain.
      Real courage is not securing your Wi-Fi network.

      Comment


        #63
        Originally posted by Michael McSharry View Post
        Have you ever seen it report 100%. It could be the 1-wire drivers not dealing with the saturation if you only observe it 0 when it should be at 100%. Similar logic could be applied to all humidity sensors so the software would treat 0 as 100.
        You may be right about this. I've just looked at another station near here, and it is reporting 100% RH.
        Real courage is not securing your Wi-Fi network.

        Comment


          #64
          V6.14 en Hobby-boards 6 Channel Master Hub

          I want to use v 6.14 for scannen my 1 wire network by a hobby-board hub. I only scan 1 port with 3 device en not the other 5 ports.

          Before I use V5 en Xap en 1wireXAP

          whats wrong?


          with regards Peter

          Comment


            #65
            mcsTemperature does not support the DS2409 hub switch. xapmcs1wire does support it.

            Comment


              #66
              Seeing the following every 2-3 hours with HSPro Beta 2.4.0.31 update. Didn't see it with .27. Currently at .13 mcsTemp - will update to .14 tonight.

              3/31/2010 11:06:25 PM mcsTemperature GetSpawnedImage on line 190 The system cannot find the file specified.
              3/31/2010 11:07:25 PM mcsTemperature GetSpawnedImage on line 190 The system cannot find the file specified.
              - Pete

              Auto mator
              Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.12.X
              Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.12.X
              HS4 Pro - V4.1.7.0 - Ubuntu 18.04/VB W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono 6.12.x
              HS4 Lite -

              X10, UPB, Zigbee, ZWave and Wifi MQTT automation. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

              Comment


                #67
                This is the GetWebFile.exe file that it is looking for to do the image download which is likely for the Forecast radar image

                Comment


                  #68
                  Thanks for Michael!
                  By now the problem is solved. The main problem is the USB <>, port2 definition was (I think), but the 4-8 couldnt be controlled therefore.

                  I fully reinstalled HS, and all modules. After that MCS starts control well, temp sensors, and DS 2408 ports. All port is controlled now, and they execute command in short time.

                  As I see, the most important setting in MCS menu the DS9094 port settings, ( polling time, etc.) it has strong effect on proper work. Unfortunately I dont know all menupoints ideal setting, my help button doesnt work. Where can I find a good explanation of MCS (under HS) settings?

                  Comment


                    #69
                    Hello Michael,
                    Removed all "getwebfile.exe" instances yesterday morning. Its still showing same in log every couple of hours. Just looked at setup:
                    Attached Files
                    - Pete

                    Auto mator
                    Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.12.X
                    Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.12.X
                    HS4 Pro - V4.1.7.0 - Ubuntu 18.04/VB W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono 6.12.x
                    HS4 Lite -

                    X10, UPB, Zigbee, ZWave and Wifi MQTT automation. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

                    Comment


                      #70
                      "Reporting queued error: faulting application GetWebFile.exe, version 1.0.0.0, faulting module ntdll.dll, version 5.2.3790.4455, fault address 0x0004cde2."

                      3/31/2010 11:06:25 PM mcsTemperature GetSpawnedImage on line 190 The system cannot find the file specified.

                      Removed all "getwebfile.exe" instances yesterday morning. Its still showing same in log every couple of hours. Just looked at setup:
                      GetWebFile.exe is not used by mcsSprinkles as of V2.10 and was ony an option in prior versions. GetWebFile.exe is used by mcsTemperature to download the Forecast page radar URLs.

                      GetWebFile is just an application that runs in a new process to execute the Windows API "URLDownloadToFile". Apparently URLDownloadToFile uses or has a relationship to ntdll.dll and I have no visibiility into what it may be. URLDownloadToFile has been part of Windows since at least W95.

                      To get rid of the GetSpawnedImage error then GetWebFile.exe needs to be restored for mcsTemperature or the request to download the radar images removed from mcsTemperature. Once it is restored then perhaps a better characterization of ntdll.dll fault can be determined.

                      Comment


                        #71
                        Where can I find a good explanation of MCS (under HS) settings?
                        The manual associated with V6 of mcsTemperature was lost, but the prior version manual should be on your computer under the Homeseer folder \HTML\Help\mcsTemperature\mcsTemperature_Readme.pdf

                        Comment


                          #72
                          Doing the above setting of the option to use INET worked. The logs are clear now.

                          Not an issue anymore. Yes last time I had the same issue I re-installed the GetWebFile.exe program under the mcsTemperature BIN directory and the problem went away. Easier though just to use the INET option. The 'ntdll.dll" version that is being used on my 2003WStandard is: 5.2.3790.4455 that came with 2003 SP2.

                          FYI - its been a couple of days with no issues.


                          Thanks Michael.
                          Last edited by Pete; April 3, 2010, 12:18 PM.
                          - Pete

                          Auto mator
                          Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.12.X
                          Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.12.X
                          HS4 Pro - V4.1.7.0 - Ubuntu 18.04/VB W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono 6.12.x
                          HS4 Lite -

                          X10, UPB, Zigbee, ZWave and Wifi MQTT automation. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

                          Comment


                            #73
                            New Graphing

                            Michael,

                            Will you be switching over the graphing in MCSTemperature to the same style as you introduced with newest MCSSprinklers?
                            - Pete

                            Auto mator
                            Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.12.X
                            Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.12.X
                            HS4 Pro - V4.1.7.0 - Ubuntu 18.04/VB W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono 6.12.x
                            HS4 Lite -

                            X10, UPB, Zigbee, ZWave and Wifi MQTT automation. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

                            Comment


                              #74
                              No plans for that. Chart director will continue to be used. The standalone version of mcsSprinklers used a similiar display in prior years and it was based on flash. HS was not able to process the flash parameters that were used through its web server so the HS user could only use the simple HTML column charts.

                              Comment


                                #75
                                I was hoping to work with the Hobby Boards 1Wire UV sensor. Unfortunately mcsTemp doesn't seem to see it on the network. Any way I might add this sensor? The doc says it uses a "custom one wire chip" but not much more other than some programming notes.
                                Real courage is not securing your Wi-Fi network.

                                Comment

                                Working...
                                X