Announcement

Collapse
No announcement yet.

1 wire configuration

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    1 wire configuration

    : Is the msjava version OK?
    What can I do more? Uninstall mcstemperature? If yes how to do that without loosing information?

    #2
    mcsTemperature will only work with the MS Java and older 1-wire drivers. If it cannot detect the DS9097U via polling you can also enter COM7 for the port. The IO window will take focus from HS so as long as it is open HS will be blocked from other activities. A better way to debug in the HS2 environment is with the debug and show raw data checkboxes on the mcsTemperature setup. The msjava install is typically in two parts. One is the original XP msjvm install and then there is a update.

    For your setup select the DS9097U as the interface, COM7, 60 seconds; Transfer mapped Virtual Devices to Database and at interval 1 minute; General Debug log.

    Another option that is available is to do your debugging with xapmcs1wire http://board.homeseer.com/showthread.php?t=101056 which is a standalone application that uses the same environment as mcsTemperature. Once you get it functional there then you should have no issues with mcsTemperature. If you do go this way, then delected the DS9097U on mcsTemperature and restart HS because both applications cannot attach the the DS9097U at the same time.

    Likely the easiest approach for you is to use the .NET 1-wire plugin from Matthew. It uses the latest drivers and Sun JVM. Once the devices are imported to HS then they can be enteterd on the mcsTemperature form for charting etc.
    Last edited by Michael McSharry; September 17, 2009, 12:40 PM.

    Comment


      #3
      MSJVM and 1 wire drivers

      Michael,

      Thanks for answering.

      I already understood that.

      The problem is that at this moment, I'm not shure about:

      a) the version of the java vm
      b) the 1 wire drivers
      c) if the mcstemperature plugin is well installed

      Can you post a link or attach the correct drivers and the correct MsJavaVM to be installed? I'm shure it would help a lot!

      Thanks

      Originally posted by Michael McSharry View Post
      mcsTemperature will only work with the MS Java and older 1-wire drivers. If it cannot detect the DS9097U via polling you can also enter COM7 for the port. The IO window will take focus from HS so as long as it is open HS will be blocked from other activities. A better way to debug in the HS2 environment is with the debug and show raw data checkboxes on the mcsTemperature setup. The msjava install is typically in two parts. One is the original XP msjvm install and then there is a update.

      For your setup select the DS9097U as the interface, COM7, 60 seconds; Transfer mapped Virtual Devices to Database and at interval 1 minute; General Debug log.

      Another option that is available is to do your debugging with xapmcs1wire http://board.homeseer.com/showthread.php?t=101056 which is a standalone application that uses the same environment as mcsTemperature. Once you get it functional there then you should have no issues with mcsTemperature. If you do go this way, then delected the DS9097U on mcsTemperature and restart HS because both applications cannot attach the the DS9097U at the same time.

      Comment


        #4
        I downloaded the pair some years ago that worked for me. I put them in file msjvm.zip at mcsSprinklers.com

        Comment


          #5
          1 wire... Black clouds around?

          Michael,

          Thanks for the files.

          Unhappyly it still didn't worked

          a)Debugging with xapmcs1wire (as your preview) is the same; no comunication; no data!

          b)The .NET 1-wire plugin from Matthew, didn't worked at all. When I run the exe I got the following:

          Specified adapter name "{na<NA>}" is not known
          Done...

          It seems some kind of Black cloud is around my run...

          Although this, with sun java, the 4.02 drivers, and the onewireapplication: No Problem!! I see all the network... strange....

          I think my next step will be the TEMP08

          I'm start missing my bobcat's...

          Comment


            #6
            There are different models of the DS9097U. Here is one sentence for a discussion thread for xapmcs1wire. I know in xapmcs1wire I made the adapter type a user entry. What did you enter when you tried to run with xapmcs1wire? It is likely you need to use DS9097U_DS9480 if you have a newer DS9097U model.

            I'm not positive what DS9097U_DS9480 vs. DS9097U is, but I suspect they are the same. I saw this in a discussion forum "I think we've found the problem. It seems that the DS9097U-009 is not a direct replacement for the DS9097U-S09....so the software is not compatible.

            Comment


              #7
              1 wire running (finally)

              UFFFFFFFF!

              Michael, thanks for your answer. You found the problem!

              Now it seems to be working...

              I just used DS9097U_DS9480 but it didn't worked.

              After that I saw (and I wrote) the code DS9097U-A (from hobbie boards) and I pushed poll 9x9x and it catched com1.

              After restarting all the temperature sensors readings are being displayed

              I tried to change the adapter to com7 but I couldn't... it only works with com1, wich is the ONBOARD com port.... then I just changed meteor to com7 and 1 wire to com1 ... and both are working!

              I noticed the data from the 1 wire network is not automaticaly written to the database, is there something more to configure on mcstemperature?

              Thanks

              Comment


                #8
                Two things for things to go into the database. One is the sensor needs to have a database filed to use and that is setup on the Sensor page. User a simple name there that will be database friendly (i.e. no spaces, special characters etc)
                The second is on the Interface Page for checkbox to transfer virtual devices to database and the rate at which to transfer.

                Comment


                  #9
                  Working 100%

                  Sorry about this...

                  That was already made... I only saw the beginning of the database (the older records - not the new ones). The data is being recorded to the database and the charting is working

                  Thanks again.

                  Comment

                  Working...
                  X