Announcement

Collapse
No announcement yet.

Some problems with MCS Temperature plugin

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Some problems with MCS Temperature plugin

    Hi,

    I have been getting following error messages in the HS log. Any ideas what is causing them?
    I'm using the latest plugin version.

    11 13:21:53 ~!~mcsTemperature~!~WeatherXML on line 710 Object variable or With block variable not set
    2.1.2011 13:22:54 ~!~mcsTemperature~!~WeatherXML on line 710 Object variable or With block variable not set
    2.1.2011 16:15:52 ~!~Error~!~Running script, script run or compile error in file: weathercom_xml.txt424:Object required: 'oNode' in line 120 More info: Object required: 'oNode'

    Jari

  • #2
    The offending line is below which lilkely means it cannot find the "ut" element in the node tree on the data from Weather.com. The current versions of mcsTemperature will not download from Weather.com, but it will process files downloaded via other means such as the WeatherXML script. The default xml file is at \data\weathercom_xml\weathercom.xml if you are reading it from a file. In this case you can post it to see if the format has changed.

    710 bMetricTemp = UCase(oNode.selectSingleNode("ut").text) = "C"

    Comment


    • #3
      Hi Mike,

      In fact I am not quite sure how I get the forecast data. I enclose an image showing the setup for forecast. It looks like that I am getting the data from NWS and not from WeatherXML. Perhaps I should disable the WeatherXML or should I choose "Get from NWS site"? I enclose also the xml-file but it seems to be empty.

      Jari
      Attached Files

      Comment


      • #4
        Hi Mike,

        I just noticed that I have an event running weathercom_xml.txt script every 120min. I am not quite sure whether this was originally included in your MCS Temp plugin or is it a separate script. If I am using the NWS site for forecast data do I need this weathercom script? I have to say that I'm somewhat confused now.

        Jari

        Comment


        • #5
          I have been seeing this recently at random times as well.
          Best regards,
          -Mark-

          If you're not out on the edge, you're taking up too much room!
          Interested in 3D maps? Check out my company site: Solid Terrain Modeling

          Comment


          • #6
            Hi Mark,

            I have also these errors at random times.

            Jari

            Comment


            • #7
              I guess I should have mentioned that I'm using the WeatherXML script to grab weather data & MCSTemp is reading that xml file. I suspect that Weather.com is changing their data formats again but have not yet grabbed a "bad" xml file for proof.
              Best regards,
              -Mark-

              If you're not out on the edge, you're taking up too much room!
              Interested in 3D maps? Check out my company site: Solid Terrain Modeling

              Comment

              Working...
              X