Announcement

Collapse
No announcement yet.

AAG Wind sensor

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    AAG Wind sensor

    Michael,

    I might have brought this up before. Is there anything I can do to calibrate the wind speed on the 1-Wire AAG wind instrument. The "inertia" makes for unrealistic wind speeds like above 50MPH to over 100MPH.

    I am currently using a Temp08 and I believe Mitch has it set for 2.49 revs to give me the numbers.

    Would I be better off moving the wind instrument to the 9097 1-wire device instead of the Temp08?

    I am currently running MCS Temperature with a Temp08 and MCSXAP with the mcsXapTemp0x and the mcsXap1-Wire plugin.
    - Pete

    Auto mator
    Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.12.X
    Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.12.X
    HS4 Pro - V4.1.7.0 - Ubuntu 18.04/VB W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono 6.12.x
    HS4 Lite -

    X10, UPB, Zigbee, ZWave and Wifi MQTT automation. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

    #2
    I doubt if it is an inertia problem, but it could be false ringing on the counter input. xapmcs1Wire and mcsTemperature count for 15 seconds for gust and the defined sample interval for speed. I believe Temp08 uses 60 seconds for gust otherwise the same. Changing interfaces will likely not help, but removing the cause of the false counts will.

    Comment


      #3
      Actually this is one of two AAG devices which have always had the same issues.

      So its time to remove the AAG Device then eh?

      I was just looking at the Davis 6250.
      - Pete

      Auto mator
      Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.12.X
      Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.12.X
      HS4 Pro - V4.1.7.0 - Ubuntu 18.04/VB W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono 6.12.x
      HS4 Lite -

      X10, UPB, Zigbee, ZWave and Wifi MQTT automation. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

      Comment


        #4
        You can connect it to 9097U and then you can observe the counts, but I do not think it will actually change the results. This is assuming you do not have a bug in the version of Temp08 firmware you are running.

        Comment


          #5
          Its easy to change it over to one of the 9097U's. I have two Temp08's with two different FW's and one Temp05. I can also swap these.

          Here's what I see with the current one in place.

          22:48:52 | Wind Speed[3E00000001890D1D]=35 MPH, Gust = 35
          22:48:53 | Lightning #01[FC00000007C9371D]=12767,12789
          22:48:54 | Temp #01[CE0000007518D026]=72.71F
          22:48:56 | Temp #02[05000800084E9210]=32.45F
          22:48:57 | Temp #03[9600000014CAB326]=63.82F
          22:48:58 | Temp #04[DC00000014C88C26]=62.25F
          Here's a local WUN station:

          Speed / Dir 3.5 mph from ENEWind Gust 3.5 mph Health

          I was going to install one of the AAG's in FL with the Dockstar; but the one on the roof is acting the same as the one that I was going install there so its not probably worth doing this until I know if it'll work.
          - Pete

          Auto mator
          Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.12.X
          Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.12.X
          HS4 Pro - V4.1.7.0 - Ubuntu 18.04/VB W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono 6.12.x
          HS4 Lite -

          X10, UPB, Zigbee, ZWave and Wifi MQTT automation. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

          Comment


            #6
            as I recall, the AAG station had different versions... and I think, different # of poles with a resulting different method of counting. In my Weather Display program there is a way to identify which version it is and this affects the count.

            Comment


              #7
              The older AAG instruments used discrete posiiton measurement for Wind Direction. The next generation used resistor network and A/D. I believe Hobby-Boards has a new interface that I never trired to implement.

              Comment


                #8
                Mine is around 5 years old. Think its the gen before last. Wind speed though has always been excessive.
                - Pete

                Auto mator
                Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.12.X
                Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.12.X
                HS4 Pro - V4.1.7.0 - Ubuntu 18.04/VB W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono 6.12.x
                HS4 Lite -

                X10, UPB, Zigbee, ZWave and Wifi MQTT automation. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

                Comment


                  #9
                  Pete,

                  Try changing the sensor TYPe to Lightning and see what the raw counts are over time. You might simply need to re-locate the sensor. I found huge differences in wind speed readings around my house depending on where I placed the sensor and how high it was.

                  Mitch
                  http://www.midondesign.com

                  Comment


                    #10
                    Thank you Mitch. The weather sensor is located on a short mast attached to the chimney of the house. I can install a second AAG wind instrument on another section of the roof to give it a test.

                    I also have another Temp08 too. Right now the AAG is sitting on one Cat5 cable from the roof to the punch down block for the Temp08. 6-7 years ago put all of the Temp08 devices on their own Cat5E cables in a star shaped topology. The lightning, temperature and older AAG humidity sensors work well. This AAG wind speed device and the old wind speed device always had excessive speeds. As a comparison of the AAG to a local WUN station you can look for my weather station on WUN, Lockport, IL at Thunderhill. I list both the AAG and local one for comparision.

                    http://www.wunderground.com/webcams/...zz/1/show.html
                    Last edited by Pete; March 16, 2011, 10:14 AM.
                    - Pete

                    Auto mator
                    Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.12.X
                    Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.12.X
                    HS4 Pro - V4.1.7.0 - Ubuntu 18.04/VB W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono 6.12.x
                    HS4 Lite -

                    X10, UPB, Zigbee, ZWave and Wifi MQTT automation. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

                    Comment


                      #11
                      Mitch,

                      Switched AAG wind sensor to lightning sensor. I also reset counter to zero.

                      MCSTemperature wind speed hasn't changed from last high of 52MPH an hour or so ago.
                      - Pete

                      Auto mator
                      Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.12.X
                      Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.12.X
                      HS4 Pro - V4.1.7.0 - Ubuntu 18.04/VB W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono 6.12.x
                      HS4 Lite -

                      X10, UPB, Zigbee, ZWave and Wifi MQTT automation. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

                      Comment


                        #12
                        That is correct. No new wind speed information is being received. You can now look at the lightning sensor to see the coulds change. They really will not be useful other than getting a sense if the counts over an update interval are was you expect based upon the wind over this same interval.

                        Comment


                          #13
                          So I can't really utilize the lightning counts for wind speed in MCSTemperature; eh?
                          - Pete

                          Auto mator
                          Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.12.X
                          Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.12.X
                          HS4 Pro - V4.1.7.0 - Ubuntu 18.04/VB W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono 6.12.x
                          HS4 Lite -

                          X10, UPB, Zigbee, ZWave and Wifi MQTT automation. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

                          Comment


                            #14
                            No. It can only be used to help with diagnostics.

                            The Temp08 will delliver either raw counts (Ligntning) or processed based upon counts/revolution (Wind Speed). The type defined by Temp08 setup is what mcsTemperature uses. No provisions for Lightning to Wind Speed conversion was done because Temp08 has this option already. mcsTemperature does do lightning to wattage or water flow.

                            The DS9097U will always deliver raw counts and then you tell mcsTemperature how to interprert those counts. One of those options is Wind Speed with calibration capability to deal with a variety of wind instruments.

                            Comment


                              #15
                              So I'll give the DS9097U a try tomorrow.

                              Disconnected the connection from the Temp08 and tried it on the other Temp08 and another Temp05. Same excessive wind speeds.

                              Right now have numerous devices on the two 9097's but now have more of the 9097's so going to try to connect the AAG instrument to a new 9097 that I purchased and see how it does on its own.

                              I had some issues with the USB driver (all of the instructions were in Chinese). I also decided to "test" the 9097 on another server. The driver just makes it a serial port; but I was already using 7 other ones such that the new driver was a bit sticky. I was able to test the USB 9097 with the Maxim 1-wire 9097 application and it is working fine. Next steps are to install the mcsXAP 1-wire application on the same box. I am currently running the mcsTemp0X on the box but its getting its serial connections via the LAN connected Quatech box.

                              I have to make up a new cable for the AAG 1-Wire device as the new 9097 USB 1-wire device only uses a pair of 3-wire mini plugs (voltage, ground and data).
                              Last edited by Pete; March 25, 2011, 01:20 PM.
                              - Pete

                              Auto mator
                              Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.12.X
                              Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.12.X
                              HS4 Pro - V4.1.7.0 - Ubuntu 18.04/VB W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono 6.12.x
                              HS4 Lite -

                              X10, UPB, Zigbee, ZWave and Wifi MQTT automation. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

                              Comment

                              Working...
                              X