Announcement

Collapse
No announcement yet.

Windows 7 x64 Install

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Windows 7 x64 Install

    In searching through the board I noticed it looks like people have been successful at getting mcsTemperature to work. I am not having the same luck and was wondering if someone could let me know which pieces and versions of sofware are needed? Drivers, MS JVM?, etc.

  • #2
    If you want to run 1-wire with it then you need MSJVM and the the DallasSemiconductor drivers "ftp://ftp.dalsemi.com/pub/auto_id/licensed/install_1_wire_drivers_v400.msi"
    If you want charts then you need the COM/ASP version of chart director which should be at "http://download.advsofteng.com/chartdir_com_win32.exe". It uses some VB6 controls such as Winsock. I believe I have a zip file on the ADIOcelot forum that contains the full collection of all controls that I have used in various plugins.

    Comment


    • #3
      When I try to install the v400 driver I get a message that says it is not compatible with 64-bit Windows. I tried to install it using compatibility mode but I still get he message and the install stops.

      Is there a way around this?

      Comment


      • #4
        I have never run HS / mcsTemperature on x64 so do not have any experience to know if there is a mechanism. I do know that once DallasSemiconductor went the route of the J/.NET rather than MSJVM for driver support the COM/ASP mechanism used by VB6/mcsSprinklers no longer worked. J/.NET is also obsolete as MS discontinued it as of .NET 2.0, but x64 was around when .NET 2.0 was active.

        Comment


        • #5
          If anyone is using mcsTemperature on Windows 7 x64 let me know.

          Michael, i guess my next choice is to go the mcsxap1wire route if no one has been successful?

          Comment


          • #6
            Windows 7 x64 working

            Originally posted by sforeman00 View Post
            If anyone is using mcsTemperature on Windows 7 x64 let me know.
            I got this to work correctly after playing around quite a bit. I think the problem lies in that 32 bit software by default installs into the "c:\Program Files (x86)\" folder. mcsTemperature doesn't seem to like that.

            I solved the problem by moving my entire HomeSeer installation to a folder called C:\HSPRO. Once all that is up and running, then install mcsTemperature. When the installer asks you where to put it, enter C:\HSPRO as the path. Make sure that it installs into the top level of that folder, not a subfolder as it seems to want to do. It will warn you that the directory already exists. That's normal.

            That seemed to get everything working for me. I have to assume that other plugins may have the same types of issues with the install location. My recommendation on any x64 system is to install into a folder other than Program Files (x86).
            HS Pro 3.0 | Linux Ubuntu 16.04 x64 virtualized under Proxmox (KVM)
            Hardware: Z-NET - W800 Serial - Digi PortServer TS/8 and TS/16 serial to Ethernet - Insteon PLM - RFXCOM - X10 Wireless
            Plugins: HSTouch iOS and Android, RFXCOM, BlueIris, BLLock, BLDSC, BLRF, Insteon PLM (MNSandler), Device History, Ecobee, BLRing, Kodi, UltraWeatherWU3
            Second home: Zee S2 with Z-Wave, CT101 Z-Wave Thermostat, Aeotec Z-Wave microswitches, HSM200 occupancy sensor, Ecolink Z-Wave door sensors, STI Driveway Monitor interfaced to Zee S2 GPIO pins.

            Comment

            Working...
            X