No announcement yet.

problem adding 1WIO

  • Filter
  • Time
  • Show
Clear All
new posts

    problem adding 1WIO

    Hi Michael,

    I've been using mcsTemperature with a TEMP08 for 2 years now, mostly without issues. I recently added a 1WIO to my TEMP08...and with hyperterm, can turn each relay on and off.

    But I can't get mcsTemperature configured to see the 1WIO. Here's what I see in the HS log (sensor 5 is my new 1WIO device) :
    <table border="0" cellpadding="0" cellspacing="2" width="100%"> <tbody><tr><td colspan="1" class="LOGDateTime0" align="left" nowrap="nowrap">9/11/2011 6:53:11 PM </td><td colspan="3" class="LOGType0" align="left"> mcsTemperature </td><td colspan="8" class="LOGEntry0" align="left">Temp05/08 Data: 05 CA00000001053329 DS2408 OK P{ 30 35 20 43 41 30 30 30 30 30 30 30 31 30 35 33 33 32 39 20 44 53 32 34 30 38 20 4F 4B 20 50}</td></tr> <tr> <td colspan="1" class="LOGDateTime1" align="left" nowrap="nowrap">9/11/2011 6:53:11 PM </td><td colspan="3" class="LOGType1" align="left"> mcsTemperature </td><td colspan="8" class="LOGEntry1" align="left">Process DIS Command: on line 70 Subscript out of range</td></tr></tbody> </table>
    I never see the sensor in the sensor page. I tried playing around with checking the RELAY05 box -- do I need to do that to use a 1WIO? In either setting, the problem still remains. Any info on how to configure mcsTemperature for 1WIO would be helpful.

    Happy to provide you my .ini and debug log files if needed.


    Relay05 should not be checked. It is a different unit. There is one or more threads on 1WIO in the mcsTemperature subforum where I worked with those who had this hardware. Review these as that will be the best source of information. Also look at the change log at the top of this subforum to assure that you are running a version of mcsTemperature that has incorporated changes for this hardware.