No announcement yet.

Cannot access plug-in (may need to be re-installed): HSPI_MCSTEMPERATURE.HSPI

  • Filter
  • Time
  • Show
Clear All
new posts

    Cannot access plug-in (may need to be re-installed): HSPI_MCSTEMPERATURE.HSPI

    Am doing a fresh install of HS2 and upgrading to MCSTemp ver 6 from ver 4 - hopefully it won't hurt too much

    First hurdle is this message right after installation/restart.

    Cannot access plug-in (may need to be re-installed): HSPI_MCSTEMPERATURE.HSPI - Object variable or With block variable not set.

    What happened or didn't happen?

    Am running Windows 7 32 bit and HS ver

    By the way, should I install the version 4 ocx (by over writing ver 6 ocx) which my current HS config and mcstemperature.mdb will recognize then upgrade to 6, or just go to ver 6 and hope my existing events all recognize the new version?


      I suspect you have not registered the .ocx. You really should use the updater to install mcsTemperature and then its installer will do whatever is needed. It has been too long since Version 4 to know what issues may occur. There is logic added to the plugin to make automatic upgrades when version changes occur, but it expects some form of orderly migration and may not be able to bridge two major versions. With V6 you will not longer have form setup that is supported. Only browser setup has been maintained.


        so I used the installer (again) to try to re-install MCS Temp. Downloaded successfully, gave me the message to restart HS, did that, got the install messages from the plug-in at restart, said to put MCS Temp in the HS directory (default path in my case) and got the same message again once I restarted HS

        What now?


          I would mention that there's no hspi_mcstemperature.ocx file under HS directory, any of it's sub directories, or anywhere on my hard drive for that matter... ?!

          edit: looks like ocx files aren't used anymore. there is a hspi_mcstemprature.exe file in HS directory but certainly no *.hspi file anywhere on my hard drive.
          Last edited by johnnyt; March 23, 2012, 08:25 AM.


            hspi_mcstemprature.exe is the plugin and it was developed with VB6. There will be no .HSPI. HS is trying to access the plugin as if it was .NET. The process is updater to download, HS restart to run mcsTemperature installer. This will register the .exe. Restart HS to recognize the plugin. Activate the plugin via HS Setup Interfaces. The red text is from HS. My best guess is that it is not registered when HS was started, but dont know exactly what HS is trying to do that produces the message.


              Originally posted by Michael McSharry View Post
              Activate the plugin via HS Setup Interfaces.
              It doesn't show up in the setup interfaces tab for me to activate.


                Sounds like it's not installing into the correct directory. What directory did you install HomeSeer into?


                  am using all the defaults along the way.

                  Tried uninstalling and re-installing, making sure to "Run as administrator" everything involved that has an exe to run...

                  Am getting the same error with usbpowerlinc but not with ISY Insteon or RCS Serial Thermostat


                    Various versions of Homeseer install, by default, in different folders. mcsTemperature installs by default in just one location. It is likely you cannot use the defaulf for the version of HS you have installed. Try installling it again and pay attention to the prompts asking for where it should be installed. It should be installed in the same location as Homeseer is installed.


                      HS and hspi_mcstemperature.exe both got installed to C:\Program Files\HomeSeer HS2. The plug-in installer even said something like "directory already exists, are you sure you want to copy files there?" to which I said clicked yes.

                      I have tried another full install going back first to an image I made before installing HS the first time, in case something got mucked up on the way.

                      no joy.


                        After all that farting around I thought what if I just turn off Windows UAC and now I can see the plug-in!

                        Argh, is that all I needed to do? Why isn't that clear in the installation dialogue or sticky?

                        I did get the following "info" message the first startup but not on subsequent start up:

                        ~!~Info~!~HS Compatibility, cannot access plug-in HSPI_MCSTEMPERATURE.HSPI ActiveX component can't create object

                        Hopefully not a problem waiting to happen later?

                        Seems to work now but it hasn't been running long and I haven't tried to point it to my old database and HS config file yet.