Announcement

Collapse
No announcement yet.

errors after transferring installation to pro-100

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • errors after transferring installation to pro-100

    I have recently transferred my HS installation from a pc to a pro-100. 95% of the plug-ins are working. mcsSprinklers seems to be doing fine. I am getting errors with mcsTemp concerning weather. I was asked to install chartdirector and I did that. I have copied the config files from the old installation and tried to catch all the HS install directory changes and correct them.

    Here are some of the errors I am getting:

    3/4/2013 5:48:40 PM mcsTemperature WeatherXML on line 710 Object variable or With block variable not set
    3/4/2013 5:48:40 PM mcsTemperature TCPClient GetURL1 http://image.weather.com/web/maps/sa...at_277x187.jpg on line 40 Component 'msinet.ocx' or one of its dependencies not correctly registered: a file is missing or invalid

    3/3/2013 8:01:20 PM Event Event Trigger "Weather XML"
    3/3/2013 8:01:20 PM Event Running script in background: weathercom_xml.txt
    3/3/2013 8:01:20 PM Error Running script, script run or compile error in file: weathercom_xml.txt424:Object required: 'oNode' in line 121 More info: Exception from HRESULT: 0x800A01A8

    Thanks for help in trouble-shooting this.

  • #2
    msinet.ocx was likely not bundled with XP embedded provided with your PRO100. There are a number of controls at the top of the ADIOcelot thread and it should be in there. Copy it to Windows System32 folder and use "regsvr32 msinet.ocx" to register it.

    Comment


    • #3
      Thanks, did that, got the files and registered them, got rid of the first error message, but still getting errors like

      3/5/2013 5:19:51 PM mcsTemperature WeatherXML on line 710 Object variable or With block variable not set

      and

      3/5/2013 4:01:20 PM Error Running script, script run or compile error in file: weathercom_xml.txt424:Object required: 'oNode' in line 121 More info: Exception from HRESULT: 0x800A01A8


      any ideas?

      Comment


      • #4
        When Weather.com changed their service to a pay rather than frree model a migration to other providers occurred. The WeatherXML package contains the provisions to write directly to the mcsTemperature database. You will be getting your weather using it rather than by mcsTemperature pulling it. There has been other discussion in this and the WeatherXML forum on the WeatherXML and mcsTemperature integration to provide specific setup information.

        Comment


        • #5
          Could you point me to the documentation or threads on how to set up mstemp with xmlweather? Thanks

          Comment


          • #6
            I would just go to the WeatherXML forum and do a search for mcsTemperature. There is no setup in mcsTemperature because WeatherXML now populates the mcsTemperature database directly. You should not have anything setup that directly mcsTemperature to pull Forecast data from any web site. This part is all done by WeatherXML.

            Comment


            • #7
              So you are saying that nothing should be populated on the forecast tab of mcstemp? All the blanks on forecast tab should just be empty, is that correct? Except possibly virtual devices in HS that I want included...

              Comment


              • #8
                This is all from memory, but I believe there are two things that you are interested in. One is what virtual devices are used to populate the weather display page. This is independent of collection of forecast data. The collection is controlled by settings that select a source. Your setup should be that no source is selected for mcsTemperature to collect data. If you want to use WeatherXML data in the weather display page then you would indentify the devices populated by WeatherXML in the virtual devices boxes that you referenced.

                Comment

                Working...
                X