Announcement

Collapse
No announcement yet.

Error attempting to display the Groups Web Page in mcsTemperature

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error attempting to display the Groups Web Page in mcsTemperature

    I just added about 10 new sensors (all from devices). I then attempted to enter the Groups screen in order to associate the devices to my sensor groups, and the page came up blank. When I looked at the HomeSeer log, I received the following message when attempting to bring up the Groups screen:

    1/5/2014 11:49:42 AM - mcsTemperature - FormatGroupScreen: on line 50 Item cannot be found in the collection corresponding to the requested name or ordinal.

    Can anyone tell me what might be happening here? Any assistance would be greatly appreciated.

  • #2
    The referenced line has to do with the sort order of the records in the display. It is obtained from Config\mcsTemperature.ini. In the example below it is set to Name. You apparently have an invalid entry here. The current source code should not generate an error as it checks for this situation explicitly. You should be able to edit the mcsTemperature.ini to include the value as below. If you have an older version of mcsTemperature then you have the option to get later version.

    [Temperature]
    SortOrder=Name

    Comment


    • #3
      Michael,

      Thank you very much for your reply! I went into the .ini file, and it contained:

      SortOrder=Exclude

      I changed it to =Name, and all works well now!

      Thanks again!

      Comment

      Working...
      X