Announcement

Collapse
No announcement yet.

1-Wire setup using DS9097U

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    1-Wire setup using DS9097U

    I'm trying to get temperature readings from my 1-wire setup. I am using the DS9097U and a temp sensor (DS80S20????)

    Here's what I've done...
    1. Installed Sun's Java
    2. Installed the TMEX drivers (Got message that said you must install the Microsoft Java Virtual Machine)
    3. Installed the 1-wire viewer (Will eventually use the xAP-1-wire plugin)
    No devices found.
    4. Installed the Microsoft Java Virtaul Machine
    5. Reinstalled the TMEX drivers (No message this time)
    6. Autodetected and it found the DS9097U on COM1
    7. Installed the 1-wire viewer (Will eventually use the xAP-1-wire plugin)
    No devices found. This time the viewer closed and I got a strange java error that was made as a link on my desktop.

    I would like to know the URL for the Java that I need and the URL for the TMAX drivers. (I think I might be downloading wrong versions.)

    Or maybe I'm hooking up the DS9097U wrong or the temp sensor wrong....(I looked up the pins for both sensor and DS9097U and connected them the way it said to.)

    Can anyone please help me?
    Thanks,
    Chris

    #2
    If you are running W2K then you already have the correct JavaVM. If you are using XP then there is no official link to the Microsoft JVM after Microsoft had to remove it to allow Sun a chance to compete. In the past I have found some bootleg sites. In my case it was a base install followed by a service pack type update to it.

    If the viewer can see the adapter, then the JavaVM needs to be working. There are, however, versions of the iButton viewer that use the TMEX drivers rather than the java wrapper around them. Same conclusion that if the adapter is seen then the sensors should also be seen if connected correctly.

    You can also just forget about the iButton viewer and run the 1-wire xap app. First thing to do is open the IO Comm window so you can view the traffic between the DS9097U and the PC. If nothing shows up in this window within the polling window you setup then I would look at the physical connection of the sensor to the adapter.

    Only 1 1-wire application can run at the same time. Dont try to have both open together.

    Comment


      #3
      You can always try the older Windows 1-wire viewer (with DS9097U drivers) ftp://ftp.dalsemi.com/pub/auto_id/licensed/tm321_32.exe No Java required...just to test the install.
      Jon

      Comment


        #4
        OK, here's what I did:
        1. Reinitialized HD and installed XP SP2
        2. Installed Homeseer
        3. Installed the older Windows 1-wire viewer (with the drivers)

        Still no go.

        The install autodetected the DS9097U-S09 on COM1 but the DS18S20 was still not detected in the viewer.

        Here's my pin connections using CAT5:

        DS9097U(left to right)
        empty, empty, White/Orange, Orange, Blue, White/Blue

        Tried this:
        White/Orange -> Outside pins of DS18S20
        Orange -> Middle pin of DS18S20

        and I tried this:
        White/Orange -> Middle pin of DS18S20
        Orange -> Outside pins of DS18S20

        I tried both the above using 2 different sensors to rule out a seonsor problem.
        Any ideas?

        Thanks,
        Chris

        Comment


          #5
          Chris,

          Take a look at my one-wire introduction at www.jon00.me.uk/onewireintro.shtml (site seems slow today - so you may need to refresh)???

          It gives the pin-out details there.
          Jon

          Comment


            #6
            Alright, finally got it to work. I think the problem was the crimp in the RJ11 jack that plugged into the DS9097U.

            Thanks for all of your help! I really appreciate it.

            -Chris

            Comment


              #7
              MS JVM not possible with XP SP2

              Michael,

              My homeseer machine is XP sp2 and does not have MS JVM installed.

              I don't understand how to use the old TMEX drivers with MCS Temperature.

              I have two device configured as 1-wire transceivers, 1 being a temp08 and the second being a "link" serial interface.

              I downloaded and installed the older drivers as recommended below as MS JVM is now not possible with sp2 installed as it runs in protected memory that the OS now strictly controls. ( This is a reaaly common problem for anyone running the combination above, and I cannot be the only one )

              Every time I tick the 9097U box in MCS Temperature it insists on installing the latest MAXIM drivers automatically which require MS JVM.

              How do I get around this, I have spent hours trying to fix this.

              Please help.

              Thanks

              Nick

              Comment


                #8
                If anyone need MSJAVA this links:
                http://www.plastronic.hu/uploads/msjavx86.exe
                and last update:
                http://www.plastronic.hu/uploads/MSJavWU.exe

                Comment


                  #9
                  All variants of my 1-wrie software uses the MS JVM. I had expected DallasSemi/Maxim to recomple their libraries with Sun JVM by this time. It has not happened. There have been two beta updates of the 1-wire libraries since the court rulling of JVM. These continue to use the old Microsoft JVM.

                  When I was using XP I was able to run with bootleg Microsoft JVM. I never installed SP2. I'm back in my comfort zone with W2K and only running XP on the computer that is being used for HS2 testing.

                  Comment


                    #10
                    follow up

                    This bugs me. Since I work at DS I contacted some people and asked why we don't fix this. This is the formal responce:

                    "Well sun didn't support COM objects and when compiling COM objects makes a bunch of .dll's."

                    Then they proceded to give me a couple of link to sites that I could get unsupported versions of MSJVM. I don't speak for Dallas Semiconductor but just though I would pass this on.

                    Comment


                      #11
                      It is good to know that it was intentional rather than just an oversight.

                      Someday W2K/XP will be as prevalent as Windoows 3.0/3.1 is today. There will be a new Language and Java will have gone by the wayside so it will all be a mute point.

                      Comment

                      Working...
                      X