Announcement

Collapse
No announcement yet.

Pulse script question...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Pulse script question...

    HS3 Standard Edition 3.0.0.258

  • #2
    The & in the body of your script should not be there. You do not need the script, you only need to include this one line in the event tab rather than the name of the script. Either the & without the script or no & in a script.

    The pulse was added to handle the case where HS becomes non-responsive. If it is healthy enough the schedule the event every 2 minutes then it should be good enough to do other things. If it fails to do this then GA will take the recovery action. Similiar to when HS goes to 100% for long periods of time.

    Comment


    • #3
      Attached Files
      HS3 Standard Edition 3.0.0.258

      Comment


      • #4
        I think it should be in the next tab over in "Scripts/Speech".

        Comment


        • #5
          Jeff is correct, it goes in the same place as you name of your script file. It is just a 1-line script and that is indicated on this tab by using the & prefix.

          I also noticed that you have smart quotes in the line. They should be the old fashion ones used by textpad rather than the ones used by Word. The smart ones point to the left and right while the ones that you want point up and down.

          Comment


          • #6
            Attached Files
            Last edited by Richard; February 17th, 2005, 08:37 PM. Reason: add graphic
            HS3 Standard Edition 3.0.0.258

            Comment


            • #7
              I just edit the HS GUI box directly. I will delete the character before, the quote and character after the quote then use the keyboard to retype the three characters. The only way I know to get smart quotes is to cut and paste from a Word document.

              Comment


              • #8
                I ran into the same problem. I did copy / paste from your Help doc and then had to delete the Word quotes and retype them directly into HS field (HS2.0).

                I have noticed during some HS2.0 manual shutdown attempts, that HS stops shutting down due to some reason (probably a beta bug). When this happens, CPU shows homeseer.exe to be using 49 - 50% CPU. This is on a Hyperthreading PC XPPro. Should Guardian Angel be set to kill app at 48% and not 95% for a hyperthread PC?

                Comment


                • #9
                  I suspect that 50% is the most any process will see so that rather than 100% will be the appropriate upper limit.

                  Not a good place for smart quote in the document.

                  Comment


                  • #10
                    I run this script:

                    PHP Code:
                    hs.launch hs.GetAppPath "\GuardianAngel.exe","homeseer.exe|90|120|homeseer.exe|c:\Program Files\Homeseer\Homeseer.exe|above_normal" 
                    Note: I typed the whole thing in Textpad to get rid of smart quotes.

                    I get this error message when I trigger the above script manually:

                    8/21/2005 9:39:09 PM - Error - Running script, script run or compile error in file: C:\Program Files\HomeSeer\scripts\Monitors\GuardianAngel.txt0: in line 0 More info: Unknown name.

                    In two minutes, I see a pop that says "Label1" and then a countdown to restart.
                    When the count is at zero, another pop up says "Homeseer is already running". The countdown resumes counting in a negative direction.

                    My understanding from the docs is that the above script will see if HS is running over 90% cpu for two minutes, and if so, will restart Homeseer. Being this PC is HS2.0 1955 on XPPro all service pack updates, Hyperthreading On, I also tried 45% with same response.

                    I have HS2 installed to c:\program files\Homeseer\homeseer.exe

                    Am I getting this stuff right?
                    Thanx.

                    Comment


                    • #11
                      You would normally run GuardianAngel out of your startup folder becuase you do not want a new copy each time Homeseer starts. It looks like the error is from Homeseer' launch command. Dont know where a file .txt0 comes from

                      Comment


                      • #12
                        I looked again at your post and see that you are trying the sample from the Doc. The script that is being run is llikely one you generated to create the pulse file. The syntax appears to be incorrect for HS2 in this script.

                        I also evaluated GA under HS2 and what I tried worked except for restart of just Homeseer. When trying to start homeseer.exe a message box appears indicating that some bmp files are missing. I suspect this is related to the installer for HS2 getting into the middle of the startup.

                        I did make some changes so that pulse monitoring only occurs if a pulse file is present and may be some other things I ran accross. It is V1.3.2.

                        Comment

                        Working...
                        X