Announcement

Collapse
No announcement yet.

Cant get xapmcsHubConsole.exe to run

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cant get xapmcsHubConsole.exe to run

    Running windows 7 x32bit. Downloaded the .net hub from this page:
    http://board.homeseer.com/showthread.php?t=109125


    If i click on the exe nothing appears. If i click it again, it says xapmcshub.txt is in use. I look in task manager and i can see xapmcshub.exe is running - which I am able to end. But clicking on it again just does the same.

    the log file says:
    False 13/08/2013 11:09:49 | 13/08/2013 11:09:49 | xapmcsHub Hub Startup


    netstat -an shows nothing listening at UDP/3639

    I've tried on on another Win7x32 machine (my live homeseer box) and get the same thing - although that one does prompt to allow the program through the windows firewall. (My test machine has windows firewall switched off)


    I've also tried the service version, which appears to install but i cant find any service in service manager.

    Struggling to know what to test next.

  • #2
    I did a .NET xAP hub for use on Linux and I do have it running as a service on one of my XP embedded computers. The one that is mainstream and does both xAP and xPL is in the xap Library on this message board. It is a VB6 application with a tray user interface.

    If you want to go .NET then I suggest using the hubs provided by xFx on the UK sites.

    Comment


    • #3
      I'm getting confused now


      I originally downloaded the vb6 version and was getting mswinsck.ocx errors when starting up. I followed a few threads about registering what appeared to be a legacy driver into my windows 7 machine and wondered if i was using the wrong program, so then moved onto the .net versions.

      I'm following Bob Funke's installation instructions;
      "Install xapmcshub first. It should install without incident"
      And it makes no mention of winsock problems - so i wondered if i was using the wrong s/w

      So with a windows7 x32 machine I do indeed need the vb6 version and i need to register the mswinsck.ocx to get it working ? And do I also need to run in in windows XP compatibility mode (which i also saw mentioned in another thread).



      thanks..
      Last edited by ecuboss; August 13th, 2013, 09:49 AM. Reason: Added actual ocx filenames to help others searching

      Comment


      • #4
        Ok - Update;
        Searched my entire harddisk for the mswinsck.ocx file, found it on some of my old network hacking tools from years ago..


        File version 6.1.97.82
        Microsoft Winsock Control
        Product Version 6.01.9782
        Date modified 08/03/2004 23:00

        I copied the file to c:\windows\system32
        Run cmd box as administrator
        CD \windows\system32
        regsvr32.exe MSWINSCK.OCX

        Now the VB6 version works on my Windows 7 machine and I can see my mcs1wire plugin.

        Continuing...

        Comment


        • #5
          Needed to copy to different directory on my Win7 PC...

          In case someone else is having trouble doing this... In my case I needed to copy the mswinsck.ocx file to \windows\SysWOW64 for it to work on my Windows 7 system.

          Comment


          • #6
            The xFx-Evpress hub is also an option.
            Mike____________________________________________________________ __________________
            HS3 Pro Edition 3.0.0.548

            HW: Stargate | NX8e | CAV6.6 | Squeezebox | PCS | WGL 800RF, Rain8Net+ | RFXCOM | QSE100D | Vantage Pro | Green-Eye | X10: XTB-232, -IIR | Edgeport/8 | Way2Call | Ecobee3

            Comment

            Working...
            X