Announcement

Collapse
No announcement yet.

mcsxAP 3.0.0.35 State error?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • mcsxAP 3.0.0.35 State error?

    Hi Michael,

    There seems to be an issue with the STATE with mcsxAP.

    Any value less than 255 and the state remains 'off'. Sending a value of 255 sets the level to 255 and the state 'on'. The state remains on when setting an new level, and remains on until a level of 0 is sent. It then remains 'off' until a level of 255 is sent, no matter what other levels are in the mean time.

    This is from the device list page. This also occurs when running events.

    I have over 150 lighting devices and only use the 'levels' as a device. I don't want to double up and end up having to have both state and level devices.

    Any chance you could take a look at this?

    Thanks, Marty.
    iCore5 Win 10 Pro x64 SSD

    HS3 Pro Edition 3.0.0.435 Windows

    BLOccupied:,Device History:,Yamaha:,UltraMon3:,mcsXap:,Restart:,UltraNetatmo3:, UltraM1G3:,Ultra1Wire3:,BLBackup:,Harmony Hub:,DoorBird:,UltraECM3:,Nanoleaf 3P:,UltraRachio3:,Z-Wave:,SDJ-Health:,BLGarbage:,Blue-Iris:,Chromecast:,Pushover 3P:,EasyTrigger:

  • #2
    This is what I understand to be the desired operation of devices that are dimmable using the preset dim model of device operation. The maximum and minimum of the dim range are used to change the ON/OFF state of the device.

    Can you propose what behavior you would like to have for a device that has been accepted as a Level= device? HS2 has separate Value and State, while HS3 produces a status/state based upon a user-defined value status pairs.

    Comment


    • #3
      I'm pretty sure this 'issue' has just occurred with the update.

      I use mcsxAP for c-bus lighting via a UKUSA c-bus gateway. The mcsxAP plugin discovers a 'level' 'origin' and 'state' property for each c-bus light. I have accepted the level property as a HS device.

      Previously setting the device value (level) to any number between 1 and 255 inclusive would automatically include 'state=on' in the xap message. But now the state value only becomes on if the level is 255. So it seems any value between 0 and 255 has no effect on the state. Only 0 and 255 set the state to off and on respectively.

      So when I run an event to turn the bathroom lights on at dimmed level when motion is detected the lights won't come on as the xap message includes 'state=off'. Only if I set the level at full (255/255) does the light come on.

      I hope this helps explain the situation. Thanks for your assistance.

      Marty.
      iCore5 Win 10 Pro x64 SSD

      HS3 Pro Edition 3.0.0.435 Windows

      BLOccupied:,Device History:,Yamaha:,UltraMon3:,mcsXap:,Restart:,UltraNetatmo3:, UltraM1G3:,Ultra1Wire3:,BLBackup:,Harmony Hub:,DoorBird:,UltraECM3:,Nanoleaf 3P:,UltraRachio3:,Z-Wave:,SDJ-Health:,BLGarbage:,Blue-Iris:,Chromecast:,Pushover 3P:,EasyTrigger:

      Comment


      • #4
        Hmmmmmmm...looks like I'll have to look a little further into this. I'll have to retract my previous post as for some lights the correct state value is sent. Weird.
        Marty
        iCore5 Win 10 Pro x64 SSD

        HS3 Pro Edition 3.0.0.435 Windows

        BLOccupied:,Device History:,Yamaha:,UltraMon3:,mcsXap:,Restart:,UltraNetatmo3:, UltraM1G3:,Ultra1Wire3:,BLBackup:,Harmony Hub:,DoorBird:,UltraECM3:,Nanoleaf 3P:,UltraRachio3:,Z-Wave:,SDJ-Health:,BLGarbage:,Blue-Iris:,Chromecast:,Pushover 3P:,EasyTrigger:

        Comment


        • #5
          I do not think I have the latest mcsXap on my laptop so I will not be able to make a change until end of the month. I suspect what will end up being the solution is make it a user-option if they want the dimmable devices to operate with preset dim independent of the on/off state or have off be only for the unique value of 0 brightness.

          Comment


          • #6
            or have off be only for the unique value of 0 brightness.
            That would be awesome. It would certainly solve the problem.
            Thanks again, Marty
            iCore5 Win 10 Pro x64 SSD

            HS3 Pro Edition 3.0.0.435 Windows

            BLOccupied:,Device History:,Yamaha:,UltraMon3:,mcsXap:,Restart:,UltraNetatmo3:, UltraM1G3:,Ultra1Wire3:,BLBackup:,Harmony Hub:,DoorBird:,UltraECM3:,Nanoleaf 3P:,UltraRachio3:,Z-Wave:,SDJ-Health:,BLGarbage:,Blue-Iris:,Chromecast:,Pushover 3P:,EasyTrigger:

            Comment


            • #7
              Marty, good to find another C-Bus user making use of Michael's invaluable plugin. I've been having the same issues as you. I have a blind controller and it sets blind level base don dim level, so if I set my blinds to 128/255 then they should open half way, but because the state does not change to "on" they never open.

              I also notice that if I click the device "Off" button for CAPI control, it set's the level to 1/255 not 0/255

              Michael made some custom changes to the HS2 plugin based on a certain device type. I like the idea of a user-selectable choice between the two options. You do know that this will prevent a "restore to last dim level on "on" command" type functionality though right?

              In addition, have you managed to get predictable behavior from HSTouch and slider? I'd be curious to hear your experience.

              Gaz
              Last edited by beerygaz; February 19th, 2014, 06:52 AM.
              Author of Highpeak Plugins | SMS-Gateway Plugin | Blue Iris Plugin | Paradox (Beta) Plugin | Modbus Plugin | Yamaha Plugin

              Comment


              • #8
                Gaz,

                I too have blinds (using C-bus shutter relays). I haven't had time yet to configure them properly other than open and close. Did you need to set the 'operation times' in C-bus toolkit to get the DIM working at the right settings? Did you just time how long it takes for a full open/close travel? I still have a little tweaking to do in C-bus. And I still have to set up the DMX gateway for the RGB stuff (pool lights etc).

                Yep, I understand the significance of loosing the present dim levels. But to be honest I just set them in HS3 (when it works). I'm hoping Michael will be able to implement to option of any 'level' value > 1 making the 'state' attribute change to ON.

                I presume you are using the UKUSA gateway form Kevin?

                I haven't even started on HSTouch yet. We have a brand new build and there is still much to be done. I'll start on the user interface once I have all the device working properly in HS3.

                Keep in touch. It's great to have another C-bus user on the forums.

                Marty
                iCore5 Win 10 Pro x64 SSD

                HS3 Pro Edition 3.0.0.435 Windows

                BLOccupied:,Device History:,Yamaha:,UltraMon3:,mcsXap:,Restart:,UltraNetatmo3:, UltraM1G3:,Ultra1Wire3:,BLBackup:,Harmony Hub:,DoorBird:,UltraECM3:,Nanoleaf 3P:,UltraRachio3:,Z-Wave:,SDJ-Health:,BLGarbage:,Blue-Iris:,Chromecast:,Pushover 3P:,EasyTrigger:

                Comment


                • #9
                  My C-Bus units are set in "Level Translation Mode" where they translate a Dim level to a percentage of open. The blind motors have automatic stops set at fully open and fully closed with the C-bus units having a "failsafe" timeout just in case. To get the right dim levels to match the positions I did as you said, timed the open/close time and set the failsafe timer to that plus 2 seconds and then used a bit of trial and error to get the dim levels to match the blind positions I wanted.

                  I am indeed using Kevin's wonderful gateway, it's been so much easier than trying to write to C-Gate directly but clearly the C-bus -> xAp -> Homeseer translations have posed some challenges. I too would like to see an option where 0 = OFF and any value above 0 = ON and the level. That should get things working with HSTouch too, and allow a single command to control the lights (right now I have to send ON and level separately, which is a pain).

                  I'm not sure why 1 = OFF right now rather than 0 = OFF either.
                  Author of Highpeak Plugins | SMS-Gateway Plugin | Blue Iris Plugin | Paradox (Beta) Plugin | Modbus Plugin | Yamaha Plugin

                  Comment


                  • #10
                    Hi Michael,

                    I know you're a busy man. I'm still in limbo with the 'level/state' issue. I was wondering if you are working on the option of automatically sending 'state=ON' when the level is set to anything above 0?

                    Thanks, Marty.
                    iCore5 Win 10 Pro x64 SSD

                    HS3 Pro Edition 3.0.0.435 Windows

                    BLOccupied:,Device History:,Yamaha:,UltraMon3:,mcsXap:,Restart:,UltraNetatmo3:, UltraM1G3:,Ultra1Wire3:,BLBackup:,Harmony Hub:,DoorBird:,UltraECM3:,Nanoleaf 3P:,UltraRachio3:,Z-Wave:,SDJ-Health:,BLGarbage:,Blue-Iris:,Chromecast:,Pushover 3P:,EasyTrigger:

                    Comment


                    • #11
                      Yes I will provide that option. Just digging out from being away for three weeks.

                      Comment


                      • #12
                        3.0.0.36 has an option at the bottom of the setup page on how the state key should be managed for level changes.

                        Comment


                        • #13
                          Michael, thanks for this, it's working like a dream from the Web interface. However, HSTouch seems to be posing some challenges. I think this is related to the ControlUse implementation which is clear-as-mud to me.

                          In HST if I add a toggle button for the xap device, I get no results.
                          If I add a discreet "ON' and another "off" button I see the following CAPI commands in the log:


                          Mar-05 16:50:35 Device Control Device: C-Bus Office Office Downlights to On (2147483647) by/from: CAPI Control Handler
                          Mar-05 16:50:31 Device Control Device: C-Bus Office Office Downlights to Off (-2147483647) by/from: CAPI Control Handler

                          If I add a slider with min value 0 and max value 255 and then try to use the slider to adjust the device status nothing happens.

                          The slider reacts to "on" and "off" commands from the web interface, but if I change the level to 0 or 255 (or anything in-between) there is also no reaction.
                          Author of Highpeak Plugins | SMS-Gateway Plugin | Blue Iris Plugin | Paradox (Beta) Plugin | Modbus Plugin | Yamaha Plugin

                          Comment


                          • #14
                            Don't understand why these threads suddenly stop. Did someone answer you privately?
                            Did someone solve this for you beerygaz?

                            Comment


                            • #15
                              mcsxAP 3.0.0.35 State error?

                              Nope, I never heard back on this thread. Michael did say he'd do some more investigation into HSTouch integration but that was the last I heard.

                              Michael, if you're still following this thread, is there any news? It seems HSTouch thinks the range for these devices is way higher/lower than 0-255


                              Sent from my iPad using Tapatalk HD
                              Author of Highpeak Plugins | SMS-Gateway Plugin | Blue Iris Plugin | Paradox (Beta) Plugin | Modbus Plugin | Yamaha Plugin

                              Comment

                              Working...
                              X