Announcement

Collapse
No announcement yet.

mcsXap plugin for HS3 Window/Linux and jQuery

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • mcsXap plugin for HS3 Window/Linux and jQuery

    The Windows and Linux versions of mcsXap for HS3 have been merged into a single binary that can run on either platform. The version number sequence has been started at 3.0.0.50.

    This version also implements the HS3 clsPageBuilder with use of jQuery to provide user selection on setup without a save operation. This significantly reduces the time to make reinitialize after settings are changed. It now will run on Raspberry Pi without a timeout.

    There have been no changes made with respect to ControlUse, ValueStatusPairs or other aspects of the xAP - HS3 integration. I am open to making changes in this area as well, but need guidance as to what should be done to improve the operation.

    There was no intention to change any of the config or database content, but a good idea to create a backup because of the significant change from prior version.

  • #2
    I recently updated to XAP 3.0.0.50 and the plug in fails I get this error please help
    1/10/2015 9:47:54 PM ~!~Error~!~Initializing plug-in(1): mcsXap Instance::InitHW Could not load file or assembly 'System.Data.SQLite, Version=1.0.87.0, Culture=neutral, PublicKeyToken=db937bc2d44ff139' or one of its dependencies. The system cannot find the file specified.Startup Complete, 1 errors detected, check the log for more information.


    Thanks Ken
    HSPRO,HS3PRO, BLsecurity, , MCSxap, HSTouch Android, UltraGCIR, CM15a, USBUIRT, BLUSBUIRT, WIFIRGB, BLAB8SS, BLcontrol, BLGData, BLLAN,BLOccupied, BLRadar, BLVolume, iTunesDAAP, UltraGCIR3, Airplayspeak, BLalarm, BLbackup, BLLED, BLrandom, BLReminders, BLRF, BL Speech, Hyperion, IFTTT, KINECT, XBMC, MCSprinkers PRO, PHLocation, ULtrapioneer, Ultralog, ultraweatherbug, Z,troller, GC-100, GC WIFICC, GC-WIFI SERIAL, Nitrogen logic depth camera controllers,

    Comment


    • #3
      System.data.sqlite.dll will exist on a subfolder within HS3. mcsXap is expecting it in the HS3 root. Put a copy there. I have also attached a copy for your convenience.
      Attached Files

      Comment


      • #4
        Mike, putting it in the root folder breaks other plugins can th8s be updated
        HSPRO,HS3PRO, BLsecurity, , MCSxap, HSTouch Android, UltraGCIR, CM15a, USBUIRT, BLUSBUIRT, WIFIRGB, BLAB8SS, BLcontrol, BLGData, BLLAN,BLOccupied, BLRadar, BLVolume, iTunesDAAP, UltraGCIR3, Airplayspeak, BLalarm, BLbackup, BLLED, BLrandom, BLReminders, BLRF, BL Speech, Hyperion, IFTTT, KINECT, XBMC, MCSprinkers PRO, PHLocation, ULtrapioneer, Ultralog, ultraweatherbug, Z,troller, GC-100, GC WIFICC, GC-WIFI SERIAL, Nitrogen logic depth camera controllers,

        Comment


        • #5
          The version of system.data.sqlite.dll that my HS3 uses is 1.0.87.0 and that is the same one that mcsXap is using. Where is the conflict?

          Comment


          • #6
            Originally posted by Michael McSharry View Post
            The version of system.data.sqlite.dll that my HS3 uses is 1.0.87.0 and that is the same one that mcsXap is using. Where is the conflict?

            Sorry Mike,

            My error I copied the SQlite.interop.dll over instead of the system.data.dll that was where the issue was all is up and running fine now. I will report back if there are any issues

            Thanks for the quick response
            Ken
            HSPRO,HS3PRO, BLsecurity, , MCSxap, HSTouch Android, UltraGCIR, CM15a, USBUIRT, BLUSBUIRT, WIFIRGB, BLAB8SS, BLcontrol, BLGData, BLLAN,BLOccupied, BLRadar, BLVolume, iTunesDAAP, UltraGCIR3, Airplayspeak, BLalarm, BLbackup, BLLED, BLrandom, BLReminders, BLRF, BL Speech, Hyperion, IFTTT, KINECT, XBMC, MCSprinkers PRO, PHLocation, ULtrapioneer, Ultralog, ultraweatherbug, Z,troller, GC-100, GC WIFICC, GC-WIFI SERIAL, Nitrogen logic depth camera controllers,

            Comment


            • #7
              Mike,

              I spoke to soon putting this in the the HS3 root folder crashed the Jowihue plugin I beleive that these need to be in their oun sub directory in the Bin folder to avoid the conflict

              Cheers Ken
              HSPRO,HS3PRO, BLsecurity, , MCSxap, HSTouch Android, UltraGCIR, CM15a, USBUIRT, BLUSBUIRT, WIFIRGB, BLAB8SS, BLcontrol, BLGData, BLLAN,BLOccupied, BLRadar, BLVolume, iTunesDAAP, UltraGCIR3, Airplayspeak, BLalarm, BLbackup, BLLED, BLrandom, BLReminders, BLRF, BL Speech, Hyperion, IFTTT, KINECT, XBMC, MCSprinkers PRO, PHLocation, ULtrapioneer, Ultralog, ultraweatherbug, Z,troller, GC-100, GC WIFICC, GC-WIFI SERIAL, Nitrogen logic depth camera controllers,

              Comment


              • #8
                I thought I had already provided a .config file, but it looks as if it needs to be updated. Put the attached in the HS3 root. When mcsXap starts it will look in \bin where HS3 puts the .dll.
                Attached Files

                Comment


                • #9
                  Thanks Mike,

                  That got it all running again

                  Cheers Ken
                  HSPRO,HS3PRO, BLsecurity, , MCSxap, HSTouch Android, UltraGCIR, CM15a, USBUIRT, BLUSBUIRT, WIFIRGB, BLAB8SS, BLcontrol, BLGData, BLLAN,BLOccupied, BLRadar, BLVolume, iTunesDAAP, UltraGCIR3, Airplayspeak, BLalarm, BLbackup, BLLED, BLrandom, BLReminders, BLRF, BL Speech, Hyperion, IFTTT, KINECT, XBMC, MCSprinkers PRO, PHLocation, ULtrapioneer, Ultralog, ultraweatherbug, Z,troller, GC-100, GC WIFICC, GC-WIFI SERIAL, Nitrogen logic depth camera controllers,

                  Comment


                  • #10
                    @Michael,

                    Here goofing around installed the xAP plugin on my Linux HS3 server. Just installed the exe and the configuration file.

                    Concurrently set up the old Temp0X connected to one serial Temp05 device and running the xAP hub on said wintel server.

                    On the Linux HS3 xAP GUI I see just HS3 xAP devices but no devices from the Wintel box.

                    Do I have to run something else on the Linux box?

                    Answering my own question. Running the hub...via mono xapmcshubconsole.exe and now seeing devices from the network on the GUI.

                    I am running on Ubuntu 64 bit 14.04 server. While I did configure a small footprint GUI; not using it much. Do I need to for the xAP hub?

                    So I picked one device which is a temperature sensor.

                    I see the value just fine coming from:

                    mcs.Temp0X.wintelbox:xapmcsTemp0x_Garage Temperature.8F000000F53A9926.Temperature
                    I am seeing the following in the HS3 console but not in the log. It doesn't stop and appears related to the HS3 xAP stuff.

                    "HSEvent: STRING_CHANGE
                    HSEvent: VALUE_CHANGE"

                    Is there a way to shut this off?

                    I tried to shut off the logging of the device and it didn't do anything to the console stuff.



                    Created a service to start the xap hub.

                    Upstart service saids its working but I do not see the hub on the network unless I start it manually after HS3 / xap plugin starts.

                    xFx message viewer version V4 never worked for me (thinking its a wierd dot net thing)

                    xFx message view version 3 works fine.
                    Attached Files
                    Last edited by Pete; January 22nd, 2015, 04:59 PM.
                    - Pete

                    Auto mator
                    Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU - Mono 6.4X
                    Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.4X

                    X10, UPB, Zigbee, ZWave and Wifi MQTT automation.

                    Comment


                    • #11
                      I am seeing the following in the HS3 console but not in the log. It doesn't stop and appears related to the HS3 xAP stuff.

                      "HSEvent: STRING_CHANGE
                      HSEvent: VALUE_CHANGE"

                      Is there a way to shut this off?

                      I tried to shut off the logging of the device and it didn't do anything to the console stuff.
                      I used the console for selective output during debugging. Did not think anybody would care what shows on the console. I can remove it on another update located at http://mcsSprinklers.com/MCSXAP_30053.zip

                      Created a service to start the xap hub.

                      Upstart service saids its working but I do not see the hub on the network unless I start it manually after HS3 / xap plugin starts.
                      I cannot help any with Linux scheduling. There should be no dependency between the hub and HS3/mcsXap. The hub should not care about user as long as it has permission to use sockets. Its role in life is to listen on port 3639 and then route anything received to other xAP applications on the same computer using localhost and a port which is broadcast by the xAP application in its heartbeat messages.


                      Was there any other question that you were not able to answer yourself?
                      Last edited by Michael McSharry; January 22nd, 2015, 05:25 PM.

                      Comment


                      • #12
                        Thanks Michael.

                        Will update with posted version.

                        Think I have the auto starting of the hub working now.

                        Was there any other question that you were not able to answer yourself
                        No
                        - Pete

                        Auto mator
                        Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU - Mono 6.4X
                        Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.4X

                        X10, UPB, Zigbee, ZWave and Wifi MQTT automation.

                        Comment


                        • #13
                          Originally posted by Pete View Post
                          xFx message viewer version V4 never worked for me (thinking its a wierd dot net thing)

                          xFx message view version 3 works fine.
                          Sorry late to the party - I was just reading this thread as trying HS3 with xAP on my Pi2. Just sorting out the hub autostart as running it via mono from the autostart_hs file prior to the HSConsole start causes HS3 not to start up correctly. Anyway starting it manually afterwards seems to work OK.

                          Your experience with xFX Viewer v4 is likely because V4 requires a xAP hub be present on the same machine otherwise it will not display any messages.

                          V3 used to pinch the xAP port 3639 during startup and so worked without a hub but consequentially stopped any other (later launched) xAP applications from working. This was bad practice, and although easier when xFX Viewer was the only app running it was remedied in V4. So if you install the xFX Express Hub I suspect V4 will leap into life for you. Every device running xAP should have a xAP hub running on it.

                          Kevin

                          Comment


                          • #14
                            mcsxap error

                            Hi Michael,
                            I'm using version 3.0.0.50 of your plugin. It's one of the most valuable plugins I use. It connects to WebControl boards (via xapmcswebcontrol) and my C-Bus gateway (UKUSA Cbus/xAP gateway).

                            Lately I have been getting the following error in my HS Log:

                            Jun-24 11:50:16 a.m. mcsXap ProcessMessage New Line 0 Index was outside the bounds of the array.
                            Jun-24 11:50:16 a.m. mcsXap ProcessMessage New Line 0 Index was outside the bounds of the array.
                            Jun-24 11:50:16 a.m. mcsXap ProcessMessage New Line 0 Index was outside the bounds of the array.
                            Jun-24 11:49:54 a.m. mcsXap ProcessMessage New Line 0 Index was outside the bounds of the array.
                            Jun-24 11:49:53 a.m. mcsXap ProcessMessage New Line 0 Index was outside the bounds of the array.
                            When this happens the device status on HS does not update. Turning lights on or off via the Cbus wall switch has no effect on the device status in HS. Controlling devices via HS effects a change (i.e. the light actually turns on or off) but the device status is HS remains unchanged.

                            A reboot of the HS machine fixes the problem. It happens about once a week at random times. I'm not sure what the cause of it is. I have updated HS the version 3.0.0.187.

                            Any ideas on what the source of the problem could be?

                            Thanks, Marty.
                            iCore5 Win 10 Pro x64 SSD

                            HS3 Pro Edition 3.0.0.435 Windows

                            BLOccupied:,Device History:,Yamaha:,UltraMon3:,mcsXap:,Restart:,UltraNetatmo3:, UltraM1G3:,Ultra1Wire3:,BLBackup:,Harmony Hub:,DoorBird:,UltraECM3:,Nanoleaf 3P:,UltraRachio3:,Z-Wave:,SDJ-Health:,BLGarbage:,Blue-Iris:,Chromecast:,Pushover 3P:,EasyTrigger:

                            Comment


                            • #15
                              Change UID

                              Hi Michael,

                              Where do I set the application portion of the xAP UID that HomeSeer uses - it defaults to 000D. I have two instances of the app running on different HomeSeer installs but they're both using that UID.

                              uid=FF.000D:0000
                              class=xap-hbeat.alive
                              source=mcs.XapHS3.HomeTrollerZeeS2

                              uid=FF.000D:0000
                              class=xap-hbeat.alive
                              source=mcs.XapHS3.HPServer1

                              Comment

                              Working...
                              X