Announcement

Collapse
No announcement yet.

xapmcsADIOcelot - ADIOcelot xAP Node

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    I sprinkled some log outputs around the communications areas. You should also turn on the Log Comm Errors checkbox to log the data received from the ocelot.
    Last edited by Michael McSharry; July 14th, 2006, 01:23 AM.

    Comment


    • #32
      I finally got it working! Thanks for you help. I am using a 32 port Comtrol Rocketport adapter. COM7 worked fine with the homeseer plugin and CMAX but not the xAP connector. To get it to work, I had to manually change COM7 to forcefully choose 9600bps. Apparently it did not like the Auto mode.

      Comment


      • #33
        Connecting to Ocelot

        I started the xAPmcsHub.exe, and it seems to work. Here's he log file.

        4/15/2007 7:02:12 PM | xapmcsHub Hub Startup 2228 at Line 0
        4/15/2007 7:02:13 PM | Backup Hub Process 2228 Starting as Primary Hub on port 3639 192.168.0.112 at Line 0

        However, when I right click on the systray icon, although the View Traffic option pops open a dialog box as expected, none of the other options does anything (System Config, System Status and Help -- clicking on each does nothing). So, I'm not really sure if it's truly working or not.

        That said, I went ahead and ran the xapmcsAdiOcelot.exe file, and it launches. After about 2 minutes, a blue icon shows up in the systray. I configure it with the GUI Setup option to use COM5 (leaving the Serial Com IP field blank), but it can't find the Ocelot. The log looks like this:

        15/2007 7:12:30 PM Unit Mappings:
        4/15/2007 7:12:34 PM Ocelot Timeout Expected: 3 Got: 0
        4/15/2007 7:12:34 PM Unit Mappings:
        4/15/2007 7:12:38 PM Ocelot Timeout Expected: 3 Got: 0
        4/15/2007 7:12:42 PM Ocelot Timeout Expected: 3 Got: 0
        4/15/2007 7:12:42 PM Unit Mappings:
        4/15/2007 7:12:46 PM Ocelot Timeout Expected: 3 Got: 0
        4/15/2007 7:12:46 PM Waiting for IO info from Ocelot
        4/15/2007 7:12:50 PM Ocelot Timeout Expected: 264 Got: 0
        4/15/2007 7:12:50 PM Waiting for IO info from Ocelot
        4/15/2007 7:12:54 PM Ocelot Timeout Expected: 264 Got: 0
        4/15/2007 7:12:54 PM Waiting for var info from Ocelot
        4/15/2007 7:12:58 PM Ocelot Timeout Expected: 264 Got: 0
        4/15/2007 7:12:58 PM Waiting for var info from Ocelot
        4/15/2007 7:13:02 PM Ocelot Timeout Expected: 264 Got: 0
        4/15/2007 7:13:03 PM Waiting for IO info from Ocelot
        4/15/2007 7:13:07 PM Ocelot Timeout Expected: 264 Got: 0
        4/15/2007 7:13:07 PM Waiting for IO info from Ocelot
        4/15/2007 7:13:11 PM Ocelot Timeout Expected: 264 Got: 0

        Incidentally the System Config and System Status options don't work from the mcsADIOcelot icon in the systray either (but the Browser and GUI setup options both work). When I exit the mcsADIOcelot.exe app and launch Cmax on com5, it works just fine. Per MadMax's suggestion, I checked on MS-Windows setting for Com5, and it has it set to 9600 baud, so that's not the problem either. Help!

        What am I doing wrong here?

        Comment


        • #34
          The System xxx tray options are future provisions for a unified UI for xAP nodes. They have no function at this time.

          It is not communicating with the ocelot. I would suggest using the Browser interface as that is the one I use. The windows forms were the original implemntation and have not had much use of late.

          Make certain CMAX is not running or anything else that is using the same port. I normally put a message to the log when the application opens the serial port. These "log" messages will typically be produced using the Homeseer.Event/Homeseer.Log message schema as xAP messages. I have an xapmcsWritelog application that makes it conventient to view these. The xapmcsADIOcelot should be current on the HS message board, but to be certain you can download the version at http://mcsSprinklers.com under xAP applications

          Comment


          • #35
            Originally posted by Michael McSharry View Post
            The System xxx tray options are future provisions for a unified UI for xAP nodes. They have no function at this time.

            It is not communicating with the ocelot. I would suggest using the Browser interface as that is the one I use. The windows forms were the original implemntation and have not had much use of late.

            Make certain CMAX is not running or anything else that is using the same port. I normally put a message to the log when the application opens the serial port. These "log" messages will typically be produced using the Homeseer.Event/Homeseer.Log message schema as xAP messages. I have an xapmcsWritelog application that makes it conventient to view these. The xapmcsADIOcelot should be current on the HS message board, but to be certain you can download the version at http://mcsSprinklers.com under xAP applications
            Michael, thanks for the quick reply and for helping to figure this out. The xapmcsadiocelot file I was using is identical to the one on your mcssprinklers.com site. I used the browser interface to set the com port to 5, but it still doesn't find the Ocelot. I know the Ocelot is working because when I launch the CMax utility, it finds it immediately. Then I exit CMAX and launch the xapmcsadiocelot executable but it can't find the Ocelot, so I know it's not a com port conflict. Any other ideas what this might be?

            I am so excited to be using your mcsxap framework but I'm so frustrated that I can't get it to find the ocelot. So close and yet so far! Thank you very much for the help.

            Comment


            • #36
              Originally posted by jerny View Post
              Michael, thanks for the quick reply and for helping to figure this out. The xapmcsadiocelot file I was using is identical to the one on your mcssprinklers.com site. I used the browser interface to set the com port to 5, but it still doesn't find the Ocelot. I know the Ocelot is working because when I launch the CMax utility, it finds it immediately. Then I exit CMAX and launch the xapmcsadiocelot executable but it can't find the Ocelot, so I know it's not a com port conflict. Any other ideas what this might be?

              I am so excited to be using your mcsxap framework but I'm so frustrated that I can't get it to find the ocelot. So close and yet so far! Thank you very much for the help.
              Michael, in trying to debug this problem, I tried the following:
              - started the xapmcsadiocelot app
              - watched as it timed out trying to find the ocelot
              - tried to start the cmax app
              - cmax bombed saying com5 was already in use
              - exited the xapmcsadiocelot app
              - tried starting cmax again; this time it worked

              So, I think this proves that the xapmcsadiocelot is trying to connect to the ocelot on com5, but something is preventing the connection. Does this help to debug the problem? Are there settings I can tweak to help the xapmcsadiocelot app to find the ocelot?

              Comment


              • #37
                I was never able to get the xAP Ocelot program to connect to my ocelot via direct com port attachment either. I was only able to get it to work with a serial ip interface. The strange thing is that the ADIOCelot Homeseer plugin worked fine with a direct attached ocelot.

                Comment


                • #38
                  Originally posted by madmax View Post
                  I was never able to get the xAP Ocelot program to connect to my ocelot via direct com port attachment either. I was only able to get it to work with a serial ip interface. The strange thing is that the ADIOCelot Homeseer plugin worked fine with a direct attached ocelot.
                  Madmax, thanks for the tip. I'm having the same issue -- works fine in the plug-in, but not with the xAP program. Would you please be kind enough to give me a pointer toward the serial IP interface. How would I go about setting that up? I assume that is some kind of software that creates a virtual IP address interface to a com port? Thanks

                  Comment


                  • #39
                    I looked at my current source and saw it was more current that the posted files. I must have fixed the local COM sometime in the past and not posted updates. It is posted now V2.0.55

                    Comment


                    • #40
                      COM still doesn't work

                      Originally posted by Michael McSharry View Post
                      I looked at my current source and saw it was more current that the posted files. I must have fixed the local COM sometime in the past and not posted updates. It is posted now V2.0.55
                      Hi Michael,

                      I just downloaded v2.0.55 and installed it, but no luck. The local com port connection still doesn't work. I went back to the HS plug-in, and that still works fine. I emailed offline with MadMax from this message board, and he has never been able to get it to work with a local COM port either, so I suspect something is wrong with the code. Any idea what the problem might be? It looks like there is some code overlap between the plug-in and the XAP module, so maybe you could cut/paste the COM port communications source code from the plug-in? I'm using v1.14.0.3 of the plug-in, and it works great, but the XAP support sure would be great!

                      Thanks,
                      Jeremy

                      Comment


                      • #41
                        When the application starts it generates an xAP Homeseer.Event/Homeseer.Log message that indicates what xAP port and what COM port are being used. What xAP messages do you get from it at startup?

                        I do run via IP, but this morning I made a COM8 connection and it connected fine and no communicaiton errors were generated to ocelot.log.

                        Comment


                        • #42
                          First 8 XAP messages from xapmcsadiocelot

                          Michael, I'm using Viewer to capture all the XAP messages on my PC. I then copy/pasted the first 8 messages after launching the xapmcsadiocelot program. Here they are. Does this leave any clues?

                          Incidentally, at this point I tried launching CMAX to control my Ocelot (which, incidentally has a SECU16-IR and a SECU16 attached to it), but when I try to connect CMAX to my Ocelot it says "Com Port 5 already in use." If I then Exit the xapmcsadiocelot application, the CMAX application will then connect to the Ocelot without a problem. Therefore, the xapmcsadiocelot program is clearly opening up com 5, but it's just not seeing the Ocelot. This causes me to wonder whether it's using the wrong com protocol (not n,8,1) or assuming some sort of strange flow control or something else?

                          ---

                          xap-header
                          {
                          v=12
                          hop=1
                          uid=FF00C700
                          class=Homeseer.Event
                          source=mcs.AdiOcelot.HOMESEER
                          }
                          Event.Log
                          {
                          type=xapmcsAdiOcelot
                          time=4/17/2007 9:29:30 PM
                          data=Using xAP port 32768
                          }

                          xap-header
                          {
                          v=12
                          hop=1
                          uid=FF00C700
                          class=Homeseer.Event
                          source=mcs.AdiOcelot.HOMESEER
                          }
                          Event.Log
                          {
                          type=xapmcsAdiOcelot
                          time=4/17/2007 9:29:31 PM
                          data=Version 2.0.55 Registered with Setup
                          }

                          xap-header
                          {
                          v=12
                          hop=1
                          uid=FF00C700
                          class=Homeseer.Event
                          source=mcs.AdiOcelot.HOMESEER
                          }
                          Event.Log
                          {
                          type=xapmcsAdiOcelot
                          time=4/17/2007 9:29:31 PM
                          data=Initializing X10 Interface on port 5
                          }

                          xap-header
                          {
                          v=12
                          hop=1
                          uid=FF00C700
                          class=Homeseer.Event
                          source=mcs.AdiOcelot.HOMESEER
                          }
                          Event.Log
                          {
                          type=xapmcsAdiOcelot
                          time=4/17/2007 9:29:33 PM
                          data=Using Comm Port 5
                          }

                          xap-header
                          {
                          v=12
                          hop=1
                          uid=FF00C700
                          class=Homeseer.Event
                          source=mcs.AdiOcelot.HOMESEER
                          }
                          Event.Log
                          {
                          type=xapmcsAdiOcelot
                          time=4/17/2007 9:29:36 PM
                          data=Ocelot Plug-in Error, Timeout looking for CPU-XA/Ocelot
                          }

                          xap-header
                          {
                          v=12
                          hop=1
                          uid=FF00C700
                          class=Homeseer.Event
                          source=mcs.AdiOcelot.HOMESEER
                          }
                          Event.Log
                          {
                          type=xapmcsAdiOcelot
                          time=4/17/2007 9:29:39 PM
                          data=Ocelot Plug-in Error, Timeout looking for CPU-XA/Ocelot
                          }

                          xap-header
                          {
                          v=12
                          hop=1
                          uid=FF00C700
                          class=Homeseer.Event
                          source=mcs.AdiOcelot.HOMESEER
                          }
                          Event.Log
                          {
                          type=xapmcsAdiOcelot
                          time=4/17/2007 9:30:05 PM
                          data=ReadSystemMap: No Project File has been specified
                          }

                          xap-header
                          {
                          v=12
                          hop=1
                          uid=FF00C700
                          class=Homeseer.Event
                          source=mcs.AdiOcelot.HOMESEER
                          }
                          Event.Log
                          {
                          type=xapmcsAdiOcelot
                          time=4/17/2007 9:30:09 PM
                          data=ReadSystemMap: No Project File has been specified
                          }

                          xap-header
                          {
                          v=12
                          hop=1
                          uid=FF00C700
                          class=Homeseer.Event
                          source=mcs.AdiOcelot.HOMESEER
                          }
                          Event.Log
                          {
                          type=xapmcsAdiOcelot
                          time=4/17/2007 9:30:17 PM
                          data=ReadSystemMap: No Project File has been specified
                          }

                          xap-header
                          {
                          v=12
                          hop=1
                          uid=FF00C700
                          class=Homeseer.Event
                          source=mcs.AdiOcelot.HOMESEER
                          }
                          Event.Log
                          {
                          type=Warning
                          time=4/17/2007 9:30:38 PM
                          data=Ocelot Plug-in, Timeout getting Vars
                          }


                          (By the way, that last message then repeats every 17 or 18 seconds thereafter.)

                          Comment


                          • #43
                            V2.0.56 should work for you. My testing before was with an emulated COM port (Lantronix Redirector) and the problem was masked because the emulation does not include the setup of the port. When I recabled to a real COM port I could see the problem.

                            Comment


                            • #44
                              Thank you x 1,000!!!

                              Eureka! It works!! Thank you very, very much, Michael.

                              Comment


                              • #45
                                Thanks Michael,

                                I know it is a total hassle to disconnect your setup for testing.

                                Comment

                                Working...
                                X