No announcement yet.

xapmcsADIOcelot - ADIOcelot xAP Node

This topic is closed.
  • Filter
  • Time
  • Show
Clear All
new posts

  • xapmcsADIOcelot - ADIOcelot xAP Node

    This is an xap connector for the ADI Ocelot. It supports three published Schema. One for IR, one for X10, and BSC for variables and iopoints. The operations are the same as the Homeseer ADIOcelot plugin.

    Note: this is a three-part download
    (1) xapmcsADIOcelot executable
    (2) support images and html help
    (3) Word Document

    Install each zip file into same folder of your choosing and maintain the folder structure contained in the zip file

    Revision Log
    PR1 2.0.0 Provide Web-based Setup & Internal Server for Status/Control
    PR2 2.0.0 Include Documention and Help link from application
    PR3 2.0.0 Integrate the System Map names for BSC message names
    PR4 2.0.0 Use System Map names for IR schema (or Location extension)
    PR5 2.0.0 Integate previous two setup screens
    PR6 2.0.0 Provide direct IP addressing of the serial port
    PR7 2.0.2 Replace spaces in names with underscore rather than null
    PR8 2.0.3 Create IR label file if not present
    PR9 2.0.4 BSC query for variables reports output.state so control buttons will be generatd
    PR10 2.0.5 X10 / BSC resond only when explicitly enabled
    PR11 2.0.5 Unique ID for signal only 10 rather than 16 characters
    PR12 2.0.25 General Updates, repost to current version
    PR13 2.0.43 Add local scripting support
    PR14 2.0.55 Update to current compile including local COM operations
    PR15 2.0.56 Physical COM port init incorrrect
    PR16 2.0.57 Zone 1..16 -> SECU16IR, 0,17+ -> Ocelot
    PR17 2.0.58 Zone 1 -> SECU16 0
    PR18 2.0.58 Include Zone in IR.Info ack messages
    PR19 2.0.59 Zone 16 does not go to SECU16IR
    PR20 2.1.22 SECU16I points missing on restart
    Attached Files
    Last edited by Michael McSharry; December 13th, 2015, 04:49 PM.

  • #2
    ocelot xap

    Thanks for posting this. I will try it this weekend. Good work on all of this xAP stuff.


    • #3
      xapmcsADIOcelot Documents

      This is part 2 of a 2 part package.
      Attached Files
      Last edited by Michael McSharry; November 9th, 2005, 01:52 AM.


      • #4
        xapmcsADIOcelot Reserved

        Previously 3 part post, now a 2 part one
        Last edited by Michael McSharry; November 9th, 2005, 01:54 AM.


        • #5
          Browser Setup Image

          Setup from GUI is still available. The browser view is second option.
          Attached Files


          • #6
            The web view also provide status and control of all the ocelot items
            Attached Files


            • #7
              I just tried setting up the xapmcsADIOcelot, but it isn't saving any of the settings. The ini files are staying at 0 bytes. Any ideas?


              • #8
                I just reposted with the version I'm currently running. Always changing so I have not been reposting. It is a 2-part post with the second one containing the document and help files.


                • #9
                  Thanks. I will try it when I get home tonight. Trying to get as many things converted to xap as possible. Are you aware of any xap modules that support the usb x10 interface adapter from smarthome?


                  • #10
                    I think I did one sometime back but never had anyone that want to evaluate it at that time. I'd have to go back and look at what its condition may be. I dont have the USB interface for X10 to test with myself.


                    • #11
                      Thank You.

                      I would love to test the usb xap for you if you can find it.

                      Well I tried the version you posted for the ocelot. The labels still don't show up in the ir webpage, even after doing the sync. Re-checked my system map and it is fine shows the ir names/labels. And this version doesn't show the secu16 I/O module now either, the previous one did.


                      • #12
                        Attached are my configuration files to play with. There are several IR labels and I do have the SECU16 that is operating as expected. While the data in my files are of no value to you, the format may shed some light. I do not thing the irlbl.cfg file is used. It seems like I changed some IR labels in the system map and reimported it not very long ago. I dont know if I had any special naming convetions that had to be followed. When I was documenting it I should have disclosed it if it was the case.
                        Attached Files


                        • #13
                          Thanks. Well it appears that I just had to be patient for my IR labels to show up, you must have a timer that writes out the config files once in a while, not real time. This morning they were all there.

                          But I can't get it to communicate properly with my ocelot, I get the following errors in the ocelot.log, repeated over and over.

                          11/10/2005 7:35:13 AM Ocelot Timeout Expected: 264 Got: 0
                          11/10/2005 7:35:13 AM Waiting for var info from Ocelot
                          11/10/2005 7:35:22 AM Ocelot Timeout Expected: 264 Got: 0
                          11/10/2005 7:35:22 AM Waiting for IO info from Ocelot
                          11/10/2005 7:35:26 AM Ocelot Timeout Expected: 264 Got: 0
                          11/10/2005 7:35:26 AM Waiting for IO info from Ocelot
                          11/10/2005 7:35:30 AM Ocelot Timeout Expected: 264 Got: 0

                          The CMAX utility is communicating on COM1, and the xapmcsadiocelot is configured for com1 also. Any ideas?? (Launching CMAX from inside xapmcsadiocelot, it isn't running at the same time otherwise.)



                          • #14
                            I dont know if I tested the cmax to xapmcsadiocelot transitions as cmax is someting that I rarely use. do a clean start without using cmax or manually go between the two to assure only one is running at a time. The message means that the basic handshake between the PC and ocelot is not occurring with communication problems at a relatively low level. There is a log output selection, but I do not think it will help much in this case.

                            There are no timers for the label definitions that I recall so there is something else going on that caused the behavior your described.


                            • #15
                              I just tried the following:

                              Start xapocelot - same errors in the log
                              Started CMAX - Attempted to connect to the controller - COm1 in use
                              Exited xapocelot
                              In CMAX Attempted to connect to the controller again - Worked just fine.

                              And ideas on what to look for?