Announcement

Collapse
No announcement yet.

xapmcsHub xAP/xPL Hub

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • xapmcsHub xAP/xPL Hub

    VB6 Hub
    --------
    PR1 1.0.1 Limit backup hubs to 1
    PR2 1.2.0 Provide full XPL<-->XAP routing
    PR3 1.2.1 Add xPL zwave.basic <-> xAP xapbsc translation
    PR4 1.2.2 Add hearbeat wraparound
    PR5 1.0.15.1 .NET interface selection option changed

    http://mcsSprinklers.com/xapmcsHub.zip


    .NET Hub
    ---------
    Provides heartbeat wraparound for mcsXap self-monitoring

    .NET xAP only Console hub http://mcsSprinklers.com/xapmcsHubConsole.zip
    .NET xAP only Service hub installer http://mcsSprinklers.com/xapmcsHubService.exe

    The .NET hub works with either Windows of Linux. In the Linux case the IP address is not detectable on autostart, but is detected when running from a login. To address this the behavior of the manual selection of the interface via Config/mcsXap.ini has been changed so that if an interface is specified it will be used unless there is another interface is detected. The example below would use 192.168.0.200 as the interface to listen for xAP traffic. Previously the specified interface would only be used if discovered during startup.

    Code:
    [Interface]
    InterfaceAddress=192.168.0.200
    BroadcastAddress=192.168.0.255
    Last edited by Michael McSharry; January 7th, 2017, 05:26 PM.

  • #2
    Automatic lauch of hub

    Hi,

    im tring to write a .bat file to launch the hub before homeseer.
    I tried something like this :

    start /B "C:\Program Files\Xap\xapmcsHub.exe"

    echo "START"

    start /B %HSREPERT%\homeseer.exe



    HS launches all right, but no hub !

    any idea ?

    regards
    claude

    Comment


    • #3
      I use .vbs files rather than batch files. It may be that batch files are not launched as the interactive user under windows, but this is just a guess. The file I have in my startup folder on the computer that has homeseer and several xAP applications is startup.vbs and contains the following

      Code:
      On error Resume Next
      Hubmcs = "D:\Program Files\XAP\xapmcsHub\xapmcsHub.exe"
      Applications = Array( _
        "-D:\Program Files\Homeseer\GuardianAngel.exe", _
        "-D:\Program Files\XAP\xapmcsWritelog\xapmcsWritelog.exe", _
        "D:\Program Files\Homeseer\Homeseer.exe", _
        "-D:\Program Files\XAP\xapmcsScript\Script\xapScript.vbs", _
        "D:\Program Files\XAP\xapmcsCM11A\xapmcsCM11A.exe", _
        "D:\Program Files\XAP\xapmcsUPB\xapmcsUPB.exe", _
        "D:\Program Files\XAP\xapmcsAdiOcelot\xapmcsAdiOcelot.exe", _
        "D:\Program Files\XAP\xapmcsW800\xapmcsW800.exe", _
        "D:\Program Files\Homeseer\xapmcsAudrey.exe", _
        "D:\Program Files\XAP\xapmcsDatabase\xapmcsDatabase.exe", _
        "D:\Program Files\XAP\xapmcsTemp0x\xapmcsTemp0x.exe", _
        "D:\Program Files\XAP\xapmcs1Wire\xapmcs1Wire.exe", _
        "D:\Program Files\Homeseer\xapmcsEnvironment.exe", _
        "D:\Program Files\XAP\xapmcsWeatherXML\xapmcsWeatherXML.exe", _
        "D:\Program Files\XAP\xapmcsWeatherAWS\xapmcsWeatherAWS.exe", _
        "D:\Program Files\XAP\xapmcsAudrey\xapmcsAudrey.exe", _
        "D:\Program Files\XAP\xapmcsVaux\xapmcsVaux.exe", _
        "D:\Program Files\XAP\xapmcsvoice\xapmcsVoice.exe", _
        "D:\Program Files\XAP\xapmcschart\xapmcschart.exe", _
        "D:\Program Files\XAP\xapEmailMonitor\MailMonitor.exe", _
        "D:\Program Files\XAP\xapEmailOSD\NewEmailOSD.exe", _
        "D:\Program Files\mcsSprinklers\mcsSprinklers.exe" _
                         )
      Const q = """"
      set oShell = createObject("Wscript.shell")
      
      oShell.Run q & Hubmcs & q
      
      Wscript.Sleep 10000 'wait for SQL to be ready
      
      'if settings file is corrupted then copy the master to replace it
      set fso = createObject("Scripting.FileSystemObject")
      fConfig = "D:\Program Files\Homeseer\Config\"
      set f = fso.getfile(fConfig & "settings.ini")
      if f.size < 5000 then
        set f = Nothing
        fso.DeleteFile fConfig & "settings.ini"
        fso.CopyFile fConfig & "settings_master.ini", fConfig & "settings.ini"
      end if
      set fso = Nothing
      
      
      for i = 0 to ubound(Applications)
          if left(Applications(i),1) <> "-"  then
              oShell.Run q & Applications(i) & q
          end if
      Next
      Last edited by Michael McSharry; December 4th, 2008, 03:06 PM.

      Comment


      • #4
        Xpl messages?

        Michael quick question.
        Your HUB app has Xap & Xpl listed. I am working on me Asterisk PBX and have enabled Xpl on the box. Will I be able to see the Xpl messages in your HUB viewer?

        I am tying to verify a heart beat from Asterisk.

        I do have the Xpl box checked. Just wanted to be sure that I would see Xpl messages.

        Thanks
        HS2 Environment
        Zotac 1.83 GHz Quadcore
        HomeSeer Way2Call
        Netiom-Xap board
        opnode 1-wire 1.2.7
        Plug-In's
        WeatherXML 1.0.0.32
        Pwr Link USB 1.0.0.13
        mcsTemp V6.2.0.14
        mcsXap V3.0.0.0/3.0.0.20
        IM Connector 4.87.2.5
        Sip Connector 2.56.2.4
        RFXCOM 15.0.0.22
        Odroid X2
        Asterisk 11.5.1
        FreePBX 2.11.0.42
        WebMin 1.720
        Xap Switchboard by Mi4

        There is no place Like 127.0.0.1

        Comment


        • #5
          mcsHUB view Xpl messages?

          Michael

          Not sure if its a port problem. Xap uses 3639 UDP port and Xpl uses 3865 UDP port

          I have a xpl hub and can see messages from Asterisk but not in your mcsHUB. I was hoping to use your mcsHUB so it might do some type of crossover and join the two networks Xpl & Xap.

          I am tring to use your HUB to get CID info out of my Asterisk box through Xpl.
          I can see a heart beat in a Xpl HUB I am testing with but not your mcsHUB.

          Let me know if this was ever working.

          Thank
          HS2 Environment
          Zotac 1.83 GHz Quadcore
          HomeSeer Way2Call
          Netiom-Xap board
          opnode 1-wire 1.2.7
          Plug-In's
          WeatherXML 1.0.0.32
          Pwr Link USB 1.0.0.13
          mcsTemp V6.2.0.14
          mcsXap V3.0.0.0/3.0.0.20
          IM Connector 4.87.2.5
          Sip Connector 2.56.2.4
          RFXCOM 15.0.0.22
          Odroid X2
          Asterisk 11.5.1
          FreePBX 2.11.0.42
          WebMin 1.720
          Xap Switchboard by Mi4

          There is no place Like 127.0.0.1

          Comment


          • #6
            The hub view traffic form has a checkbox for xPL. It some some simple mapping between xPL to xAP schema, but I do not know if I forwarded other schema. Is it your intention to put xPL schema through port 3639?

            Comment


            • #7
              Well I would like to convert the port your HUB recieves Xpl messages to Transmit Xap messages.

              1) mcsHUB recieves Xpl message on 3865
              2) mcsHUB displays Xpl message in viewer
              3) mcsHUB sends Xpl message out Xap port 3639 as is
              HS2 Environment
              Zotac 1.83 GHz Quadcore
              HomeSeer Way2Call
              Netiom-Xap board
              opnode 1-wire 1.2.7
              Plug-In's
              WeatherXML 1.0.0.32
              Pwr Link USB 1.0.0.13
              mcsTemp V6.2.0.14
              mcsXap V3.0.0.0/3.0.0.20
              IM Connector 4.87.2.5
              Sip Connector 2.56.2.4
              RFXCOM 15.0.0.22
              Odroid X2
              Asterisk 11.5.1
              FreePBX 2.11.0.42
              WebMin 1.720
              Xap Switchboard by Mi4

              There is no place Like 127.0.0.1

              Comment


              • #8
                hometech: you may want to try this: http://patrick.lidstone.net/haweb/html/asterisk.html it is a Xap to asterisk management interface connector so that you can use Xap from asterisk instead of just xpl... I am in the process of building and setting up a new asterisk box to migrate from my astlinux as it seems like astlinux isnt being developed as quick as id like im going to a full distro and plan to implement this package.
                -Christopher
                PerfecTemp - the Most advanced HVAC system I've ever Built - and its in my House

                Comment


                • #9
                  I saw that as well as a package from Greg Limings.
                  I have been tring to get it to run on my Asterisk box but no Joy.
                  When I try to start it up ./axc.pl& It is complaining about a Log file it cannot find . I will keep hacking at it . But yes I beleive it will be eases to just have Asterisk do Xap.

                  here is the ling to what I am tring to get going.
                  http://www.limings.net/xap/axc/
                  Last edited by HomeTech; January 21st, 2007, 03:22 PM.
                  HS2 Environment
                  Zotac 1.83 GHz Quadcore
                  HomeSeer Way2Call
                  Netiom-Xap board
                  opnode 1-wire 1.2.7
                  Plug-In's
                  WeatherXML 1.0.0.32
                  Pwr Link USB 1.0.0.13
                  mcsTemp V6.2.0.14
                  mcsXap V3.0.0.0/3.0.0.20
                  IM Connector 4.87.2.5
                  Sip Connector 2.56.2.4
                  RFXCOM 15.0.0.22
                  Odroid X2
                  Asterisk 11.5.1
                  FreePBX 2.11.0.42
                  WebMin 1.720
                  Xap Switchboard by Mi4

                  There is no place Like 127.0.0.1

                  Comment


                  • #10
                    I added the forwarding of all xPL and the reverse as well. Translation of X10.basic and Remote.basic is also still available. It is V1.2.0.

                    An xPL x10.basic to turn A1=ON will turn into the following xAP messages depending upon the checkboxes checked. Note that the source for xAP is 3 segments and for xPL it is 2 so I prefix with xpl.

                    When remote.basic is translated to xapbsc and there is more mumbo-jumbo that is done to make the syntax compliant with the protocols.

                    I can do other translations if there should be a need. These two are the ones that were being used by the xPL W800 node that I was using before I wrote my own one for xAP.

                    Code:
                    xpl-cmnd
                    {
                    hop=1
                    source=WMUTE-SENDER.CMDLINE
                    target=*
                    }
                    X10.BASIC
                    {
                    COMMAND=OFF
                    DEVICE=A1
                    }
                    Code:
                    xap-header
                    {
                        v=12
                        hop=1
                        uid=FF00FF00
                        class=X10.BASIC
                        source=xpl.WMUTE-SENDER.CMDLINE
                    }
                    X10.BASIC
                    {
                        command=OFF
                        device=A1
                    }
                    Code:
                    xap-header
                    {
                        v=12
                        hop=1
                        uid=FF00FF00
                        class=xap-x10.request
                        source=xpl.WMUTE-SENDER.CMDLINE
                    }
                    xap-x10.request
                    {
                        command=OFF
                        device=A1
                    }
                    Last edited by Michael McSharry; January 22nd, 2007, 06:08 PM.

                    Comment


                    • #11
                      Michael the updated mcsHUB app now does show and forward Xpl messages!

                      But I have seen somthing strange going on and I am not sure what starts it going But on the bottom right of the HUB viewer were it counts Received Forwarded & Duplicate messages it starts counting like crazy very fast count increasing. Then the HUB stops working at least thats what HS2 has in the log
                      it is no longer seeing the HUB.

                      I will see if I can tell what starts is going later today.
                      HS2 Environment
                      Zotac 1.83 GHz Quadcore
                      HomeSeer Way2Call
                      Netiom-Xap board
                      opnode 1-wire 1.2.7
                      Plug-In's
                      WeatherXML 1.0.0.32
                      Pwr Link USB 1.0.0.13
                      mcsTemp V6.2.0.14
                      mcsXap V3.0.0.0/3.0.0.20
                      IM Connector 4.87.2.5
                      Sip Connector 2.56.2.4
                      RFXCOM 15.0.0.22
                      Odroid X2
                      Asterisk 11.5.1
                      FreePBX 2.11.0.42
                      WebMin 1.720
                      Xap Switchboard by Mi4

                      There is no place Like 127.0.0.1

                      Comment


                      • #12
                        if you use the xAP viewer then you should be able to see if a specific message is getting looped.

                        I've been running with V1.2.0 in an xAP-only environment since yesterday and have not observed any such behavior. I suspect it is related to an xPL message.

                        In V1.1 xPL messages were only bridged to port 3639. In V1.2 they are also bridged to all 127.0.0.1 ports being manged by the hub. This allows both xPL and xAP to exchange information on the same computer.

                        Comment

                        Working...
                        X