Announcement

Collapse
No announcement yet.

HAI Plugin v1.0.0.15 Beta

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • HAI Plugin v1.0.0.15 Beta

    Changes in this version:
    --HAI interface now runs in its own thread.


    Note - if you had errors installing the previous version, remove your existing Root node. The Root node and all children will be rebuilt when the plugin starts up.

    If you were running fine before this version, there is no need to remove the Root node.

    Post any issues here...
    HS3Pro Running on a Raspberry Pi3
    68 Z-Wave Nodes, 174 Events, 326 Devices
    UPB modules via OMNI plugin/panel
    Plugins: Z-Wave, OMNI, HSTouch, weatherXML, EasyTrigger
    HSTouch Clients: 3 Android, 1 Joggler

  • #2
    Yup; runs fine on a previously configured (with INI file setup).

    From scratch though it will not let me go to the interface settings as it errors out.

    I can post the logs here as I enable the plugin if you want?
    - Pete

    Auto mator
    Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.8X
    Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.8X
    HS4 Pro - V4.0.9.0 - Ubuntu 18.04/W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono 6.8X
    HS4 Lite -

    X10, UPB, Zigbee, ZWave and Wifi MQTT automation. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

    Comment


    • #3
      Originally posted by Pete View Post
      Yup; runs fine on a previously configured (with INI file setup).

      From scratch though it will not let me go to the interface settings as it errors out.

      I can post the logs here as I enable the plugin if you want?
      Yeah, email them to me. Glenn and I worked together to find an issue with Zones, so I have a new version ready to release - I'd like to take a look at this issue to see if I can add it to this build.
      HS3Pro Running on a Raspberry Pi3
      68 Z-Wave Nodes, 174 Events, 326 Devices
      UPB modules via OMNI plugin/panel
      Plugins: Z-Wave, OMNI, HSTouch, weatherXML, EasyTrigger
      HSTouch Clients: 3 Android, 1 Joggler

      Comment


      • #4
        Tested the plugin new on another running HS3 Pro box with Linux. Prepped it with Mono, downloaded HS3 for Linux, un tarred it and ran it via dot go.

        Downloaded and installed fine. The unhandled exception below just repeats after I enabled the plugin. I disable it and the message goes away.

        Note the below logs are from an HS3 / Linux box that has not run the HAI plugin before.

        The other Linux box with a previous version of the plugin upgraded and ran fine with V.15.

        > 09:33:43:4127:[Info]->System connected to MyHomeSeer Service, waiting for acknowledge...
        09:33:51:7166:[Info]->System connected to MyHomeSeer Service successfully.
        09:35:56:7847:[Updater]->Starting download of updates
        09:35:56:7894:[Updater]->Downloading update: HAI
        09:35:59:7474:[Updater]->Update HSPI_HAI.exe downloaded successfully
        09:35:59:7485:[Updater]->Installing package HAI
        09:36:01:0521:[Updater]->Copying file: \usr\local\HomeSeer\HSPI_HAI.exe
        09:36:01:0616:[Updater]->Copying file: \usr\local\HomeSeer\HSPI_HAI.exe.config
        09:36:01:0671:[Updater]->Copying file: \usr\local\HomeSeer\Uninstall_HSPI_HAI.exe
        09:36:01:0729:[Updater]->Copying file: \usr\local\HomeSeer\HAI.Controller.dll
        09:36:01:0840:[Updater]->Extracting files from zip file: HAI_DLLs.zip
        09:36:01:3008:[Updater]->Extraction Complete.
        09:36:01:3019:[Updater]->Extracting files from zip file: /usr/local/HomeSeer/Updates3/HAIBETA 1.0.0.15/HAI_Config.zip Destination: /usr/local/HomeSeer/Config/
        09:36:01:3033:[Updater]->Extraction Complete.
        09:36:01:3052:[Updater]->Extracting files from zip file: HAI_Images.zip
        09:36:01:3489:[Updater]->Extraction Complete.
        09:36:01:3515:[Updater]->Install/Update of package HAI was successful.
        HAI Plugin v1.0.0.15
        Connecting to HomeSeer at 127.0.0.1:10400
        09:37:21:1197:[Info]->Plugin HAI has connected. IP:127.0.0.1:37642
        Connected to HS
        09:37:21:4123:[Warning]->Cannot find requested INI file: /usr/local/HomeSeer/Config/HAI.ini

        Unhandled Exception:
        System.IO.FileNotFoundException: Could not load file or assembly 'MySql.Data, Version=6.6.5.0, Culture=neutral, PublicKeyToken=c5687fc88969c44d' or one of its dependencies.
        File name: 'MySql.Data, Version=6.6.5.0, Culture=neutral, PublicKeyToken=c5687fc88969c44d'
        at System.Threading.Thread.StartInternal () [0x00000] in <filename unknown>:0
        [ERROR] FATAL UNHANDLED EXCEPTION: System.IO.FileNotFoundException: Could not load file or assembly 'MySql.Data, Version=6.6.5.0, Culture=neutral, PublicKeyToken=c5687fc88969c44d' or one of its dependencies.
        File name: 'MySql.Data, Version=6.6.5.0, Culture=neutral, PublicKeyToken=c5687fc88969c44d'
        at System.Threading.Thread.StartInternal () [0x00000] in <filename unknown>:0
        09:37:21:5312:[Info]->Plugin HAI with instance: has disconnected
        09:37:21:5579:[Plug-In]->Finished initializing plug-in HAI
        09:37:51:4747:[Warning]->I/O interface HAI is down, executable is not running, restarting ...
        HAI Plugin v1.0.0.15
        Connecting to HomeSeer at 127.0.0.1:10400
        09:37:53:0167:[Info]->Plugin HAI has connected. IP:127.0.0.1:37644
        Connected to HS
        09:37:53:3060:[Warning]->Cannot find requested INI file: /usr/local/HomeSeer/Config/HAI.ini
        Last edited by Pete; October 17th, 2014, 09:25 AM.
        - Pete

        Auto mator
        Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.8X
        Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.8X
        HS4 Pro - V4.0.9.0 - Ubuntu 18.04/W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono 6.8X
        HS4 Lite -

        X10, UPB, Zigbee, ZWave and Wifi MQTT automation. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

        Comment


        • #5
          I went to install it on a new HS3 for Linux box.

          Updater worked fine. I downloaded and installed plugin. Enabled plugin to configure it.

          Errored out not connecting.

          I am doing this in test mode from scratch as other users will probably try to install the plugin in this fashion.
          - Pete

          Auto mator
          Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.8X
          Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.8X
          HS4 Pro - V4.0.9.0 - Ubuntu 18.04/W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono 6.8X
          HS4 Lite -

          X10, UPB, Zigbee, ZWave and Wifi MQTT automation. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

          Comment


          • #6
            Yeah, that's not good. Will have to take a look and install on a fresh machine.

            Sent from my SCH-R970X using Tapatalk
            HS3Pro Running on a Raspberry Pi3
            68 Z-Wave Nodes, 174 Events, 326 Devices
            UPB modules via OMNI plugin/panel
            Plugins: Z-Wave, OMNI, HSTouch, weatherXML, EasyTrigger
            HSTouch Clients: 3 Android, 1 Joggler

            Comment


            • #7
              Got it working.

              1 - shut down HS3 Pro in Linux (testing on RPi)
              2 - copied contents of /Bin/HAI to /bin/HAI - NOTE: I did notice that the rest of the HS3 Pro stuff was installed in the little alpha character bin rather than the big alpha character Bin.
              3 - restarted RPi
              4 - enabled HAI plugin
              5 - configured plugin for panel
              6 - connected and plugin downloaded configuration from panel.

              Just seeing a "trouble" on AUX battery which I do not see when using PCA (see attached).
              Attached Files
              Last edited by Pete; October 25th, 2014, 08:43 AM.
              - Pete

              Auto mator
              Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.8X
              Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.8X
              HS4 Pro - V4.0.9.0 - Ubuntu 18.04/W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono 6.8X
              HS4 Lite -

              X10, UPB, Zigbee, ZWave and Wifi MQTT automation. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

              Comment


              • #8
                Ah. Thanks Pete. I need to modify the installation file to always use the lower case.

                Sent from my SCH-R970X using Tapatalk
                HS3Pro Running on a Raspberry Pi3
                68 Z-Wave Nodes, 174 Events, 326 Devices
                UPB modules via OMNI plugin/panel
                Plugins: Z-Wave, OMNI, HSTouch, weatherXML, EasyTrigger
                HSTouch Clients: 3 Android, 1 Joggler

                Comment


                • #9
                  Thanks Rob.

                  Are you still using your HP Touchpad?

                  I have left mine in HP OS mode and noticed sone announced changes.
                  - Pete

                  Auto mator
                  Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.8X
                  Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.8X
                  HS4 Pro - V4.0.9.0 - Ubuntu 18.04/W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono 6.8X
                  HS4 Lite -

                  X10, UPB, Zigbee, ZWave and Wifi MQTT automation. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

                  Comment


                  • #10
                    Yeah, it's still running on the wall. I loaded cyanogenmod 9 on it instead of hp os. My sister works for HP and still had a couple, but she left HP os on them.

                    Sent from my SCH-R970X using Tapatalk
                    HS3Pro Running on a Raspberry Pi3
                    68 Z-Wave Nodes, 174 Events, 326 Devices
                    UPB modules via OMNI plugin/panel
                    Plugins: Z-Wave, OMNI, HSTouch, weatherXML, EasyTrigger
                    HSTouch Clients: 3 Android, 1 Joggler

                    Comment


                    • #11
                      Thanks Rob. Yup here right now HP OS does all I need. So I might leave it there for the time being.
                      - Pete

                      Auto mator
                      Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.8X
                      Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.8X
                      HS4 Pro - V4.0.9.0 - Ubuntu 18.04/W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono 6.8X
                      HS4 Lite -

                      X10, UPB, Zigbee, ZWave and Wifi MQTT automation. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

                      Comment

                      Working...
                      X