Announcement

Collapse
No announcement yet.

Problem with Evohome Plugin - Problems with connecting to service

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem with Evohome Plugin - Problems with connecting to service

    Hi there,

    I installed your plugin and it started to work fine for half an hour. Had some issues with signing in to the service but somehow it started to work after I had logged in to the service through the web. After 30 minutes it stopped working with an error that it could not log in to the service. After a day where it still didn't work I have tried again lots of things and not sure what helped it to work again but it started to work again but after about 25 minutes it stopped again. I searched for log files but couldn't find them in the directory html/ as indicated in the logs

    Error: TCC login failure
    aug-26 10:05:33 PHEvoHome (TccPollLocation) Reauthenticating....
    aug-26 10:05:32 PHEvoHome (SysTimer) Elapsed
    aug-26 10:05:17 PHEvoHome (SysTimer) Elapsed
    aug-26 10:05:02 PHEvoHome (SysTimer) Elapsed
    aug-26 10:04:47 PHEvoHome (SysTimer) Elapsed
    aug-26 10:04:32 PHEvoHome (SysTimer) Elapsed
    aug-26 10:04:17 PHEvoHome (SysTimer) Elapsed
    aug-26 10:04:02 PHEvoHome (SysTimer) Elapsed
    aug-26 10:03:47 PHEvoHome (SysTimer) Elapsed
    aug-26 10:03:32 PHEvoHome (SysTimer) Elapsed
    aug-26 10:03:17 PHEvoHome (SysTimer) Elapsed
    aug-26 10:03:02 PHEvoHome (SysTimer) Elapsed
    aug-26 10:02:47 PHEvoHome (SysTimer) Elapsed
    aug-26 10:02:32 PHEvoHome (SysTimer) Elapsed
    aug-26 10:02:17 PHEvoHome (SysTimer) Elapsed
    aug-26 10:02:02 PHEvoHome (SysTimer) Elapsed
    aug-26 10:01:47 PHEvoHome (SysTimer) Elapsed
    aug-26 10:01:32 PHEvoHome (SysTimer) Elapsed
    aug-26 10:01:17 PHEvoHome (SysTimer) Elapsed
    aug-26 10:01:02 PHEvoHome (SysTimer) Elapsed
    aug-26 10:00:47 PHEvoHome (SysTimer) Elapsed
    aug-26 10:00:34 PHEvoHome (TccPollLocation) Reauthenticating....
    aug-26 10:00:32 PHEvoHome (SysTimer) Elapsed
    aug-26 10:00:16 PHEvoHome (SysTimer) Elapsed
    aug-26 10:00:01 PHEvoHome (SysTimer) Elapsed
    aug-26 09:59:46 PHEvoHome (SysTimer) Elapsed
    aug-26 09:59:31 PHEvoHome (SysTimer) Elapsed
    aug-26 09:59:16 PHEvoHome (SysTimer) Elapsed
    aug-26 09:59:01 PHEvoHome (SysTimer) Elapsed
    aug-26 09:58:46 PHEvoHome (SysTimer) Elapsed
    aug-26 09:58:31 PHEvoHome (SysTimer) Elapsed
    aug-26 09:58:16 PHEvoHome (SysTimer) Elapsed
    aug-26 09:58:01 PHEvoHome (SysTimer) Elapsed
    aug-26 09:57:46 PHEvoHome (SysTimer) Elapsed
    aug-26 09:57:31 PHEvoHome (SysTimer) Elapsed
    aug-26 09:57:20 PHEvoHome (GetRegistrationState) Called.
    aug-26 09:57:16 PHEvoHome (SysTimer) Elapsed
    aug-26 09:57:01 PHEvoHome (SysTimer) Elapsed
    aug-26 09:56:46 PHEvoHome (SysTimer) Elapsed
    aug-26 09:56:31 PHEvoHome (SysTimer) Elapsed
    aug-26 09:56:16 PHEvoHome (SysTimer) Elapsed
    aug-26 09:56:01 PHEvoHome (SysTimer) Elapsed
    aug-26 09:55:46 PHEvoHome (SysTimer) Elapsed
    aug-26 09:55:36 PHEvoHome (TccLogin) Internet connectivity test OK. TCC service may be down.
    aug-26 09:55:33 PHEvoHome (TccPollLocation) Reauthenticating....
    aug-26 09:55:31 PHEvoHome (SysTimer) Elapsed
    aug-26 09:55:16 PHEvoHome (StartDQThreads) Evo Location DQ thread started OK.
    aug-26 09:55:16 PHEvoHome (Startup) Finished at 09:55:16.834
    aug-26 09:55:16 PHEvoHome (StartDQThreads) Evo Device DQ thread started OK.
    aug-26 09:55:16 PHEvoHome (CreateDeviceLists) Finished.
    aug-26 09:55:16 PHEvoHome (CreateDeviceLists) Adding ZoneID [656206] to known zones list.
    aug-26 09:55:16 PHEvoHome (CreateDeviceLists) Adding ZoneID [656207] to known zones list.
    aug-26 09:55:16 PHEvoHome (CreateDeviceLists) Adding ZoneID [652019] to known zones list.
    aug-26 09:55:16 PHEvoHome (CreateDeviceLists) Adding ZoneID [652020] to known zones list.
    aug-26 09:55:16 PHEvoHome (CreateDeviceLists) Adding LocationID [600735] to polled locations list.
    aug-26 09:55:16 PHEvoHome (CreateDeviceLists) Adding ZoneID [652018] to known zones list.
    aug-26 09:55:16 PHEvoHome (CreateDeviceLists) Adding ZoneID [652021] to known zones list.
    aug-26 09:55:16 PHEvoHome (CreateDeviceLists) Adding SystemID [652022] to known systems list.
    aug-26 09:55:16 PHEvoHome (CreateDeviceLists) Account status device found with ref: 3263.
    aug-26 09:55:16 PHEvoHome (CreateDeviceLists) Called.
    aug-26 09:55:16 PHEvoHome (Startup) License state returned 0
    aug-26 09:55:16 PHEvoHome (Startup) Plug-In is registered.
    aug-26 09:55:16 PHEvoHome (GetRegistrationState) Called.
    aug-26 09:55:16 PHEvoHome (Startup) Database version is: 3
    aug-26 09:55:16 PHEvoHome (Startup) Database structure update not required.
    aug-26 09:55:14 PHEvoHome (Startup) Plug-in version is: 3.0.0.35
    aug-26 09:55:14 PHEvoHome (LoadPiSettings) SetpointDeviceMode is API.
    aug-26 09:55:14 PHEvoHome (LoadPiSettings) Recording of temperatures to db is ON
    aug-26 09:55:14 PHEvoHome (LoadPiSettings) UTC offset secs: 7200
    aug-26 09:55:14 PHEvoHome (LoadPiSettings) Database = C:\Program Files (x86)\HomeSeer HS3\Data\PHEvoHome\PHEvoHome.db3
    aug-26 09:55:14 PHEvoHome (LoadPiSettings) LogPath = html\PHEvoHome\Logs\
    aug-26 09:55:14 PHEvoHome (LoadPiSettings) ImagePath = images\PHEvoHome\
    aug-26 09:55:14 PHEvoHome (LoadPiSettings) HSAppPath = C:\Program Files (x86)\HomeSeer HS3
    aug-26 09:55:14 PHEvoHome LoadPiSettings Called.
    aug-26 09:55:14 PHEvoHome (Startup) Detected OS is Windows version 6.2.9200.0
    aug-26 09:55:14 PHEvoHome (Startup) System decimal separator used is [,]
    aug-26 09:55:14 PHEvoHome (Startup) Begins at 09:55:14.700
    Olof

  • #2
    It would appear that there have been some issues with availability of the TCC service over the last few days as I have seen similar connection issues here.

    The plug-in is set to stop polling the TCC service after 12 failed attempts which equates to approximately 1 hour (12 x 5 minutes). If this occurs the TCC Account Status device in HS3 will change to "Error Polling Disabled". Polling can be re-enabled by either using the button on this device or by re-starting the plug-in.

    Paul..

    Comment


    • #3
      Tried to re-enable but still not working. The website itself still works. A quick look on Twitter on TCC and found one person reporting it on 25th. Are you sure it is a service outage?

      Comment


      • #4
        Originally posted by olof View Post
        Tried to re-enable but still not working. The website itself still works. A quick look on Twitter on TCC and found one person reporting it on 25th. Are you sure it is a service outage?
        It's working fine here for me in the UK right now although there have been some service outages (at least that's what I think was the cause) over the last week or so.

        I will need some more information to investigate your issues. Please contact me by email paul dot huddlestone at gmail dot com

        Paul..

        Comment


        • #5
          Love that you've done this plug-in, but I've just downloaded the plug-in and am having a different sort of problem from Olof's when connecting to the service. The 'Discover System' button on the TCC Account tab is sending me to PayPal, not the Honeywell server. I'm sure that wasn't deliberate. On the General tab the 'Check for update' button is also connecting straight to PayPal.

          Michael

          Comment


          • #6
            Hmmm, just tried accessing the PI using Chrome instead of Explorer, and the Discover button worked as it should. I'd only retained Explorer because it seemed to be the browser that worked best with HS, but it looks like that isn't the case any more. Never seen such an odd glitch as that !

            Comment

            Working...
            X