Announcement

Collapse
No announcement yet.

Suddenly stopped connecting

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Suddenly stopped connecting

    Hi,

    In the last 2 days, the plugin has stopped to connecting to my fritz 7490.
    It has been working flawless for years so I realise it is something that Ive done .. but I cant for the life of me work it out.

    Im getting :

    Sep-07 2:32:30 PM FritzTR064 Failed to connect to FritzBox (Unable to connect to the remote server)
    Sep-07 2:32:19 PM FritzTR064 Failed to connect to FritzBox (Unable to connect to the remote server)
    Sep-07 2:32:08 PM FritzTR064 Failed to connect to FritzBox (Unable to connect to the remote server)
    Sep-07 2:31:57 PM FritzTR064 Failed to connect to FritzBox (Unable to connect to the remote server)
    Sep-07 2:31:46 PM FritzTR064 Failed to connect to FritzBox (Unable to connect to the remote server)
    Sep-07 2:31:35 PM FritzTR064 Failed to connect to FritzBox (Unable to connect to the remote server)
    Sep-07 2:31:24 PM FritzTR064 Failed to connect to FritzBox (Unable to connect to the remote server)

    in the HS3 Pro event log.

    Things I have checked :

    1) IP address is the same
    2) User name Im using "admin" is the same
    3) The password for admin is the same
    4) I have tried turning the firewall off, on the win10 server that HS3 runs on .. makes no difference
    5) I tried turning on General Debugging but got no more information in the log
    6) I tried connecting to Fritzbox from a web browser on the server with the above credentials and that works fine

    Any ideas what might be causing the errors ?

    Thanks,
    Glen.

  • #2
    Not really. Have you tried restarting the 7490?
    stefxx

    Comment


    • #3
      hire the sam

      Hi ,
      the same here.
      after update windows 10 professional.

      Event viewer:
      first:
      Fault bucket 120846307897, type 4
      Event Name: APPCRASH
      Response: Not available
      Cab Id: 0
       
      Problem signature:
      P1: conhost.exe
      P2: 10.0.16299.15
      P3: 4dbabb31
      P4: ConhostV2.dll
      P5: 10.0.16299.15
      P6: 9407c601
      P7: c0000005
      P8: 0000000000006404
      P9:
      P10:
       
      Attached files:
      \\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER7EF8.tmp.dm p
      \\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER7F58.tmp.WE RInternalMetadata.xml
      \\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER7F62.tmp.cs v
      \\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER7F82.tmp.tx t
       
      These files may be available here:
      C:\ProgramData\Microsoft\Windows\WER\ReportArchive\AppCrash_ conhost.exe_55914f9069c5feb7bf7d91ae7c1e2901b90937f_4ad80bba _121c8503
       
      Analysis symbol:
      Rechecking for solution: 0
      Report Id: 0d06064f-6ebe-449d-8ef1-aa2097cced8b
      Report Status: 268435456
      Hashed bucket: f8bf9dd6b32e98de0b4aae4fc2f96cdd

      Then:
       

      Application: HSPI_FritzTR064.exe
      Framework Version: v4.0.30319
      Description: The process was terminated due to an unhandled exception.
      Exception Info: System.IO.IOException
      at System.IO.__Error.WinIOError(Int32, System.String)
      at System.IO.__ConsoleStream.Write(Byte[], Int32, Int32)
      at System.IO.StreamWriter.Flush(Boolean, Boolean)
      at System.IO.StreamWriter.Write(Char[], Int32, Int32)
      at System.IO.TextWriter.WriteLine(System.String)
      at System.IO.TextWriter+SyncTextWriter.WriteLine(System.String)
      at System.Console.WriteLine(System.String)
      at HSPI_FritzTR064.UTILS.Log(System.String, Boolean, System.String, Boolean)
      at HSPI_FritzTR064.fritzbox.FB_PollFritzBox()
      at System.Threading.ThreadHelper.ThreadStart_Context(System.Obj ect)
      at System.Threading.ExecutionContext.RunInternal(System.Threadi ng.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
      at System.Threading.ExecutionContext.Run(System.Threading.Execu tionContext, System.Threading.ContextCallback, System.Object, Boolean)
      at System.Threading.ExecutionContext.Run(System.Threading.Execu tionContext, System.Threading.ContextCallback, System.Object)
      at System.Threading.ThreadHelper.ThreadStart()
       
       

      Then:

      Faulting application name: HSPI_FritzTR064.exe, version: 3.0.0.1, time stamp: 0x5675768e
      Faulting module name: KERNELBASE.dll, version: 10.0.16299.15, time stamp: 0x2cd1ce3d
      Exception code: 0xe0434352
      Fault offset: 0x001008b2
      Faulting process id: 0x1808
      Faulting application start time: 0x01d376a75475ead4
      Faulting application path: C:\Program Files (x86)\HomeSeer HS3\HSPI_FritzTR064.exe
      Faulting module path: C:\WINDOWS\System32\KERNELBASE.dll
      Report Id: 88859e96-2bbe-4275-81a6-938cf2906d2e
      Faulting package full name:
      Faulting package-relative application ID:

      it will work is I start in het homeseer 3 directory : HSPI_FritzTR064.exe with admin rights.
      But then (i Think) the homeseer and pluin memory is high.

      <TABLE class=full_width_table cellSpacing=0 width="100%"> <TBODY> <TR> <TD class=tablecell align=right></TD> <TD class=tablecell align=left></TD></TR> <TR> <TD class=tablecell align=right></TD></TR></TBODY></TABLE>

      Comment


      • #4
        Sorry, I fail to see how the connection error is related to the plugin crashing.

        Can you delete and reinstall the plugin to see if that fixes the crashing? It seems some kind of permission error indeed.
        stefxx

        Comment


        • #5
          Dec-17 19:14:32 Updater Install/Update of package FritzTR064 was successful.
          Dec-17 19:14:32 Updater Copying file: C:\Program Files (x86)\HomeSeer HS3\HSPI_FritzTR064.exe
          Dec-17 19:14:32 Updater Installing package FritzTR064
          Dec-17 19:14:32 Updater Update HSPI_FritzTR064.exe downloaded successfully
          Dec-17 19:14:32 Updater Downloading update: FritzTR064
          Dec-17 19:14:32 Updater Starting download of updates

          Then:
          Go tot he app page in the brouwser.
          404 Bad Request: /FritzTR064_Config

          Then
          Dec-17 19:16:19 Info Plugin FritzTR064 with instance: has disconnected
          Dec-17 19:16:14 FritzTR064 Initializing plugin FritzTR064 version 3.0.0.1
          Dec-17 19:16:14 Info Plugin FritzTR064 has connected. IP:127.0.0.1:51985
          Dec-17 19:16:14 Warning I/O interface FritzTR064 is down, executable is not running, restarting ...
          Dec-17 19:15:53 Error Getting web page from plugin page FritzTR064_Config:Object reference not set to an instance of an object.
          Dec-17 19:15:53 Info Plugin FritzTR064 with instance: has disconnected
          Dec-17 19:15:44 Plug-In Finished initializing plug-in FritzTR064
          Dec-17 19:15:44 FritzTR064 Initializing plugin FritzTR064 version 3.0.0.1
          Dec-17 19:15:43 Info Plugin FritzTR064 has connected. IP:127.0.0.1:51907

          In the fritz.box 7490 no error(s)

          Comment


          • #6
            Ok, yes, I see a potential issue here. Give me a few days to look into this.

            Somehow the plugin crashes when the "Developer Mode" is disabled AND it cannot connect to the FritzBox.
            stefxx

            Comment


            • #7
              Ok, can you please try the new version (3.0.0.2) in the updater?

              It should not crash anymore. Also, it now supports SSL ports other than 443. See images below for the Plugin settings and where to find the port in the FritzBox:
              Attached Files
              stefxx

              Comment


              • #8
                you are the best, it works as Always.
                many Thanks

                Comment


                • #9
                  P.S. I have it on port 443 !!!

                  Comment


                  • #10
                    Originally posted by tja View Post
                    P.S. I have it on port 443 !!!
                    Nice that it works again, thanks for confirming.

                    The ability to change the port might help others (like gdarby?) as I found that the plugin breaks if you set a port forward on the FritzBox for port 443. You then have to choose another port in the Fritz for SSL access and the plugin had 443 hard coded so it wouldn't work anymore...
                    stefxx

                    Comment

                    Unconfigured PHP Module

                    Collapse

                    Working...
                    X