Announcement

Collapse
No announcement yet.

Buienradar plugin

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Buienradar plugin

    Hello Stefxx,

    Does your buienradar plugin still work? I cannot add my address to the location page, it is not saved. Also i see the BuienradarDevice is disconnected.

    Regards,

    Frans

  • #2
    Hi Frans,

    Absolutely! It still works and I use it every day.

    When it fails to save a location it is usually because device have been removed manually from the device list. So when you try to edit or recreate a location, the plugin thinks there is a corresponding device, but then it fails because it can't be found.

    Can you create other locations that haven't been used before?

    Alternatively, you can remove all the BuienRader devices (including the BuienradarDevice itself) and restart the plugin so it will be recreated. You have to redo all location settings afterwards.
    stefxx

    Comment


    • #3
      Hello Stefxx,

      Last couple of days i constantly receive:
      Incorrect amount of data received from Buienradar:
      So it look like the plugin isn't working anymore. No config has changed.

      Regards,

      Frans

      Comment


      • #4
        Hi Frans,

        I see a lot of those errors as well in the log. The error is on the buienradar api, not much I can do about it. The plugin works as designed and is stilk working, but I get a lot of "empty" responses. Luckely, some responses are still valid so they can be processed.
        stefxx

        Comment


        • #5
          Hello Stefxx,

          Tnx the error was resolved with buienradar as it seems. I have a question about device values: the Precipitation parameters device currently has a value of 0. On the advanced tab it says: '0 = Precipitation now', but currently no precipitation is excpected, which is the string value of the device.

          I want to close our screens when the sun is shining and no precipitation is expected. So i check wether the value of the device is equal to 'No precipitation expected'. But this would assume -1 as value not 0 right?

          Regards,

          Frans

          Comment


          • #6
            Yes, I see. I believe that is a bug... Give me some time to investigate and fix.
            stefxx

            Comment


            • #7
              Can you try the version attached? If it's stable (please test a few days) I'll release a new version.

              Thanks for reporting this issue!
              Attached Files
              stefxx

              Comment


              • #8
                Sorry didn't read the forums earlier then now. I installed the new version and will test some days. As the weather is bad now and for the upcoming days it will take a while to test:-)

                Comment


                • #9
                  Hello Stefxx,

                  All working fine now with the new version. Tnx!!

                  Frans

                  Comment


                  • #10
                    Thanks. I will release this as a new version in the updater.
                    stefxx

                    Comment

                    Unconfigured PHP Module

                    Collapse

                    Working...
                    X