Announcement

Collapse
No announcement yet.

Some Issues with Plugin

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Some Issues with Plugin

    Well done on the plugin,The Neato Plugin works well for the most part (i am using Connected D3 with the latest firmware), however i feel i must be missing something as well, but let me cover the first problem. i see the following regularly in the log for the plugin exactly every 20 seconds. (My poll time is set currently to 10)

    Neato Failed to send : The remote server returned an error: (404) Not Found.

    ok for the next part, i want to get stuck notifications and finished cleaning notifications (not the docked alert as i would receive this when its moved on and off the dock.) not sure how i would go about getting these states? when its just finished cleaning at the time i received the notification on the phone i saw that the status was -1 which is Offline, so i don't think that status is correct as it didn't go offline in the app and it changed to Idle as soon as it then docked a minute or so later.

  • #2
    stefxx

    Comment


    • #3
      cheers for the feedback i will do more checking around the errors, great news regarding the maps etc.. for the new version.

      I have enabled debugging and i get the following

      Apr-26 13:06:43 Neato {"version":1,"reqId":"77","result":"ok","data": {},"error":null,"alert":null,"state":2,"action":1,"cleaning" : {"category":2,"mode":1,"modifier":1,"navigationMode":2,"spot Width":0,"spotHeight":0},"details": {"isCharging":false,"isDocked":false,"isScheduleEnabled":fal se,"dockHasBeenSeen":true,"charge":89},"availableCommands": {"start":false,"stop":true,"pause":true,"resume":false,"goTo Base":false},"availableServices": {"generalInfo":"basic-1","houseCleaning":"minimal-2","IECTest":"basic-1","logCopy":"basic-1","maps":"basic-1","preferences":"basic-1","schedule":"minimal-1","softwareUpdate":"basic-1","spotCleaning":"micro-2","wifi":"basic-1"},"meta": {"modelName":"BotVacD3Connected","firmware":"4.0.0-1632"}}
      Apr-26 13:06:42 Neato Signature: 67784d1cbfb62dfc14e2cad5da05069d9a1921b239c18a134fc79baa3a60 6fc1
      Apr-26 13:06:42 Neato JSON: {"reqId":"77","cmd":"getRobotState"}
      Apr-26 13:06:42 Neato
      Apr-26 13:06:42 Neato Failed to send : The remote server returned an error: (404) Not Found.

      Comment


      • #4
        Thanks. Are you using the latest version of the plugin? 3.0.0.2 should be in the updater since yesterday.
        stefxx

        Comment


        • #5
          Originally posted by stefxx View Post
          Thanks. Are you using the latest version of the plugin? 3.0.0.2 should be in the updater since yesterday.
          Ok I missed that there was an update. I did check before I first posted but I don't think I waited long enough for the updated list to be downloaded. I've just updated so will do some testing tomorrow

          Sent from my SM-G950F using Tapatalk

          Comment


          • #6
            Thanks. Let me know if that resolves the error in the event log.

            The new version that include maps (and more) will be submitted sometime next week.
            stefxx

            Comment


            • #7
              FYI, that version fixed the issue with the error in the log. thanks.

              Comment

              Working...
              X