Announcement

Collapse
No announcement yet.

Failed to send Nucleo command: The remote server returned an error: (404) Not Found.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Failed to send Nucleo command: The remote server returned an error: (404) Not Found.

    Hi.
    The plugin I'm using is version 3.0.0.6.

    I get this error in my log file (There is a lot of them):
    Failed to send Nucleo command: The remote server returned an error: (404) Not Found.
    I can't sent commands to my Neato, I can see that it worked 2 days ago.
    I have tried to login again via the config page, but it did not help.

    When I logged in again it found my Neato, so there most be some kind of communication to the Neato server.

    What can I try?

  • #2
    Hi HomeNorway,

    This error does NOT indicates an issue with the Neato server connection. The issue is with the Neato BotVac connection. Sometimes it helps to reboot the BotVac, but it could also mean a weak WiFi connection and you will need to relocate the Neato and/or improve overall WiFi signal strength.

    The Mobile App is a little more forgiving that my plugin, but I suspect when you use the Mobile App it will show "disconnected" every now and then as well. The App usually starts by "Connecting" but will eventually also show "Offline".

    You could try puttng the BotVac next to your WiFi router/access point and see if the errors go away (or at least show up less frequent).
    stefxx

    Comment


    • #3
      Hi stefxx.

      Thanks that help, the robot was not correct docked, so it only had 3% battery.
      I guess it drops the wifi connection at very low battery.

      Thanks again.

      Comment


      • #4
        Hi stefxx. I know that this is an older thread but the same thing is happening to me. It just started today. I've followed all of the steps mentioned and they didn't work. What WILL work is if I remove all of the Neato devices from the plugin and re-authenticate. Unfortunately this also deletes and re-adds all of the HS Neato devices with all new reference IDs. It also removes them from all of my HS Neato events. Lastly even if I reprogrammed all of the HS events, I appear to also be missing Neato devices such as "Neato Mode" which specifies Turbo and ECO modes.

        Now I know that Neato updated the firmware to include Zone cleaning and I know from a previous post that you are waiting for the API programming guide to be updated before incorporating it into the plugin but do you think that this firmware change has anything to do with what I'm experiencing? It was working perfectly up until yesterday.

        Comment


        • #5
          Hi rotunnoe,

          What device do you use? A D7 I assume?

          If you are getting a 404 error, the problem is between the Neato servers and your robot. Removing your devices and re-authenticate should never be required (and I don't see how it could work as a solution or workaround). If the problem persists, please enable all logging and log to file, and send me the file. Send me a PM and I'll give you an email address to send it to. I do not see any relation to the new firmware. I have been running that for weeks without issue.

          I can see why it doesn't recreate the "Mode" device, that is also caused by the new firmware. I will fix that in the next release. Let me know if you need a version with this fix now (PM me your email so I can send it to you).

          Thanks!
          stefxx

          Comment


          • #6
            In response to rotunnoe's issue, the problem was likely at the robot that needed to re-register with the App/Cloud. However, an issue was found when recreating HS3 devices with the latest firmware. That has been resolved in version 3.0.0.9, released today. Thanks!
            stefxx

            Comment

            Working...
            X