Announcement

Collapse
No announcement yet.

version 3.0.0.14: failed getting interfaceStatus

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • version 3.0.0.14: failed getting interfaceStatus

    What I did, use the update feature, after that it was broken.
    Tried:
    Disable / re-enable plugin > no succes.
    Disable plugin, shutdown HSpro, restart HSpro, enable plugin > no succes
    Tried deleting and reinstall, only after first disable, and restart of HS i could delete it. Reinstall of 3.0.0.14 > no succes.

    I think im now out of options
    The log says this:
    jun-16 22:00:22 Plug-In Finished initializing plug-in Buienradar
    jun-16 22:00:22 Error Initializing plug-in(2): Buienradar Instance::String was not recognized as a valid DateTime.STACK: Server stack trace: Exception rethrown at [0]: at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessag e(IMessage reqMsg, IMessage retMsg) at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(Mess ageData& msgData, Int32 type) at HomeSeerAPI.IPlugInAPI.InitIO(String port) at Scheduler.clsHSPI.CheckInterfaces()
    jun-16 22:00:21 Buienradar Initializing plugin Buienradar version 3.0.0.14
    jun-16 22:00:21 Info Plugin Buienradar has connected. IP:127.0.0.1:52410

  • #2
    That is strange... did you remove any of the buienradar devices manually?

    We can try two things:
    - Enable developer mode and restart the plugin. That should reveal an errormessage that should point me in the right direction (please share a screendump of the error), or
    - Remove the buienrader.ini from the config directory and remove all buienradar devices (incl. the status device). This off course means you will loose all settings but could probably get you up and running quickly.

    I prefer the first as I might be able to prevent this error in the future. Thanks!
    stefxx

    Comment


    • #3
      Here the screenshot of developer mode.
      Other options have to wait till tomorrow because have to get up early tomorrow
      Attached Files

      Comment


      • #4
        Thanks. However, I don't see the plugin crashing in the developer window... I would expect it to crash as soon as you start the plugin, based on your description...
        stefxx

        Comment


        • #5
          In the event overview it say: "The plug-in Buienradar is not running or is not connected to HomeSeer"
          Ive now disabled the 2 events so my log > no succes.

          Deleted all buienrader devices. Deleted the plugin. Renamed the ini file so that i would have backup. Reinstalled plugin, location was empty.
          Entered the location again and plugin said it was disconnected. So restart of homeseer and the error came again:
          Initializing plug-in(2): Buienradar Instance::Object reference not set to an instance of an object.STACK: Server stack trace: Exception rethrown at [0]: at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessag e(IMessage reqMsg, IMessage retMsg) at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(Mess ageData& msgData, Int32 type) at HomeSeerAPI.IPlugInAPI.InitIO(String port) at Scheduler.clsHSPI.CheckInterfaces()
          The new ini file is:
          [Settings]
          Version=3.0.0.14
          The old one
          [Settings]
          Version=3.0.0.14
          [Options]
          GraphType=Curved lines
          GraphBackgroundColor=White
          GraphXYAsColor=Black
          GraphColor=Blue
          Speak=unchecked
          TextParamDevice=%Precipitation%\nStart: %PrecipitationStart%\nStop: %PrecipitationStop%\nIntensity: %PrecipitationIntensity%\nAverage: %PrecipitationAverage% mm/h\nMaximum: %PrecipitationMax% mm/h
          TextPrecipitation=Verwachte neerslag
          TextNoPrecipitation=Geen neerslag verwacht
          Debug=unchecked
          Fake=unchecked

          Comment


          • #6
            Here the event overview, notice how value 0,3 is displayed as 3 when event line details are closed.
            Attached Files

            Comment


            • #7
              I got the same problem. I just installed for the first time version 3.0.0.14.

              When I start Homeseer I get:
              Starting up....

              2015-07-12 18:16:53 ~!~Error~!~Initializing plug-in(2): Buienradar Instance::Object reference not set to an instance of an object.STACK:Server stack trace: Exception rethrown at [0]: at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessag e(IMessage reqMsg, IMessage retMsg) at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(Mess ageData& msgData, Int32 type) at HomeSeerAPI.IPlugInAPI.InitIO(String port) at Scheduler.clsHSPI.CheckInterfaces()Startup Complete, 1 errors detected, check the log for more information.

              And the plugin sais:
              WARNING: Failed getting InterfaceStatus from Buienradar - the interface was not found in the list of active interfaces, the list may need to be refreshed.

              Comment


              • #8
                Thanks for reporting. I am currently on vacation but will contact you when I get back to find a solution.

                In the meantime, please tell me if you have used a previous version of Buienradar and if so, what version. And perhaps send me a PM with your email address so I can send you a debug version when I get back.
                stefxx

                Comment


                • #9
                  I have not been using any earlier version of the plugin.

                  Comment


                  • #10
                    Ok, this crashing of the plugin (for just a few people) remains a mystery. For Agwan is seems not to crash anymore but his location is not supported. For The-Source is seems reverting back to 3.0.0.13 solves the problem but the changes should not be the reason of this issue...

                    If anyone else sees this issue please report to me. Please enable debug, and if the plugin does not start at all create/edit the Buienradar.ini (in the config directory) and add the following before attempting another start:

                    [Options]
                    Debug=checked

                    Enable developer mode, create a screenshot and send all the relevant logs to me (also check Windows eventlogs, minidumps created etc) and hopefully we can resolve this once and for all.

                    Thanks!
                    stefxx

                    Comment


                    • #11
                      i tracked the error so far and its dot net related ,

                      i updated my dot net yesterday to 4.5.2 and than i got this error ,

                      before i had no dot net 4.0 , because of my new windows install of 1 week ago i totally forget..
                      Preferred -> Jon's Plugins, Pushover, Phlocation, Easy-trigger,
                      Rfxcom, Blade Plugins, Pushbullet, homekit, Malosa Scripts




                      HS3Pro 4.0.1.18 on windows 10 enterprise X64 on hp quadcore laptop 8 GB.

                      Comment


                      • #12
                        This issue is resolved in version 3.0.0.16, available in the HS3 updater.

                        Malosa, thank you for helping me on this issue!
                        stefxx

                        Comment

                        Working...
                        X