Announcement

Collapse
No announcement yet.

ADIO-100 drops connection

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • ADIO-100 drops connection

    I've just upgraded to HS3 and have it installed on a Qotom Q350P micro PC running Win10Pro. Everything seems to be running fine, except that the ADIO-100 I have on the COM3 Port usually disconnects as some point (often within 12 hours of running). I have no idea of what's behind the disconnect. The connection was initially with Cat5e cable using DB9 to RJ45 converters. Suspecting that there may be some cable interference, I swapped this out to a plain DB9 M/F serial cable. The baud rate on both the ADIO and PC is set at 11500.

    I should note that the ADIO performed flawlessly on my old Hometroller S4 running XPe and HS2. The HS3 ADIO plug-in is currently set to poll every 15 seconds, but I've tried 30 seconds with the same results.

    Any ideas??

  • #2
    11,500 baud is not a valid speed on my machine. If you really meant 115,200, that is way too fast for RS232 on anything but a couple feet of cable. Try 9600 baud. That is the natural speed for the ADIO100. RS232 will work well at 9600 baud up to about 50 feet, maybe 75 feet.

    You don't say what kind of hardware you have for your serial port. If it uses USB, make sure you go to "Device Manager" > "Universal serial bus controllers" > "properties" (for the specific device) > "Power Management" and unclick the box that says "Allow the computer to turn off this device to save power". Otherwise the computer can turn off the device when it thinks its not in use.

    Comment


    • #3
      115,200 is what I meant. I'll try 9600 and see if that works. It was set at that for a long while, but I had read that the higher speed was recommended by some. The cable is about 5 feet long and it's connected to a convential serial port (no USB).

      Comment


      • #4
        Ah yes, I do remember something about needing to set it to 115,200 initially to get it working. In any case, mine is currently set at 9600 and working flawlessly.

        Have you already done the R7 resistor removal to get the ADIO100 to read sensors accurately? See https://forums.homeseer.com/showthre...light=resistor

        Comment


        • #5
          I have not done the R7 resistor pack mod yet. I wanted to get things up and running first. It is definitely on my list, but I'm not sure if I'm going to do the mod myself or have someone else do it for me.

          Comment


          • #6
            Well, 9600 won't work on my system at all. I did call Integrity Instruments the OEM for the ADIO-100. The folks there are super nice and walked me through troubleshooting. Basically this seems to be a Plug-In issue (are you listening HS.) Using Integrity's software I am able to see the ADIO-100 at 9600 and can read data off it, so it is not a PC or ADIO-100 issue. However, the ADIO plug-in seems to be hard wired to look for the 115200 speed and nothing else. I tried all of the speed settings an nothing works except 115200. Interestingly if you watch the LED closely, you can see where the ADIO seems to get some sort of signal (there is a slight hiccup/flicker in the green pulse), but it quickly aborts and goes back to it's steady blink until the next polling interval. The guy I spoke with at Integrity said that it is unusual to not have a baud setting in the software interface and that this is likely the cause of the problem. 115200 is fast and while some systems can support it, others simply can't or they can't maintain it. I suspect HST hardwired that into the plug-in and if memory serves, that was not the case with the HS2 version.

            I don't know if there are any other versions of this plug-in floating around. I have ADIO-100, version: 3.0.0.29 on my machine. Perhaps an older one has better compatibility. In the meantime I am stuck with an unusable piece of hardware.

            Comment


            • #7
              Techvet, I am using the same plugin version 3.0.0.29 and mine is working fine at 9600 baud. My settings in device manager are:
              Com3,
              9600 baud,
              8 bits,
              no parity,
              1 stop bit,
              no flow control,
              FIFO Buffers turned on,
              Receive Buffer = High(14),
              Transmit Buffer = High(16).

              I'm using a USB to Serial adapter and the driver is Prolific Ver 3.8.1.3 dated 7/5/2016.

              The ADIO's baud rate is set by internal DIP switches so it must be opened up and both switches set to "Off" for 9600 baud. Not sure what speed it is shipped at but it sounds like yours is at 115,200.

              My ADIO polling interval is set to 10 seconds. Note that in HS2 you gave the interval in milliseconds (eg 10 seconds = "10000"), and now in HS3 it is in seconds (same 10 seconds now = "10"). I used to be able to poll at 1 second in HS2, but that didn't work in HS3 so I changed it to 10 seconds. I forget now what problem it caused, but 10 seconds is ok for my application so I just left it that way.

              Don't give up on it yet, it can be made to work!..
              Last edited by Burrington; January 27th, 2017, 02:54 PM.

              Comment


              • #8
                Still no dice. Nothing I have done so far seems to make a difference for any connection speed slower than 115200. I pulled a USB to serial converter out and it does nothing at 9600.

                Out of frustration I went back to 115200 and the ADIO connected up right away (as anticipated.) For grins I have turned the buffers down to low this time to see if the connection can hold. My next step will be to turn them off completely. I'm not giving up just yet, but I have an Arduino sitting on my desk just in case!

                Comment


                • #9
                  What number are you using in the "Poll Interval" field?

                  Comment


                  • #10
                    The poll interval is 6 seconds, expressed as 6 in the poll field.

                    There is a note in the serial config section of Device Manager that says if communication issues develop to slow down the buffers, which is why I decided to give it a try. I'm perfectly okay with the high speed as long as the connection remains stable.

                    Comment


                    • #11
                      Oh, regarding the dip switches... They do work just fine. I set them at 9600 for the test with Integrity Instruments software and it connected just fine at 9600. So, I go back to the plug-in. I think that if HST had designed in a baud rate selection field it could be made to work at 9600. The auto-negotation of the baud rate (if indeed that is what they are trying to do) is apparently not perfect and there are too many folks who have had this issue for it to be "just me".

                      Comment


                      • #12
                        I'm not sure the plug-in auto-selects the baud rate. I believe the computer end of the baud rate is set in Device Manager, and the ADIO end is set by the DIP switches.

                        I also seem to recall that I tried 5 second poll interval and had to raise it to 10 seconds to make it work. You could try that too.

                        Comment


                        • #13
                          The connection dropped again, this time after 7 hours. I forgot to note that when both the PC and the ADIO are set at anything but 115200, an error shows up in the HS3 Start-up Log which reads:

                          ADIO-100 ERROR~!~Expected Response from Unit Not Received For Command z

                          According to Integrity's manual, the "z" command calls for a ADIO CPU reset, which in this case the ADIO clearly does not respond to. Perhaps the CPU reset is a boot-up signal for the ADIO to initialize communications. Whatever the case, it appears that ADIO (or at least my ADIO) just can't communicate with HS3 at 9600 and can't keep a stable connection at 115200.

                          Comment


                          • #14
                            Techvet, I disassembled my ADIO to verify the dip switch settings and was surprised to see that mine are both "on" which means the ADIO is at 115200 baud. That is puzzling since Device Manager shows the PC end at 9600. So I'm not sure how they are communicating, or what the real rate is since one end is obviously switching to match the other. I suspect ADIO is switching to 9600 because if the PC was switching I think Device Manager would show the real rate.

                            So you probably have the same settings as I do.

                            Did you try changing to a 10 second poll interval? Its more than a year ago now, but if I remember correctly my ADIO would lock up after a few hours at 5 seconds poll interval and need to powered off and on to run again. I changed it to 10 seconds and it has never failed since. Its definitely a flaw in the HS3 plug-in because I used to run the same unit at 1 second poll interval under HS2 without any problems.

                            Comment


                            • #15
                              Burrington,

                              My switches were initially set to 9600 back when I had HS2 and the machine did connect at 9600, but... as noted, that was with HS2 and I'm pretty sure I had the plug-in communicate at 9600. When I first started playing around with HS3 it was with my HS2 loaded HomeTrollerS4. I installed HS3 and would periodically connect stuff to make sure everything was compatible. The ADIO had trouble with HS3 and that's when I read about and subsequently set the ADIO DIP switches to 115200. That definitely fixed the HS3 connect issue, but HS3 was never running long enough to test out the stability of my connection - remember I was just playing around with it. But even with that setting, the ADIO still connected to HS2 at 9600, because the plug-in/ settings forced HS2 to do that.

                              Here is an interesting piece of info. When I spoke with Integrity Instruments yesterday, they said that when they first OEM'd these that HST asked for them to go out the door at 9600. The default if you bought the Integrity branded unit is supposed to be 115200 and it says so in their literature. I know for sure that when I first got mine it was set for 9600. So, something has changed from when HST first fielded these for HST to specify/suggest 115200 if you were to call them with a problem.

                              As for polling intervals, I have tried 6 seconds, 10 seconds, 30 seconds, 60 seconds, all with the same result - that being the connection drops within 12 hours. I definitely think this is a plug-in issue and most likely is one that could be easily remedied by providing a means to manually force the plug-in to accept a low baud rate. I bought my ADIO-100 as an open box item from one of the authorized distributors, so I doubt I could get HST's attention with this.

                              At this point I am cutting my losses, at least for the time being. Earlier this morning, I fired up the Arduino Mega 256 and had it talking to HS3 within 30 minutes or so. I modified my event/script and presto, my Plenum Temp is up and running and has been rock solid stable for the past 12 hours. I hope I can have two more analog inputs on-line tomorrow.
                              Last edited by Techvet; January 29th, 2017, 06:44 AM.

                              Comment

                              Working...
                              X