Announcement

Collapse
No announcement yet.

Problems when adding a second ADIO-100

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problems when adding a second ADIO-100

    I'm fairly certain this is a Homeseer problem but....

    The short version is that I added a second ADIO-100 to my system and whenever a digital output is toggled on one device it is duplicated with some latency on the other. Turn on bit 1 on device 1 and within a second or so bit 1 on the device 2 turns on. This action is duplicated both directions and with either state.

    The longer version: I added an ADIO-100 on a physical com port last week. I configured it and was testing it with success. I am using the analog inputs as well as the digital outputs. The digital outputs are driving relays by optical couplers. These are the SainSmart 8 relay boards for Arduino.

    The next step was to move it to a serial over Ethernet port so that it could be remote from my server. This test worked as well. Then I added a second ADIO-100 on another virtual serial port (serial over Ethernet). I only had a couple of connections to each ADIO-100 as I was still testing. The first thing I noticed was that my analog inputs on the first unit became erratic and unreliable. Then I noticed that the analog input on the second device was reflecting the same value as the first. I also noticed some serious latency on the digital output state changing on the first device, though it was instantly indicted in the device management view in Homeseeer. Since I hadn't added all of the digital outputs, I created all eight outputs on both devices.

    That is when I found that the first devices digital outputs mirrored the second device. No matter where I changed the device state, it would reflect on the other device with a slight delay. Thnking that something might be wonky with the Ethernet to serial converters I moved one of the ADIO-100s back to a physical port -0 with the same result. Having read in another thread on these devices where someone had a missing bit and cured the problem by deleting the device, disabling the plug-in - enablng the plug-in and adding the device again. That didn't work either. I have uninstalled the plug-in and re-installed it, moved the second ADIO-100 to a physical port, always with the same result.

    There are some screenshots attached. In the last two you can see that the bit states between the two devices are identical. One thing to note is that when a second ADIO-100 is added the addresses are duplicated, intuitively that seems it could cause problems. There is no way to edit the addresses within device management.

    Since I have confirmed that the two ADIO100s function perfectly it seems this must be a software issue.

    The only error in the logs is when I add the second device then make a first attempt to change the state of one of the outputs:

    Mar-06 5:13:30 PM ADIO-100 Error initializing device: Object reference not set to an instance of an object.
    Attached Files
    Randy Prade
    Aurora, CO
    Prades.net

    PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

  • #2
    ADD A SECOND ADIO100

    I would add to my system a second ADIO100 but before to buy it (the second), let me know if the problem posted by "rprade" had no solution?
    Now I use one ADIO100 with IPSL2 (global cache) and it works with 8 digital Input ports (the magnetic sensors doors/windows). It works very well without errors but with the second ....?'''??
    thanks.

    _____________________
    HS3 Pro Edition 3.0.0.163
    (Windows)
    Restart:,NetCAM:,HSTouchServer:,VWS:,BLMediaPlayer:,ADIO100: ,Current Cost:,Z-Wave:
    Z-wave 3.0.1.0

    Comment


    • #3
      According to Bugzilla it was resolved: http://bugzilla.homeseer.com/bugzill...ug.cgi?id=1651

      Cheers
      Al

      PS Shameless Plug : I have a slightly used ADIO-100 for sale: http://board.homeseer.com/showthread.php?t=174556
      HS 3.0.0.548: 1990 Devices 1172 Events
      Z-Wave 3.0.1.262: 126 Nodes on one Z-Net

      Comment

      Working...
      X