Announcement

Collapse
No announcement yet.

Sending text to LCD panel through event

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Sending text to LCD panel through event

    So I can send text to the LCD from device manager without issue - immediate as I would expect. However, when I create an event (identical to page 9 of the user guide), 99% of the time the text is not being sent to the display.

    Playing with another event, in my test, I've got a push button setup/monitored by the plugin which toggles a small relay. At this time, I'd like to update the LCD with appropriate information, but nothing gets displayed either. Are others having this problem as well?

    I'm using .142 beta.

    Robert
    Attached Files
    HS3PRO 3.0.0.500 as a Fire Daemon service, Windows 2016 Server Std Intel Core i5 PC HTPC Slim SFF 4GB, 120GB SSD drive, WLG800, RFXCom, TI103,NetCam, UltraNetcam3, BLBackup, CurrentCost 3P Rain8Net, MCsSprinker, HSTouch, Ademco Security plugin/AD2USB, JowiHue, various Oregon Scientific temp/humidity sensors, Z-Net, Zsmoke, Aeron Labs micro switches, Amazon Echo Dots, WS+, WD+ ... on and on.

  • #2
    As a workaround, I discovered that I can call a specific page defined/stored from the device management page. The event will call the appropriate page and display the defined text.

    Robert
    Last edited by langenet; June 7th, 2017, 01:05 PM.
    HS3PRO 3.0.0.500 as a Fire Daemon service, Windows 2016 Server Std Intel Core i5 PC HTPC Slim SFF 4GB, 120GB SSD drive, WLG800, RFXCom, TI103,NetCam, UltraNetcam3, BLBackup, CurrentCost 3P Rain8Net, MCsSprinker, HSTouch, Ademco Security plugin/AD2USB, JowiHue, various Oregon Scientific temp/humidity sensors, Z-Net, Zsmoke, Aeron Labs micro switches, Amazon Echo Dots, WS+, WD+ ... on and on.

    Comment


    • #3
      What I have found is I think the Send Command processes in the Event before the String is set. When I update my displays I set the Strings in one THEN section and then I use a second THEN section to perform the Sends. It's a two step process and has been working reliably for me. Not sure if there's a better way. You can't do a String update and a Send in the same THEN section. Once you use the Line number to set the string it's taken and not available for a second command in the same THEN section.

      You may want to look at my postings here:
      https://forums.homeseer.com/showthread.php?t=190903

      Comment


      • #4
        Good to know.

        Thanks!
        HS3PRO 3.0.0.500 as a Fire Daemon service, Windows 2016 Server Std Intel Core i5 PC HTPC Slim SFF 4GB, 120GB SSD drive, WLG800, RFXCom, TI103,NetCam, UltraNetcam3, BLBackup, CurrentCost 3P Rain8Net, MCsSprinker, HSTouch, Ademco Security plugin/AD2USB, JowiHue, various Oregon Scientific temp/humidity sensors, Z-Net, Zsmoke, Aeron Labs micro switches, Amazon Echo Dots, WS+, WD+ ... on and on.

        Comment


        • #5
          Read here: https://forums.homeseer.com/showthread.php?t=189925


          ~Bill

          Comment

          Working...
          X