Announcement

Collapse
No announcement yet.

Version Mismatch - roll plugin back?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Version Mismatch - roll plugin back?

    Hi,
    Is there a way to roll the plugin back to a previous version?
    My one Arduino MEGA, running a pool controller for over a year has suddenly stopped working.

    I read it is because of the new version of the plugin. 1.0.0.131

    I mistakenly upgraded, and it has broken my pool controller.
    it is 117 degrees outside, and I really don't want to mess with this right now.
    I would like to roll back my plugin version, to make it happy.

    Happy to try to learn all this stuff again, in the fall, when it is not so hot, but right now, I need my pool motor running!


    Is there a link somewhere to download previous versions of the plugin?

    Please help!

    Swanie

  • #2
    Originally posted by swanie2000 View Post
    Hi,
    Is there a way to roll the plugin back to a previous version?
    My one Arduino MEGA, running a pool controller for over a year has suddenly stopped working.

    I read it is because of the new version of the plugin. 1.0.0.131

    I mistakenly upgraded, and it has broken my pool controller.
    it is 117 degrees outside, and I really don't want to mess with this right now.
    I would like to roll back my plugin version, to make it happy.

    Happy to try to learn all this stuff again, in the fall, when it is not so hot, but right now, I need my pool motor running!


    Is there a link somewhere to download previous versions of the plugin?

    Please help!

    Swanie
    What version were you running? API or IDE INO sketch? The sketches change frequently.

    If you have a laptop and a USB cable, it would probably be as easy to download the correct IDE and update the sketch in the board to the correct version. I can do all 6 of my boards in about 30 minutes, one would take 5.
    Randy Prade
    Aurora, CO
    Prades.net

    PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

    Comment


    • #3
      Well there is the problem.
      I haven't messed with Arduino anything for over a year.
      Not sure what the old version was.

      I am currently reprogramming my laptop with the new Arduino software V1.6.8, and downloaded the new library files.

      The board file is my biggest problem, as last year, I finally managed to install a watchdog code to keep the pool controller from locking up. This was last year, and it has been working perfectly every since.

      Luckily, I took notes. Hopefully the same code will work with the newer version.

      Looks like I am forced to revisit it all, right now. Sucks, but it is what it is!

      Thanks for the reply, but I think I am going to have to just re-learn it. I will post back if I get stuck.

      Swanie

      Comment


      • #4
        It will not help you this time, but maybe....

        Just to make sure I do not run into these kind of problems I use the following procedure before I update any plugin (caught by surprise once too often...)
        1. Stop HS3
        2. Copy the C:\Program Files (x86)\HomeSeer HS3 directory and all its subdirectories to a safe location
        3. Start HS3
        4. Update the plugin.


        I keep track of the backup copies and number them sequential. If a problem arises, reverting back is as simple as deleting the existing C:\Program Files (x86)\HomeSeer HS3 directory and copying back the old one to the original location. Saved me a couple of times (also with the Arduino plugin when I was not ready to update all my boards with a new sketch and was caught by suprise...)


        Simple, 2 minutes work and very effective

        Comment


        • #5
          This is the first time I have been bitten by an upgrade, I will use do caution in the future.

          For me, I take regular backups, on Sunday and Wednesday, and copy them to a thumb drive. I only save about two weeks worth, and then they are automatically overwritten.

          My problem is the pool controller Arduino Mega has been flawless, and has not been turned off for months. This Arduino update was a few weeks ago when I allowed it to update. Homeseer didn't complain about Version Mismatch until I turned off the power yesterday, to clean the filter. When I turned it back on, nothing worked.

          A long story short, I did get the Arduino pool controller working again. It wasn't too bad, just had to revisit/relearn everything. Glad I took notes!

          Thanks for the input guys!

          Comment

          Working...
          X