Announcement

Collapse
No announcement yet.

Arduino auto-connect on startup

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Arduino auto-connect on startup

    Have my first arduino on HS3 to read a set of momentary switches for lighting scene controls. Works great -- thanks for this PI.

    One issue -- after HS3 reboots, the arduino plug-in doesn't reconnect, despite auto connect being checked. To connect it, i must manually:
    a) uncheck auto-connect, b) recheck-auto-connect, c) press the "connect" button. Then it reliably connects....
    For clarity, it does NOT connect if I just press connect, or if I uncheck autoconnect and press connect. ONLY the sequence above seems to work.

    Log shows it connecting after startup, then about 15 secs later the PI reports "New Com Port Found". Not sure if that's the issue or not. But when I look at the Config page it shows disconnected.

    Any thoughts? I see no one else having such issues so i'm sure i'm doing something really stupid. thanks

    Current Date/Time: 6/27/2017 12:39:30 PM
    HomeSeer Version: HS3 Pro Edition 3.0.0.318
    Operating System: Microsoft Windows 10 Home - Work Station
    System Uptime: 0 Days 2 Hours 10 Minutes 43 Seconds
    IP Address: 192.168.1.64
    Number of Devices: 1035
    Number of Events: 175
    Available Threads: 800

    Enabled Plug-Ins
    1.0.0.131: Arduino Plugin
    2.0.5.0: BLTouchString
    3.0.22.30668: Blue-Iris
    0.0.0.26: drhsIpPlugIn
    3.0.0.32: EasyTrigger
    3.0.0.18: Ecobee
    3.0.0.68: HSTouch Server
    3.0.0.83: LutronCaseta
    1.0.17155.370: MyQ
    2.1.6.0: OpenSprinkler
    1.0.0.5: Restart
    1.2.2.0: SceneMaster
    3.0.6132.16975: UltraGCIR3
    3.0.6260.19461: UltraMon3
    3.0.6265.20586: UltraWeatherWU3
    3.0.1.130: Z-Wave

  • #2
    "New COM port found" does this mean the Arduino is connected using USB?

    I have a daily event that restarts HS every night and I am not seeing this kind of behavior, but all my arduino's connect over the network either wired or wireless.

    The message does however remind me of something I have seen with my RFXCOM and Z-WAVE stick. Both used the same driver for the USB to COM port conversion and every time I rebooted the PC the com ports were swapped.

    Could this be happening with the com port your Arduino is connected to? Check if the com port changes if the HS system is rebooted.

    Comment


    • #3
      Originally posted by monument View Post
      Have my first arduino on HS3 to read a set of momentary switches for lighting scene controls. Works great -- thanks for this PI.

      One issue -- after HS3 reboots, the arduino plug-in doesn't reconnect, despite auto connect being checked. To connect it, i must manually:
      a) uncheck auto-connect, b) recheck-auto-connect, c) press the "connect" button. Then it reliably connects....
      For clarity, it does NOT connect if I just press connect, or if I uncheck autoconnect and press connect. ONLY the sequence above seems to work.

      Log shows it connecting after startup, then about 15 secs later the PI reports "New Com Port Found". Not sure if that's the issue or not. But when I look at the Config page it shows disconnected.

      Any thoughts? I see no one else having such issues so i'm sure i'm doing something really stupid. thanks

      Current Date/Time: 6/27/2017 12:39:30 PM
      HomeSeer Version: HS3 Pro Edition 3.0.0.318
      Operating System: Microsoft Windows 10 Home - Work Station
      System Uptime: 0 Days 2 Hours 10 Minutes 43 Seconds
      IP Address: 192.168.1.64
      Number of Devices: 1035
      Number of Events: 175
      Available Threads: 800

      Enabled Plug-Ins
      1.0.0.131: Arduino Plugin
      2.0.5.0: BLTouchString
      3.0.22.30668: Blue-Iris
      0.0.0.26: drhsIpPlugIn
      3.0.0.32: EasyTrigger
      3.0.0.18: Ecobee
      3.0.0.68: HSTouch Server
      3.0.0.83: LutronCaseta
      1.0.17155.370: MyQ
      2.1.6.0: OpenSprinkler
      1.0.0.5: Restart
      1.2.2.0: SceneMaster
      3.0.6132.16975: UltraGCIR3
      3.0.6260.19461: UltraMon3
      3.0.6265.20586: UltraWeatherWU3
      3.0.1.130: Z-Wave
      I know there were some connection fixes with .142. Might be worth a shot.
      Mine always connect right away.

      Robert
      HS3PRO 3.0.0.500 as a Fire Daemon service, Windows 2016 Server Std Intel Core i5 PC HTPC Slim SFF 4GB, 120GB SSD drive, WLG800, RFXCom, TI103,NetCam, UltraNetcam3, BLBackup, CurrentCost 3P Rain8Net, MCsSprinker, HSTouch, Ademco Security plugin/AD2USB, JowiHue, various Oregon Scientific temp/humidity sensors, Z-Net, Zsmoke, Aeron Labs micro switches, Amazon Echo Dots, WS+, WD+ ... on and on.

      Comment


      • #4
        thanks guys, good ideas. I tend to forget about the Beta section -- so was thinking I had the latest....wrong. v.142 release notes do indeed have promising info, such as "fixed auto connect on board 1" !!!!

        i need to update the arduino firmware to use 142 and i'm traveling so not sure i want to try that remotely. back in couple days and will flash the micro and give it a whirl. Thanks for the help !

        Comment


        • #5
          Fixed

          Just to close the loop, I upgraded everything (arduino IDE, libraries, sketch, plug-in) to use the .142 beta PI. Works well now.
          THANKS for the help guys.

          Comment

          Working...
          X