Announcement

Collapse
No announcement yet.

Error compiling sketch

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • rprade
    replied
    Originally posted by dwoolridge View Post
    Thanks for the incredibly quick responses!

    While I was away from the forum, I un-installed Arduino version 1.6.8 and installed 1.6.13. I then copied the libraries over and it compiled successfully (albeit with many warnings).

    Right now my Arduino UNO is up and running with HS3 through the USB connection.

    ...So it could have been the Arduino version, or the multiple library issue suggested by enigmatheatre.

    How would I tell if I had multiple library versions installed?


    Thanks!

    --Doug
    The easiest way I know of is to uninstall the IDE, make sure the Arduino directory is deleted from the Program Files (x86) directory. Then reinstall the correct IDE - specifically the one referenced in the help files for your current version. Then download the libraries from the plug-in configuration page and copy them into the "C:\Program Files (x86)\Arduino\libraries folder, overwriting any existing files.

    Leave a comment:


  • dwoolridge
    replied
    Thanks for the incredibly quick responses!

    While I was away from the forum, I un-installed Arduino version 1.6.8 and installed 1.6.13. I then copied the libraries over and it compiled successfully (albeit with many warnings).

    Right now my Arduino UNO is up and running with HS3 through the USB connection.

    ...So it could have been the Arduino version, or the multiple library issue suggested by enigmatheatre.

    How would I tell if I had multiple library versions installed?


    Thanks!

    --Doug

    Leave a comment:


  • rprade
    replied
    Originally posted by dwoolridge View Post
    I am (finally) upgrading to HS3 and was very excited about this plug-in, but I'm having problems. I followed the instructions in the help file and in the forums and just compiling the sketch errors out with a bunch of text. Any chance I'm the only one using a USB connection with these versions? Does it matter what folder the HomeseerBoard1.ino file is in when I compile?


    HS3 3.0.0.368
    Arduino 1.6.8
    Arduino Plugin 1.0.0.131 (unregisterd at this point)

    I've copied the 5 library folders to D:\Program Files (x86)\Arduino\libraries
    (yes, Arduino is installed on my D drive)

    I'm selecting the following in the Arduino Plugin config before downloading the sketch:
    Board #1: Connection = COM3
    Type = Arduino
    (no advanced settings)

    When compiling the sketch, it errors out with 1500 lines of error messages (see attached file.)
    A couple of thoughts. Are you using the specific IDE referenced in the help files for 1.0.0.131. Are the libraries downloaded from this version? I don't remember which IDE was used with that version. I am using beta 1.0.0.142 which calls for 1.8.1. The other thought is you wrote "Type = Arduino", did you select the correct board type in the IDE?

    Click image for larger version

Name:	Capture.PNG
Views:	1
Size:	25.9 KB
ID:	1192757

    Leave a comment:


  • enigmatheatre
    replied
    It looks like you have multiple versions of the library's installed on your system. You will have to remove one of them. Try removing the ones you installed and then recompile and see what errors you get.

    Greig.

    Leave a comment:


  • dwoolridge
    started a topic Error compiling sketch

    Error compiling sketch

    I am (finally) upgrading to HS3 and was very excited about this plug-in, but I'm having problems. I followed the instructions in the help file and in the forums and just compiling the sketch errors out with a bunch of text. Any chance I'm the only one using a USB connection with these versions? Does it matter what folder the HomeseerBoard1.ino file is in when I compile?


    HS3 3.0.0.368
    Arduino 1.6.8
    Arduino Plugin 1.0.0.131 (unregisterd at this point)

    I've copied the 5 library folders to D:\Program Files (x86)\Arduino\libraries
    (yes, Arduino is installed on my D drive)

    I'm selecting the following in the Arduino Plugin config before downloading the sketch:
    Board #1: Connection = COM3
    Type = Arduino
    (no advanced settings)

    When compiling the sketch, it errors out with 1500 lines of error messages (see attached file.)
    Attached Files
Working...
X