Announcement

Collapse
No announcement yet.

NodeMCU Crashes with LCD display standard sketch

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • NodeMCU Crashes with LCD display standard sketch

    I have a NOdeMCU with LCD standard sketch. This sketch crashes the plugin. Do you know what it may be wrong. Right now I disabled it and the other boards, about 6 of them do not have issues.

    Available Sketch Version = 1.0.0.145, API Version = API1.0.0.146

    Thanks,
    Aldo

  • #2
    When you say it crashes the plugin what do you see happening and are there any errors?

    Greig.
    Zwave = Z-Stick, 3xHSM100 7xACT ZDM230, 1xEverspring SM103, 2xACT HomePro ZRP210.
    X10 = CM12U, 2xAM12, 1xAW10, 1 x TM13U, 1xMS13, 2xHR10, 2xSS13
    Other Hardware = ADI Ocelot + secu16, Global Cache GC100, RFXtrx433, 3 x Foscams.
    Plugings = RFXcom, ActiveBackup, Applied Digital Ocelot, BLDeviceMatrix, BLGarbage, BLLAN, Current Cost, Global Cache GC100,HSTouch Android, HSTouch Server, HSTouch Server Unlimited, NetCAM, PowerTrigger, SageWebcamXP, SqueezeBox, X10 CM11A/CM12U.
    Scripts =
    Various

    Comment


    • #3
      Sorry, I should have been more specific. In most cases, the plugin will not show in the list of plugins, I would need to enable it to start the plugin, in other cases I would have the interface issue. On the same subject, could you implement something in the plugin that if it crashes I could set an alert in the event? I have several plugins that have events for when the plugin crashes.

      Thanks,
      Aldo

      Comment


      • #4
        This is strange and I have had no other reports of this and I am also running it here. Are you sure the new .exe is not being blocked by your AV.

        Greig.

        Sent from my SM-G950F using Tapatalk
        Zwave = Z-Stick, 3xHSM100 7xACT ZDM230, 1xEverspring SM103, 2xACT HomePro ZRP210.
        X10 = CM12U, 2xAM12, 1xAW10, 1 x TM13U, 1xMS13, 2xHR10, 2xSS13
        Other Hardware = ADI Ocelot + secu16, Global Cache GC100, RFXtrx433, 3 x Foscams.
        Plugings = RFXcom, ActiveBackup, Applied Digital Ocelot, BLDeviceMatrix, BLGarbage, BLLAN, Current Cost, Global Cache GC100,HSTouch Android, HSTouch Server, HSTouch Server Unlimited, NetCAM, PowerTrigger, SageWebcamXP, SqueezeBox, X10 CM11A/CM12U.
        Scripts =
        Various

        Comment


        • #5
          I will add that I have 6 NodeMCU boards and 3 of them are devoted to LCDs. I also have 4 Arduino Mega 2560 boards connected by Ethernet. All 10 work fine. I will also add that I purchased 5 identical LCDs at one time and they are at 2 different addresses. 3 are at 0x3f and 2 are at 0x27. I was only able to determine the address after running the i2c scanner sketch described here. I don't think a bad address is causing your problem.
          Randy Prade
          Aurora, CO
          Prades.net

          PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

          Comment


          • #6
            What is more strange is that alghouth that board is disabled, I still see the LCD updating the values. So the board is working fine with the board disabled and the plugin is not crushing. If I enable the board then after a day the plugin will crash. Could it be that maybe I have installed a different LCD library?

            Aldo

            Sent from my SM-G935V using Tapatalk

            Comment


            • #7
              Today again the plugin crashed. This is what I'm getting "WARNING: Failed getting InterfaceStatus from Arduino Plugin - the interface was not found in the list of active interfaces, the list may need to be refreshed." Any idea? Is possible to monitor for this error so I know it failed?

              Thanks,
              Aldo

              Comment


              • #8
                Aldo,

                What version of HS are you running as there was a problem in the Beta versions that caused some plugins to stop responding?

                I can not see how I can add a flag if the plugin crashes if the plugin is crashed then it is not running and can not do anything.

                Greig.
                Zwave = Z-Stick, 3xHSM100 7xACT ZDM230, 1xEverspring SM103, 2xACT HomePro ZRP210.
                X10 = CM12U, 2xAM12, 1xAW10, 1 x TM13U, 1xMS13, 2xHR10, 2xSS13
                Other Hardware = ADI Ocelot + secu16, Global Cache GC100, RFXtrx433, 3 x Foscams.
                Plugings = RFXcom, ActiveBackup, Applied Digital Ocelot, BLDeviceMatrix, BLGarbage, BLLAN, Current Cost, Global Cache GC100,HSTouch Android, HSTouch Server, HSTouch Server Unlimited, NetCAM, PowerTrigger, SageWebcamXP, SqueezeBox, X10 CM11A/CM12U.
                Scripts =
                Various

                Comment


                • #9
                  Greg,
                  I'm still running 3.0.0.326. This version never crash, I can have it running for months without reboot.

                  Unfortunately I'm not a programmer so I do not know how others are doing it. Mark the author of Insteon and few others, have the check on interface issues and interface crashes, maybe he is checking by pinging the ip and port, not sure.

                  Thanks,
                  Aldo

                  Originally posted by enigmatheatre View Post
                  Aldo,

                  What version of HS are you running as there was a problem in the Beta versions that caused some plugins to stop responding?

                  I can not see how I can add a flag if the plugin crashes if the plugin is crashed then it is not running and can not do anything.

                  Greig.

                  Comment

                  Working...
                  X