Announcement

Collapse
No announcement yet.

Relays turning on and off

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • labbie48
    replied
    Solved! Opened up a new board and set it up as board #2 and BAM, it works. What are the chances that the first board I try (being new at this) turns out to be bad! That would make anyone question their own ability!

    Thanks for the help.

    Leave a comment:


  • enigmatheatre
    replied
    Originally posted by labbie48 View Post
    Well, that didn't work, relay still switching on and off. Have another brand new board, will try that one tonight.
    If you can not get it to work I have a D1 somewhere I can try.
    If you capture a debug log and send it to me I might see better what is going on.
    Greig.

    Sent from my SM-G950F using Tapatalk

    Leave a comment:


  • labbie48
    replied
    Well, that didn't work, relay still switching on and off. Have another brand new board, will try that one tonight.

    Leave a comment:


  • labbie48
    replied
    Originally posted by enigmatheatre View Post
    You are correct that this should not happen. Where are you powering the relay from? If you power it directly from the board it might be pulling down the power enough to reset the board and the relay.

    Greig.
    Yes, powered from the board. Heading down to the workshop to power it from a wall wart and see what happens.

    Leave a comment:


  • wadesready
    replied
    opps my bad...not enough coffee hahaha

    Leave a comment:


  • enigmatheatre
    replied
    You are correct that this should not happen. Where are you powering the relay from? If you power it directly from the board it might be pulling down the power enough to reset the board and the relay.

    Greig.

    Leave a comment:


  • labbie48
    replied
    The watts are from a fibaro switch not the arduino. Every time it updates the pins, the relay goes off then bacl on.

    Leave a comment:


  • wadesready
    replied
    by what you have posted from your log, it is updating the watts being used. I see nowhere in your log where the relay is toggling off/on.

    Leave a comment:


  • labbie48
    started a topic Relays turning on and off

    Relays turning on and off

    I'm new with this Plug-in and got my board working using WiFi. I'm using the Arduino Beta with a WEMO D1 R1 to control a relay (as a test). The problem I have is every couple of minutes the relay toggles off and on. It seems to happen whenever the board updates. My main question is why this is happening and why does the board keep reconnecting and updating? I'm sure this is not normal. I would think that once it is connected, it would stay connected.
    Attached Files
Working...
X