Announcement

Collapse
No announcement yet.

Connection error, but still works

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Connection error, but still works

    Edit - it happens with both my wired arduino boards

    The last week or so the plugin fails to connect to one of my arduino boards (Mega board with ethernet), or it says connection failed, but I can still send commands to the boardt but not receive.
    I have tried to reflash it.
    When disabling and re enabling the plugin it says connected for about 30-60 sec then says disconnected.
    I also have a NodeMcu connected, it works fine

    I tried to install the plugin on a fresh HS install and created a duplicate board, it connected and stayed connected, so the issue must be with my current installation.
    Any way to do a fresh install of the plugin, without loosing my boards?

    HS v435
    Plugin v147
    Last edited by actibus; May 12th, 2018, 02:31 AM.

  • #2
    Here is a debug log from right after disable -> enable plugin
    Attached Files

    Comment


    • #3
      From the Debug it looks like a problem in your API Code that is flooding the plugin with data. You need to only send data when your value changes on the board or after x number of seconds but it looks like you are sending on every loop.

      Greig.
      Zwave = Z-Stick, 3xHSM100 7xACT ZDM230, 1xEverspring SM103, 2xACT HomePro ZRP210.
      X10 = CM12U, 2xAM12, 1xAW10, 1 x TM13U, 1xMS13, 2xHR10, 2xSS13
      Other Hardware = ADI Ocelot + secu16, Global Cache GC100, RFXtrx433, 3 x Foscams.
      Plugings = RFXcom, ActiveBackup, Applied Digital Ocelot, BLDeviceMatrix, BLGarbage, BLLAN, Current Cost, Global Cache GC100,HSTouch Android, HSTouch Server, HSTouch Server Unlimited, NetCAM, PowerTrigger, SageWebcamXP, SqueezeBox, X10 CM11A/CM12U.
      Scripts =
      Various

      Comment

      Working...
      X