Announcement

Collapse
No announcement yet.

1-WIRE setting disappear on board setup

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    1-WIRE setting disappear on board setup

    Very strange, last day I discovered on log this error:
    Code:
     
    ago-22 12:03:37 HSTouch Server Warning Exception on String Change callback: Value was either too large or too small for an Int32.
    ago-22 12:02:59 Arduino Plugin Error = Exception in BuildOneWirePins : String was not recognized as a valid Boolean.
    ago-22 12:02:58 Arduino Plugin Error = Rom = temperatura_calorifero_sala has an time out error
    ago-22 12:02:37 HSTouch Server Warning Exception on String Change callback: Value was either too large or too small for an Int32.
    ago-22 12:02:36 Arduino Plugin Error = Exception in Rom Timer Tick : Object reference not set to an instance of an object
    ago-22 12:02:15 Arduino Plugin Error = Exception in Rom Timer Tick : Object reference not set to an instance of an object
    ago-22 12:01:37 HSTouch Server Warning Exception on String Change callback: Value was either too large or too small for an Int32.
    ago-22 12:00:37 HSTouch Server Warning Exception on String Change callback: Value was either too large or too small for an Int32.
    ago-22 11:59:37 HSTouch Server Warning Exception on String Change callback: Value was either too large or too small for an Int32.
    ago-22 11:58:37 HSTouch Server Warning Exception on String Change callback: Value was either too large or too small for an Int32.
    ago-22 11:57:37 HSTouch Server Warning Exception on String Change callback: Value was either too large or too small for an Int32.
    ago-22 11:56:37 HSTouch Server Warning Exception on String Change callback: Value was either too large or too small for an Int32.
    Checking on arduino setup page, any 1-wire reference setup are missing:

    Click image for larger version

Name:	board2.JPG
Views:	87
Size:	44.2 KB
ID:	1242681

    In my case, 1-wire connected to pin N°4
    As you can see, pin 4 is not available on pin Add list (because used for 1-wire), but in the previous picture pin4 is not displayed.
    Click image for larger version

Name:	board2_2.jpg
Views:	91
Size:	38.4 KB
ID:	1242682


    Same problem to my friend.
    HS3 last version on raspberry (raspbian) and plugin version .148 (same problem with .147 version).

    #2
    that is strange. I have .148 and I have onewire available in the plugin. something must not have been installed properly during an update of the plugin.

    Comment


      #3
      Is, that is strange! Before the update I made a homeseer folder backup.
      Yesterday I restored the backup folder (plugin 0.147).
      Ok for some time, then an error on one of my 5 1-wire sensor and the 1-wire setting disappeared.
      I changed 4.7K resistor with 3.9K and now no any error on sensor but 1-wire setting was gone.
      Seems that if an 1-wire error occur, the plugin crash (crash only the 1-wire setting part).

      Comment


        #4
        My onewire setting also disappear after I add a board. I would like to see the output difference between the bit depth resolutions but its gone. Can it be changed somewhere else?.

        Comment


          #5
          I returned to hs3 windows and no problem with 1-wire. I had this issue only with linux (raspbian) edition.

          Comment


            #6
            Sorry, I must have missed this thread. I am getting my Zee back sometime in the next couple of weeks as I gave it to a friend to try so I have no way to test the Linux build but will look into this when I get it back.

            Greig.
            Zwave = Z-Stick, 3xHSM100� 7xACT ZDM230, 1xEverspring SM103, 2xACT HomePro ZRP210.
            X10 = CM12U, 2xAM12, 1xAW10, 1 x TM13U, 1xMS13, 2xHR10, 2xSS13
            Other Hardware = ADI Ocelot + secu16, Global Cache GC100, RFXtrx433, 3 x Foscams.
            Plugings = RFXcom, ActiveBackup, Applied Digital Ocelot, BLDeviceMatrix, BLGarbage, BLLAN, Current Cost, Global Cache GC100,HSTouch Android, HSTouch Server, HSTouch Server Unlimited, NetCAM, PowerTrigger, SageWebcamXP, SqueezeBox, X10 CM11A/CM12U.
            Scripts =
            Various

            Comment


              #7
              Just to add...

              I configured a pin as one-wire, then clicked on the 'stop adding one-wire devices' and noticed the one-wire option was now missing.
              --------------------------------------------------
              **** Do You "Cocoon"? ****

              Comment


                #8
                Hi Greig,
                Any hints to solve this issue? It happens on my HS3 PRO installed on Ubuntu 18.04. Sketch Version = 1.0.0.127, API Version = API1.0.0.118, Arduino plugin version 1.0.0.131.
                Thanks

                Comment


                  #9
                  Originally posted by amd_mda View Post
                  Hi Greig,
                  Any hints to solve this issue? It happens on my HS3 PRO installed on Ubuntu 18.04. Sketch Version = 1.0.0.127, API Version = API1.0.0.118, Arduino plugin version 1.0.0.131.
                  Thanks

                  I have tested V1.0.0.166 on my Home Troller Zee S2 and am not seeing this problem so I would suggest updating to that. It is in the Beta section of the updater but is very stable.

                  khriss75 You say you set the pin as Pin 4 but are running Linux as you should not be able to select pin 4 as this is used by the ethernet shield. Have you got advanced Ethernet ticked and if so did you read about this in the manual?

                  Greig.
                  Zwave = Z-Stick, 3xHSM100� 7xACT ZDM230, 1xEverspring SM103, 2xACT HomePro ZRP210.
                  X10 = CM12U, 2xAM12, 1xAW10, 1 x TM13U, 1xMS13, 2xHR10, 2xSS13
                  Other Hardware = ADI Ocelot + secu16, Global Cache GC100, RFXtrx433, 3 x Foscams.
                  Plugings = RFXcom, ActiveBackup, Applied Digital Ocelot, BLDeviceMatrix, BLGarbage, BLLAN, Current Cost, Global Cache GC100,HSTouch Android, HSTouch Server, HSTouch Server Unlimited, NetCAM, PowerTrigger, SageWebcamXP, SqueezeBox, X10 CM11A/CM12U.
                  Scripts =
                  Various

                  Comment

                  Working...
                  X