Announcement

Collapse
No announcement yet.

New to Arduino

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • New to Arduino

    Hi folks - I'm new to Arduino and planning my first project - would love some help validating my approach and filling in some gaps.

    I have a Heat N Glo fireplace that only works with their RF remote (ugh!). I want to be able to control it via home automation (duh .

    I found this project: https://github.com/milksteakmatt/Ardufuego where someone created an Arduino RF setup to send the Heat N Glo commands (he reverse engineered the protocol).

    So my plan is to replicate what he did, then hook it to HomeSeer. Here's my rough plan:
    1. Build what he did, then test that it works to control the fire place
    2. Buy another Arduino board and an Ethernet shield
    3. Download the arduino plugin for Homeseer, and configure it to address what I've built in #2
    4. Hook a wire from a pin in board #2 to a pin in board #1
    5. Use the plugin to write a sketch to board #2 that creates a device for each fire place setting (e.g. flame height, fan speed, on/off), and then .... I think ....paste my code into the plugin (so it auto generates it into a sketch). The code would send a signal over the wire I describe in #4 to send the proper RF command.
    Does this seem about right? I guess two other variants could be:
    A. Use a Wifi shield for board #2 (haven't researched that yet)
    B. Combine it all into one board by putting the ethernet/wifi shield onto the board from #1. Not sure what that means in terms of configuring via the plugin.

    Would love any and all suggestions! Also tutorials (or things to keep in mind) would be great! Thanks for the support .

  • #2
    somewhere on this board I read where somebody soldiered wires to the remote and used arduino to activate the different actions of the remote. I have never tried this, but I can see where it would work.

    Comment


    • #3
      I have a relay shield connected to the Arduino and I pulse the contacts :-) We live in an apartment complex and were given a remote control for the garage door and the complex sliding gate. It was FAR easier to simulate the pressing of the button to open the garage and complex gate. I used a power supply to replace the battery remote so it never runs out of power. Your situation will possibly be different as pressing the same button a few times will increase fan speed etc. My buttons only require a single press. The challenge is if you have no feedback, you will need to generate it....or ignore it

      Pete
      HS 2.2.0.11

      Comment


      • #4
        Thanks....dumb question - what's a relay shield? Did some searching but I'm not an electronics geek. I don't need to control all of the various settings of the fireplace by automation. Even just on off (which I believe is a single button on the remote; there are other buttons for other features).

        Comment


        • #5
          Have a look at something like this.....google arduino relay...you can get them in 1, 2, 4, 8 relay configurations..... Click image for larger version

Name:	relay_board.jpg
Views:	13
Size:	55.5 KB
ID:	1248957
          HS 2.2.0.11

          Comment


          • #6
            Got it thanks. Will look. In the meantime, any other thoughts on the other questions/architecture assuming I can't just use relay on off?

            Comment


            • #7
              Nothing else comes to mind....Going down an RF path needs considerable expertise to extract the data, analyse and have a device that reproduces the signals. With my blind controller it was far easier shorting the buttons out with a relay....
              HS 2.2.0.11

              Comment


              • #8
                Funny, I plan on doing the exact same thing. Two weeks ago I started looking at conrtolling my unit and found instructions using an Arduino unit, so after getting a unit and playing a bit I am almost ready to begin this project. I am going to use a NodeMCU ESP8266 with an RF transmitter attached and plug it into the power under the fireplace. I have an in-wall unit so the board will be hidden in the wall with all the electronics. To me, the beauty of this method is that if/when I move, I don't have to do anything and I have not buggered a remote.

                The project uses:
                1. A NodeMCU
                2. An RF Transmitter
                3. An RF Receiver
                4. An RF Decoder
                Check out this video which is what I found for my starting point. He uses an Alexa to control things, but I intend to use HomeSeer, and then use a smart speaker via HomeSeer for voice. He also has his code posted, and linked in the video write-up.

                Karl

                Comment


                • #9
                  Wow that's a great video. I'm giving it a try too! Let's keep in touch here to see how things go...

                  Comment


                  • #10
                    Will do! I used the start that video gave me to sidetrack me into automating some of our Halloween stuff using the NodeMCU and web pages to start/stop things, etc. so it will be a bit before I start on this project, but it is something I have wanted done since having the fireplace installed 2 years ago. Originally I was going to try to wire something in, but I do prefer the simplicity of installation this is providing. Even if it will take some work to get the unit going I think it is going to be easier for me than trying to read the schematics and figure out some way to hard wire it in a way that would allow the remote to be used as well.

                    Comment


                    • #11
                      Cool - would love to know how you end up using the NodeMCU and web pages / homeseer in the meantime. I've never done networking in C++ and would prefer complete exampels / thinking WRT homeseer vs. having to reverse engineer it myself.

                      Comment


                      • #12
                        See my reply to the NodeMCU+Wifi guide for newbies? thread. Your questioned part is short but any discussion should probably happen there. I wrote that right before I saw this thread.

                        Comment


                        • #13
                          ksum - I got my NooElec SDR USB receiver so I could try to follow the YouTube video. But I can't get SDR Sharp to recognize the receiver.

                          When I plug it in I try to follow this article of installation: http://www.nooelec.com/store/qs/

                          But the NESDR/receiver does not appear in the list of USB devices. Any suggestions?

                          Comment


                          • #14
                            larrywal32 - have you tried the support chat on the NooElec web site? There is a Support item at the bottom left corner of the desktop site. At least in my chrome browser. It pops open a chat window.

                            Maybe try a different USB port? Perhaps you are on a USB 3 and it needs the older protocol, or vice-versa?

                            I have not made the purchase yet so I am sorry that I can't be much help troubleshooting the installation..

                            Comment


                            • #15
                              Thx no worries - waiting on support now.

                              Comment

                              Working...
                              X