No announcement yet.

Nodemcu not connecting

  • Filter
  • Time
  • Show
Clear All
new posts

  • Nodemcu not connecting

    I had the latest Arduino IDE installed prior to trying this plugin and while I have uninstalled the IDE and installed the build recommended, is it possible the newer build left something behind that would keep the plugin from connecting with a NodeMCU ES8266 unit? I have been able to ping the unit from the HomeSeer PC but cannot connect to it with the plugin.

    I do get this error in the logs:
    Error = Exception in BuildIRSetup : Object reference not set to an instance of an object.
    The Type is set to NodeMcu. If I have set the type to NodeMcu API and uploaded the sketch, I get a connection. I wanted to test the non-API version though and just control an output pin.


  • #2
    Can I assume this is Windows? One item that I ran into was the Windows Firewall does not normally permit the Arduino board to connect back to the plugin. This causes the board to fail to initialize and setup the pins, etc. If this is your problem you need to setup a rule in Firewall to allow external systems to connect to the HSPI_Arduino.exe at port 8888 (the default - whatever the plugin is set to listen on).

    Remember the plugin connects to the Arduino board *but* the board also connects back to the plugin. Network access in both directions is required in order to successfully connect to the board from Homeseer.


    • #3
      BTW - the error you have above may be a different problem. I initially had that issue because I basically did the same thing (wrong version). After uninstalling/reinstalling the IDE and setting up the COM port in the plugin (which is actually not required since with a NodeMCU you probably using WiFi). The IDE is going to use the COM port/USB and thus this can cause the plugin to fail. I suggest you ensure the plugin is setup correctly and then reboot your system. This solved this/these types of problems for me.


      • #4
        Does the ide have to sit on the HomeSeer system? I used a different system for that.