Announcement

Collapse
No announcement yet.

Connection Issues and Input Changes Not Being Detected

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Connection Issues and Input Changes Not Being Detected

    I'm attempting a first time installation of a new Uno with an Ethernet Shield (not genuine, both SunFounder) and am experiencing two significant issues. The Arduino Plugin is version 1.0.0.131 and is running in trial mode. The Arduino IDE is version 1.6.8 as per the plugin instructions.

    1. Using the Homeseer/Arduino plugin configuration page, I set up the Uno board with one input pin (pin 2) and one output pin (pin 3). I am able to successfully control the output pin, turning it 'On' and 'Off' from Homeseer. However, the plugin will not read the input pin state. It remains '0' regardless of the state of the pin on the Uno. I added a serial.println() command to the sketch and confirmed via the Arduino IDE Serial Monitor that the Uno is indeed reading the change in input state. However, Homeseer does not see the change.

    2. The 'Connection' function is not behaving logically to me. First, if I click 'Connect', nothing happens. If I then enable the checkbox for 'Auto Connect', it appears to connect. Then, after a variable period of time (sometimes a few seconds, sometimes several minutes or longer), it disconnects with a 'Connection ERROR'. Sometimes it attempts a couple of reconnects, but they fail. If I simply uncheck the 'Auto Connect' box, then re-check it, the connection appears to re-establish. HOWEVER, and this is the odd part, it doesn't matter if Homeseer shows 'Connected' or 'Disconnected', I can still control the Uno output pin (see #1 above). And, when it shows 'Connected', if I remove power from the Uno and disconnect it from my network, Homeseer still shows it as 'Connected' (even if the Uno is left disconnected and powered down overnight).

    I would appreciate some guidance with these issues.

    Thank you,
    Mike

  • #2
    Solved... mostly. I run my Homeseer system headless, more or less, meaning I almost always access it via a browser on a networked machine, not via the monitor on my Homeseer machine. So, when I installed the Arduino plugin, I did not see the UAC (User Account Control) nag screen asking to allow the Arduino plugin to make changes to the computer. I happened to turn on the monitor today and my Homeseer machine was patiently waiting for my response. Once I granted permission, the plugin started working normally. It appears to be staying connected, though it's only been a couple of hours since I enabled it.

    However, the one anomaly that still exists is the output commands still function when the plugin is 'Disconnected'. The input pins do not work, as I would expect, but the output function doesn't seem to care whether is 'Connected' or not, I can still change the output state from Homeseer. This is not a problem for my current usage, but I would consider it unexpected behavior. I would think that if the plugin is disconnected, all communication to the Uno would cease.

    Mike

    Comment

    Working...
    X