Announcement

Collapse
No announcement yet.

Anyone using 1.0.0.155?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Anyone using 1.0.0.155?

    Hi, just looking for some feedback before I take the plunge and upgrade.

    Thanks

  • #2
    I updated a few days ago.
    I am using two arduino's.
    The first one is a Uno Mega, where all the digital inputs and output are active.
    The update has been a great improvement for the delay when using digital inputs.
    Using a pushbutton on these, we had to maintain it for about 1sec with the former version, now it is instant, just like you expect a pushbutton to be.
    WAF is getting a lot better!

    The second board is a Arduino Uno mainly used for 1-wire temperatures.
    This board cannot connect anymore, but I am confident this will be solved very soon
    Visit zee e-maison : http://www.e-maison.com

    Comment


    • #3
      Thanks for the feedback Pierre. Hope you get your Uno sorted soon.

      Comment


      • #4
        I looked for the release notes, but was unable to find them for these latest releases. I am sure that I am looking in the wrong place.... are they not in the one of the sticky post in this forum?

        Thanks for any help.
        Billy Draper

        Comment


        • #5
          All plugin authors now have the ability to add them to the updater so everyone knows they are all in the same place. I will add something about this in the old sticky. Scroll to the beta section of he updater and click on the Release Info link.

          Greig.

          Sent from my SM-G950F using Tapatalk

          Zwave = Z-Stick, 3xHSM100� 7xACT ZDM230, 1xEverspring SM103, 2xACT HomePro ZRP210.
          X10 = CM12U, 2xAM12, 1xAW10, 1 x TM13U, 1xMS13, 2xHR10, 2xSS13
          Other Hardware = ADI Ocelot + secu16, Global Cache GC100, RFXtrx433, 3 x Foscams.
          Plugings = RFXcom, ActiveBackup, Applied Digital Ocelot, BLDeviceMatrix, BLGarbage, BLLAN, Current Cost, Global Cache GC100,HSTouch Android, HSTouch Server, HSTouch Server Unlimited, NetCAM, PowerTrigger, SageWebcamXP, SqueezeBox, X10 CM11A/CM12U.
          Scripts =
          Various

          Comment


          • #6
            Thanks Greig. I see the notes in the updater now for 1.0.0.155
            Billy Draper

            Comment


            • #7
              i am getting lots of errors?
              May-26 10:58:39 PM Arduino Plugin Error = Exception in RecievedData4 : Index was outside the bounds of the array.
              May-26 10:58:39 PM Arduino Plugin Error = Exception in RecievedData3 : Index was outside the bounds of the array.
              May-26 10:58:39 PM Arduino Plugin Error = Exception in RecievedData1 : Index was outside the bounds of the array.
              May-26 10:58:19 PM Arduino Plugin Error = Exception in RecievedData4 : Index was outside the bounds of the array.
              May-26 10:58:19 PM Arduino Plugin Error = Exception in RecievedData3 : Index was outside the bounds of the array.
              May-26 10:58:19 PM Arduino Plugin Error = Exception in RecievedData1 : Index was outside the bounds of the array.
              May-26 10:58:09 PM Arduino Plugin Error = Exception in RecievedData4 : Index was outside the bounds of the array.
              May-26 10:58:09 PM Arduino Plugin Error = Exception in RecievedData3 : Index was outside the bounds of the array.
              May-26 10:58:09 PM Arduino Plugin Error = Exception in RecievedData1 : Index was outside the bounds of the array.
              May-26 10:57:59 PM Arduino Plugin Error = Exception in RecievedData4 : Index was outside the bounds of the array.
              May-26 10:57:59 PM Arduino Plugin Error = Exception in RecievedData3 : Index was outside the bounds of the array.
              May-26 10:57:59 PM Arduino Plugin Error = Exception in RecievedData1 : Index was outside the bounds of the array.
              May-26 10:57:49 PM Arduino Plugin Error = Exception in RecievedData4 : Index was outside the bounds of the array.
              May-26 10:57:49 PM Arduino Plugin Error = Exception in RecievedData3 : Index was outside the bounds of the array.

              Comment


              • #8
                Originally posted by usLEDsupply View Post
                i am getting lots of errors?
                May-26 10:58:39 PM Arduino Plugin Error = Exception in RecievedData4 : Index was outside the bounds of the array.
                May-26 10:58:39 PM Arduino Plugin Error = Exception in RecievedData3 : Index was outside the bounds of the array.
                May-26 10:58:39 PM Arduino Plugin Error = Exception in RecievedData1 : Index was outside the bounds of the array.
                May-26 10:58:19 PM Arduino Plugin Error = Exception in RecievedData4 : Index was outside the bounds of the array.
                May-26 10:58:19 PM Arduino Plugin Error = Exception in RecievedData3 : Index was outside the bounds of the array.
                May-26 10:58:19 PM Arduino Plugin Error = Exception in RecievedData1 : Index was outside the bounds of the array.
                May-26 10:58:09 PM Arduino Plugin Error = Exception in RecievedData4 : Index was outside the bounds of the array.
                May-26 10:58:09 PM Arduino Plugin Error = Exception in RecievedData3 : Index was outside the bounds of the array.
                May-26 10:58:09 PM Arduino Plugin Error = Exception in RecievedData1 : Index was outside the bounds of the array.
                May-26 10:57:59 PM Arduino Plugin Error = Exception in RecievedData4 : Index was outside the bounds of the array.
                May-26 10:57:59 PM Arduino Plugin Error = Exception in RecievedData3 : Index was outside the bounds of the array.
                May-26 10:57:59 PM Arduino Plugin Error = Exception in RecievedData1 : Index was outside the bounds of the array.
                May-26 10:57:49 PM Arduino Plugin Error = Exception in RecievedData4 : Index was outside the bounds of the array.
                May-26 10:57:49 PM Arduino Plugin Error = Exception in RecievedData3 : Index was outside the bounds of the array.
                This is the same error as another user is experiencing but I am struggling to track it down. Please, can you send me a debug log of this to see if it shows up anything?

                Greig.
                Zwave = Z-Stick, 3xHSM100� 7xACT ZDM230, 1xEverspring SM103, 2xACT HomePro ZRP210.
                X10 = CM12U, 2xAM12, 1xAW10, 1 x TM13U, 1xMS13, 2xHR10, 2xSS13
                Other Hardware = ADI Ocelot + secu16, Global Cache GC100, RFXtrx433, 3 x Foscams.
                Plugings = RFXcom, ActiveBackup, Applied Digital Ocelot, BLDeviceMatrix, BLGarbage, BLLAN, Current Cost, Global Cache GC100,HSTouch Android, HSTouch Server, HSTouch Server Unlimited, NetCAM, PowerTrigger, SageWebcamXP, SqueezeBox, X10 CM11A/CM12U.
                Scripts =
                Various

                Comment


                • #9
                  Greig, I finally got around to update to the Beta 1.0.0.155 from the previous 146.

                  Some comments after the upgrade.

                  I have 4 functional boards, all different.

                  1. Arduino Uno - Ethernet - Standard Sketch
                  2. Wemos Mini - Wireless - API (always been a issue with disconnects)
                  3. Arduino Uno - USB - API
                  4. Wemos Mini - Wireless - Standard

                  The Upgrade went smoothly with only board 4 showing a mismatch, uploaded the new sketch, connected no problems. The other 3 boards also connected as per normal.
                  A few days later board 1 decided show a mismatch, so I downloaded the new sketch and uploaded the board. After this the board refused to connect no matter what I did. Finally I fudged the version number in the old 146 sketch to 155 uploaded the board, it connected immediately and working fine. Still in this state now.

                  Board 2 has always been a PIA, some times it will go for months other times disconnect in minutes (lately disconnects in minutes) It disconnects from the WIFI AP so HS doesn't have a chance. It was originally a NodeMCU but I changed it to see if I could improve connectivity. I have recently upgraded my wifi system and the signal is quite strong at this location now. Also placed board 4 at this location to eliminate signal issues. I would like to hear from others running the API sketch on a Wifi esp8266 board. It might be just my bad programming. Also surprised that API boards did not get a new sketch in this Beta release.

                  Boards 3 and 4 working Fine. Yes I know I should change board 3 to Ethernet.

                  Thank You for the continued support and development of this plugin. Please don't take any of the above as any criticism, it's only some feedback for your hard work.























                  Comment


                  • #10
                    Greig, i just upgraded t0 .157 hoping to fix a OneFlash issue. My log is filling with same Index out of bounds errors. Short debug file attached. Happy to help isolate if you can debug it. thanks
                    Attached Files

                    Comment


                    • #11
                      Greg, Great plugin! After upgrading, I'm having the same problem with out of bound errors on the log.
                      Attached Files

                      Comment


                      • #12
                        Also, if it helps , I never have had any type of temperature sensor, all I have is a mega 2560 and 8 relay card.

                        Comment


                        • #13
                          HI All,

                          FYI I have traced the problem down to the Uno not having enough memory to run the new sketch. I have worked out a fix for it but need to get time to code this in.

                          Greig.
                          Zwave = Z-Stick, 3xHSM100� 7xACT ZDM230, 1xEverspring SM103, 2xACT HomePro ZRP210.
                          X10 = CM12U, 2xAM12, 1xAW10, 1 x TM13U, 1xMS13, 2xHR10, 2xSS13
                          Other Hardware = ADI Ocelot + secu16, Global Cache GC100, RFXtrx433, 3 x Foscams.
                          Plugings = RFXcom, ActiveBackup, Applied Digital Ocelot, BLDeviceMatrix, BLGarbage, BLLAN, Current Cost, Global Cache GC100,HSTouch Android, HSTouch Server, HSTouch Server Unlimited, NetCAM, PowerTrigger, SageWebcamXP, SqueezeBox, X10 CM11A/CM12U.
                          Scripts =
                          Various

                          Comment


                          • #14
                            I have uploaded V.158 to the Beta section in the updater. This has a checkbox that should be ticked if using an Uno. It modifies the sketch to prevent memory errors.
                            Zwave = Z-Stick, 3xHSM100� 7xACT ZDM230, 1xEverspring SM103, 2xACT HomePro ZRP210.
                            X10 = CM12U, 2xAM12, 1xAW10, 1 x TM13U, 1xMS13, 2xHR10, 2xSS13
                            Other Hardware = ADI Ocelot + secu16, Global Cache GC100, RFXtrx433, 3 x Foscams.
                            Plugings = RFXcom, ActiveBackup, Applied Digital Ocelot, BLDeviceMatrix, BLGarbage, BLLAN, Current Cost, Global Cache GC100,HSTouch Android, HSTouch Server, HSTouch Server Unlimited, NetCAM, PowerTrigger, SageWebcamXP, SqueezeBox, X10 CM11A/CM12U.
                            Scripts =
                            Various

                            Comment


                            • #15
                              Cool, will look later, tomorrow as just been to hospital to have hand stitched due to being a dumb ***, so not in a good place ATM the pain is bad :-( hopefully tomorrow will be better

                              Comment

                              Working...
                              X