No announcement yet.

'CONNECT' button will not connect to board

  • Filter
  • Time
  • Show
Clear All
new posts

    'CONNECT' button will not connect to board

    Hey All,
    Dusting of my old HS system after recently moving house.
    Have been playing around with some new Arduino configurations for various things I would like to interface with, and have started getting some odd behaviour from the Plugin.

    If I do the following.
    1) Create a New Board, using Com5
    2) Upload the Sketch using the Arduino IDE, with success.
    3) Try connecting using the 'connect' button either in the device management screen, or the Plugin screen it simply stays disconnected.
    4) Select 'AutoConnect' and away it goes, no issues at all....

    I can see in the logs this soon after I press 'connect'
    - Board 1 Version and Plugin Version are compatible.
    But nothing further happens.

    When I de-select, then re-select the 'Auto Connect' option, i see this.
    - Connected to Board No:1 on COM5
    - Updating pins on Board No: 1
    - Updating Values on Board No: 1
    - setting Board 1 ID 715 to Auto Connect

    The Home seer logs show pretty much what I've shown above.

    The Plugin logs I created show;
    7/9/2021 ,14:20:32.278 Data Received:Version 1 HS3
    7/9/2021 ,14:20:32.290 Board 1 Version and Plugin Version are compatible.
    7/9/2021 ,14:20:32.311 Sent to com port No:5 = 1 C ,Connect Command
    7/9/2021 ,14:20:32.383 Data Received:Conneced 1

    Now, to me it looks like an unrecognised character in the last line, from here nothing more happens.

    When I connect using the 'Auto Connect option, this response is normal, and the cycle continues no problems;
    7/9/2021 ,14:20:54.743 postBackProc AutoConnect1=checked&id=AutoConnect1
    7/9/2021 ,14:20:54.749 Data Received:Connected 1
    7/9/2021 ,14:20:54.754 Connected to Board No:1 on COM5
    7/9/2021 ,14:20:54.825 Updating pins on Board No: 1

    No unrecognised Character.....
    I feel this is part of my problem, but cannot find a way to fix it.

    - Tried different ports
    - Tried different UNO Boards
    - I've tried uninstalling and re-installing the plugin.
    - I've tried re-installing HS. (Not clean, just repair)

    (Yet to try over ethernet)

    The problem remains.
    Any suggestions on steps to rectify, or explanation as to what is going on would be much appreciated

    Many Thanks in Avdance,
    Steve Button
    HS system detail below, Logs attached
    Current Date/Time: 7/09/2021 2:41:24 PM
    HomeSeer Version: HS3 Pro Edition
    Operating System: Microsoft Windows 10 Pro - Work Station
    System Uptime: 0 Days 0 Hours 22 Minutes 40 Seconds
    IP Address:
    Number of Devices: 38
    Number of Events: 109
    Available Threads: 400
    HSTouch Enabled: True
    Event Threads: 0
    Event Trigger Eval Queue: 0
    Event Trigger Priority Eval Queue: 0
    Device Exec Queue: 0
    HSTouch Event Queue: 0
    Email Send Queue: 0
    Anti Virus Installed: Windows Defender
    In Virtual Machine: No MFG: hewlett-packard
    Enabled Plug-Ins Arduino Plugin BLShutdown Harmony Hub Harmony Hub Z-Wave
    Attached Files

    Apologies, the unreconized charecter did not come through after publishing.
    Please see here
    Click image for larger version

Name:	Capture.PNG
Views:	95
Size:	27.8 KB
ID:	1494057



      V is a very old version of the plugin and as a first step I would update to the HS3 Beta V1.0.0.166 and download and update the sketch on your board. If the problem persists then just get back to me.

      Zwave = Z-Stick, 3xHSM100� 7xACT ZDM230, 1xEverspring SM103, 2xACT HomePro ZRP210.
      X10 = CM12U, 2xAM12, 1xAW10, 1 x TM13U, 1xMS13, 2xHR10, 2xSS13
      Other Hardware = ADI Ocelot + secu16, Global Cache GC100, RFXtrx433, 3 x Foscams.
      Plugings = RFXcom, ActiveBackup, Applied Digital Ocelot, BLDeviceMatrix, BLGarbage, BLLAN, Current Cost, Global Cache GC100,HSTouch Android, HSTouch Server, HSTouch Server Unlimited, NetCAM, PowerTrigger, SageWebcamXP, SqueezeBox, X10 CM11A/CM12U.
      Scripts =


        Hi Greig,

        Thanks for the response.
        I didn't realise there was a later version, I will update ASAP.
        Something I neglected to mention yesterday was, that this has been flawless in the past, USB and Ethernet.
        I'm now running different hardware for the Homeseer Server, but hadn't given it much thought until today whilst fluffing about.

        I think I have found the culprit, not 100%, but I conducted the same tests while connected via Ethernet, and things work fine/as expected.
        So, I went back to an API sketch I was trialling before these issues appeared, which when connected via USB seemed to slowly get more and more unresponsive. After some time it got to the point that I had to reset the board, and also the plugin, and it would start all over.... Figured is was my crappy code, and I was doing something completely wrong causing it to slow up over time... I tried connected via ethernet, and the this API sketch worked fine!!

        I have a feeling it is the USB interface on the computer I'm using?? Seems things just get clogged up, have zero clues how, but if the code is the same for both examples, the boards are the same, and only the communication method is different, it seems plausible. ( I did try different ports, but they are both front mount, so likely from the same area of MB??)

        Anyway, I'll update the plug in, and conduct some more tests and let you know if I have more issues.

        Either way, if things can be uploaded and the Ethernet connection works, It will do for now.

        Many Thanks,


          Just Updated, and all is working again when using the 'connect' button and USB.
          Thanks for the tip.