Announcement

Collapse
No announcement yet.

UNO with ENC28J60

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • UNO with ENC28J60

    Hi Greig

    Have you used the ENC28J60 ethernet interface with a UNO with your code ? I've been able to use UIPEthernet replacement that supports these smaller ethernet interfaces (https://github.com/ntruchsess/arduino_uip)

    I've loaded the libraries and compiled their sample code and that seems to work. I've tried it with the HS INO file and I cant seem to ping the IP address of the device. I thought I might have run out of code space so I'm going to try it with a MEGA to see if that's the issue.

    My 2 W5100s have been lost in the mail now for 6 weeks so its a lengthy wait to get replacements.

    Just curious as to what hardware you've tried..

    Thanks..pete
    HS 2.2.0.11

  • #2
    HI Pete,

    I do have one somewhere as I looked at them a long time ago but never did get it going. The new Library looks good. I will add it to the to do list which is getting very long.

    Greig.
    Zwave = Z-Stick, 3xHSM100� 7xACT ZDM230, 1xEverspring SM103, 2xACT HomePro ZRP210.
    X10 = CM12U, 2xAM12, 1xAW10, 1 x TM13U, 1xMS13, 2xHR10, 2xSS13
    Other Hardware = ADI Ocelot + secu16, Global Cache GC100, RFXtrx433, 3 x Foscams.
    Plugings = RFXcom, ActiveBackup, Applied Digital Ocelot, BLDeviceMatrix, BLGarbage, BLLAN, Current Cost, Global Cache GC100,HSTouch Android, HSTouch Server, HSTouch Server Unlimited, NetCAM, PowerTrigger, SageWebcamXP, SqueezeBox, X10 CM11A/CM12U.
    Scripts =
    Various

    Comment


    • #3
      Greig

      I've revisited this again with the UIPEthernet library and its definately a no go...

      I've changed the Arduino code to:

      #define UDP_TX_PACKET_MAX_SIZE 24

      #include <UIPEthernet.h>
      #include <UIPUdp.h>

      With wireshark I can see:

      1/ The initial connect message go out from the Arduino ie: Connect 1
      2/ Reply from HS is 1C
      3/ Nothing more

      I see from the installation of the Etherten

      1/ Initial Connect Message from Arduino: Connect 1
      2/ Reply from HS: 1C
      3/ Arduino sends the code version number
      4/ Arduino sends "Connected 1"
      5/ HS sends: 1 X

      You'd think UDP was UDP :-) There must be something different with the library implementation...bugger

      Pete
      HS 2.2.0.11

      Comment

      Working...
      X