Announcement

Collapse
No announcement yet.

Arduino Plugin feature requests

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #61
    Doug,

    Ok I think I get what you want now and I may have misunderstood what you were after. The problem is that I receive and handle the data from the onewire bus in the plugin and if it is strange data there is an error. I have no way of polling the bus from the plugin so I would need to try and handle the errors on the board or find a way to poll the device if there is an error.
    I do not have a lot of time at the moment but I will try and set up a test to see if this is possible to add.

    Greig.
    Zwave = Z-Stick, 3xHSM100� 7xACT ZDM230, 1xEverspring SM103, 2xACT HomePro ZRP210.
    X10 = CM12U, 2xAM12, 1xAW10, 1 x TM13U, 1xMS13, 2xHR10, 2xSS13
    Other Hardware = ADI Ocelot + secu16, Global Cache GC100, RFXtrx433, 3 x Foscams.
    Plugings = RFXcom, ActiveBackup, Applied Digital Ocelot, BLDeviceMatrix, BLGarbage, BLLAN, Current Cost, Global Cache GC100,HSTouch Android, HSTouch Server, HSTouch Server Unlimited, NetCAM, PowerTrigger, SageWebcamXP, SqueezeBox, X10 CM11A/CM12U.
    Scripts =
    Various

    Comment


    • #62
      Originally posted by enigmatheatre View Post
      Doug,

      Ok I think I get what you want now and I may have misunderstood what you were after. The problem is that I receive and handle the data from the onewire bus in the plugin and if it is strange data there is an error. I have no way of polling the bus from the plugin so I would need to try and handle the errors on the board or find a way to poll the device if there is an error.
      I do not have a lot of time at the moment but I will try and set up a test to see if this is possible to add.

      Greig.
      I think Doug has a good idea, though I don't see any errors here. If the board receives updated from the OneWire devices, how about not updating the device value until there are three successive error reports. Or if the OneWire devices only report when there is a change not showing error on the HS device unless it persists for more than 3000ms? Either way would leave the HS device at the last reported value until the error was proven persistent.
      Randy Prade
      Aurora, CO
      Prades.net

      PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

      Comment


      • #63
        Originally posted by rprade View Post
        I think Doug has a good idea, though I don't see any errors here. If the board receives updated from the OneWire devices, how about not updating the device value until there are three successive error reports. Or if the OneWire devices only report when there is a change not showing error on the HS device unless it persists for more than 3000ms? Either way would leave the HS device at the last reported value until the error was proven persistent.
        Ok I now think I know what your talking about. There are two ways that the error is produced. One is if the bus sends bad data and the second is a time out on the device not updating so I guess it is the bad data that is the problem as this sets the device in the the error state immediately but the time out waits 2min before setting the device in the error state.

        I will see what I can do.

        Greig.
        Zwave = Z-Stick, 3xHSM100� 7xACT ZDM230, 1xEverspring SM103, 2xACT HomePro ZRP210.
        X10 = CM12U, 2xAM12, 1xAW10, 1 x TM13U, 1xMS13, 2xHR10, 2xSS13
        Other Hardware = ADI Ocelot + secu16, Global Cache GC100, RFXtrx433, 3 x Foscams.
        Plugings = RFXcom, ActiveBackup, Applied Digital Ocelot, BLDeviceMatrix, BLGarbage, BLLAN, Current Cost, Global Cache GC100,HSTouch Android, HSTouch Server, HSTouch Server Unlimited, NetCAM, PowerTrigger, SageWebcamXP, SqueezeBox, X10 CM11A/CM12U.
        Scripts =
        Various

        Comment


        • #64
          Ok I have added a trap so that the rom has to send the error 3 times to the plugin before it will update the device to an error state. If this fixes the problem I may add this as an option on the config page as new people adding new one wire devices wont want to wait to see the errors.

          Try the new build form Here

          Greig.
          Zwave = Z-Stick, 3xHSM100� 7xACT ZDM230, 1xEverspring SM103, 2xACT HomePro ZRP210.
          X10 = CM12U, 2xAM12, 1xAW10, 1 x TM13U, 1xMS13, 2xHR10, 2xSS13
          Other Hardware = ADI Ocelot + secu16, Global Cache GC100, RFXtrx433, 3 x Foscams.
          Plugings = RFXcom, ActiveBackup, Applied Digital Ocelot, BLDeviceMatrix, BLGarbage, BLLAN, Current Cost, Global Cache GC100,HSTouch Android, HSTouch Server, HSTouch Server Unlimited, NetCAM, PowerTrigger, SageWebcamXP, SqueezeBox, X10 CM11A/CM12U.
          Scripts =
          Various

          Comment


          • #65
            marekd1 and pmiller,

            For your info LCD is now supported in the Beta that is in the updater.

            Greig.
            Zwave = Z-Stick, 3xHSM100� 7xACT ZDM230, 1xEverspring SM103, 2xACT HomePro ZRP210.
            X10 = CM12U, 2xAM12, 1xAW10, 1 x TM13U, 1xMS13, 2xHR10, 2xSS13
            Other Hardware = ADI Ocelot + secu16, Global Cache GC100, RFXtrx433, 3 x Foscams.
            Plugings = RFXcom, ActiveBackup, Applied Digital Ocelot, BLDeviceMatrix, BLGarbage, BLLAN, Current Cost, Global Cache GC100,HSTouch Android, HSTouch Server, HSTouch Server Unlimited, NetCAM, PowerTrigger, SageWebcamXP, SqueezeBox, X10 CM11A/CM12U.
            Scripts =
            Various

            Comment


            • #66
              Originally posted by enigmatheatre View Post
              Ok I have added a trap so that the rom has to send the error 3 times to the plugin before it will update the device to an error state. If this fixes the problem I may add this as an option on the config page as new people adding new one wire devices wont want to wait to see the errors.

              Try the new build form Here

              Greig.
              I installed the new build and it is working fine. Since I never see errors here, I will cause one later and see what happens.
              Randy Prade
              Aurora, CO
              Prades.net

              PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

              Comment


              • #67
                Originally posted by enigmatheatre View Post
                Ok I have added a trap so that the rom has to send the error 3 times to the plugin before it will update the device to an error state. If this fixes the problem I may add this as an option on the config page as new people adding new one wire devices wont want to wait to see the errors.

                Try the new build form Here

                Greig.
                Great! I'll try it as soon as I get home later today.

                Doug

                Comment


                • #68
                  Originally posted by enigmatheatre View Post
                  marekd1 and pmiller,

                  For your info LCD is now supported in the Beta that is in the updater.

                  Greig.
                  I am not sure how to cause an error. I've tried disconnecting the data line, the power line and the ground line for 3 minutes each and have not gotten an error. The temperature remains at the last reading. That is the behavior I would want, but I guess it should show an error at some point. How long should it take before an error condition is shown?

                  EDIT: I tried again on another board and an error shows up after about a minute, but not as soon as it is disconnected. It retained the last reading for that minute, so I think this change is going to work.
                  Randy Prade
                  Aurora, CO
                  Prades.net

                  PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

                  Comment


                  • #69
                    Originally posted by enigmatheatre View Post
                    Ok I have added a trap so that the rom has to send the error 3 times to the plugin before it will update the device to an error state. If this fixes the problem I may add this as an option on the config page as new people adding new one wire devices wont want to wait to see the errors.

                    Try the new build form Here

                    Greig.

                    Hmm. I still seem to be getting the errors sneaking through at about the same rate. They are fairly infrequent (maybe 1 out of 200 measurements), but when they happen it looks like it sticks around long enough to get by your trap? Either than or things are still not being trapped.

                    Thanks for considering this enhancement. (I'll email the log)
                    Doug

                    Comment


                    • #70
                      Not sure if this has been mentioned before, but interfacing to an RFID/NFC reader? The WAF would be huge if my wife could swipe a fob and it'd unlock the door. Also could be used to track specific people who enter to announce their arrival or run particular events.

                      This is the one I have:

                      http://www.dx.com/p/13-56mhz-nfc-rfi...2#.Veibs_lVhBc

                      PS I just bought the plugin today as my trial was going to end in two days. I was sold once I had a $3 PIR able to detect my motion and trigger an event to turn some lights on at around midnight last night. The possibilities are endless with this plugin and the source of cheap Arduino's and sensors.

                      Comment


                      • #71
                        Originally posted by DMcKnight View Post
                        Hmm. I still seem to be getting the errors sneaking through at about the same rate. They are fairly infrequent (maybe 1 out of 200 measurements), but when they happen it looks like it sticks around long enough to get by your trap? Either than or things are still not being trapped.

                        Thanks for considering this enhancement. (I'll email the log)
                        Doug
                        I've put in place a work-around for handling this in a script. What I do, is read the value of the Arduino device and, if it is a valid temperature write the value to another device used for this purpose only. This script is triggered on the change of the Arduino device value.

                        I still think there is value is making the one-wire system more robust in software, but there are other ways to skin this particular cat.

                        regards
                        Doug

                        Comment


                        • #72
                          it would be great if there was a feature for the analog inputs that would only send a value if it has changed more than "X" so you wouldn't be wasting bandwidth if your sensor value hasn't changed yet you would still get fast responses when it does change

                          Comment


                          • #73
                            Support for the RPI would be awesome :-)

                            Comment


                            • #74
                              I may have asked this before, but it would be great if a variable could be pushed to an arduino board somehow, for example as a double you may push a variable temp=21, this would tell the arduino board to set a variable (e.g. name = temp) to 21.00

                              The reason I ask this, is that I think the API is great, but it would be great to be able to offload stuff to just the Arduino and have it handle the PLC side of things, but be able to do that based on input from homeseer, so it might push onewire temperatures for inlet and outlet air for example to homeseer, and you set the variable for wanted temperature, so that way if homeseer is not running the arduino still keeps going doing it's thing, but later on you could push a different temperature and the program goes about doing it's thing with the new temperature.

                              That is just a simple scenario, but no doubt variables would be handy for many other features as well.

                              Main thing is that it is from Homeseer to the board, not the board to homeseer (which is achievable now).
                              HS3 PRO, Win10, WeatherXML, HSTouch, Pushover, UltraGCIR, Heaps of Jon00 Plugins, Just sold and about to move so very slim system.

                              Facebook | Twitter | Flickr | Google+ | Website | YouTube

                              Comment


                              • #75
                                Serial data

                                I would like to get rid of my quatech serial-to-ethernet-interface for reading a string my main AC counters delivers. (There is a potential risk not to have Quatech drivers for windows 10 and future)
                                I found many ways to have this serial string received by an Arduino, and sent back after parsing to other medias.
                                I am very new to this...
                                At present I get this string from a com port in HS, and have it parsed, saved in devices by HS scripting.
                                I imagined I could do the same if the Arduino could just send me this raw string, or that it could be parsed before using libraries easyli found on the net, and send sent to HS.
                                I have seen in a precedent message the debate over local or central processing.

                                My question is:
                                Could we have a pin declared to "serial", and its content sent as a string to a device ?
                                or
                                Could an API setup take care of that ?
                                Thanks for this great plugin, the Arduino world is wide opened to me ...
                                Visit zee e-maison : http://www.e-maison.com

                                Comment

                                Working...
                                X