Announcement

Collapse
No announcement yet.

Out of memory on UNO ????

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Out of memory on UNO ????

    Hi Greg

    I'm in town for a few days and fired up HS with the new ethernet boards. I've found that I can happily setup a mega with an ethernet controller but the freetronics UNO I suspect runs out of memory....

    Please tell me I should be able to use an UNO......

    It connects initially and then after 60 seconds gets a connection failed...Its not the hardware, I've tried the sample webserver code and it works fine....

    So with the combination of Etherten/UNO/MEGA/ENC controller, I seem to be stuck with Mega and W5100.....

    Any ideas ?

    Pete
    HS 2.2.0.11

    #2
    Pete;

    When you and I were visiting about these I had initially started with Unos with shields, but had only moved to the mega because of the small number of digital pins left when the Ethernet shield is mounted. I never had any problems with the Uno. Just to test I mounted a W5100 shield on a Uno and set it up as a test board. I assigned pins 3,5 and 6 as PWM pins and connected the board this morning. I joined the three pins as an RGB device, mounted an LED shield and began a pair of events that turn the RGB device off then on once every 5 minutes. It has been running fine for four hours.

    Mine is a genuine Arduino Uno. Can you tell me what you are doing where it fails?

    Comment


      #3
      Pete. Can you send me the sketch you are using on the Uno. This should work. Download the sketch again from the config page and try it again. Some people change the boards from usb to Ethernet and don't update the sketch which will not work and the 30 to 60sec is the timeout. If you can send me a debug log to then that would help.
      Greig.

      Sent from my HTC One using Tapatalk
      Zwave = Z-Stick, 3xHSM100� 7xACT ZDM230, 1xEverspring SM103, 2xACT HomePro ZRP210.
      X10 = CM12U, 2xAM12, 1xAW10, 1 x TM13U, 1xMS13, 2xHR10, 2xSS13
      Other Hardware = ADI Ocelot + secu16, Global Cache GC100, RFXtrx433, 3 x Foscams.
      Plugings = RFXcom, ActiveBackup, Applied Digital Ocelot, BLDeviceMatrix, BLGarbage, BLLAN, Current Cost, Global Cache GC100,HSTouch Android, HSTouch Server, HSTouch Server Unlimited, NetCAM, PowerTrigger, SageWebcamXP, SqueezeBox, X10 CM11A/CM12U.
      Scripts =
      Various

      Comment


        #4
        Randy

        The board I used was an Eleven.....I thought I saw you using an UNO and that's why this surprised me.

        Can I please double check the port assignment methodology. Each of the boards talks to a different port ? I thought at first I got this messed up as I note there is a IP/PORT listening information on the plugin page at the bottom.

        I added the mega with W5100 at first, that worked perfectly. I removed it from the configuration and then added an Eleven with W5100, did exactly the same and thats when I get the timeout. I've got a clone board but seem to have issues finding a serial driver so i can upload the sketch, more work to do.

        Either I'm doing something plainly wrong or the freetronics boards (Eleven and etherten) seem to have issues which is weird. I'll also work on trying to get this clone board to play on USB/Serial.

        Debug will follow tonight... and thankyou Greig/Randy for your collective responses

        Pete
        HS 2.2.0.11

        Comment


          #5
          The IP and listening port at the bottom of the config page are the IP address and port of your HomeSeer server that is listening for the boards. The port is 8888. For the board port and IP you can chose any free IP and port in your system or the plug-in will suggest unique IP and port numbers. I set my own IP and port numbers, but they are different for each board. I think the plug-in defaults to ports in the 8900 range. I chose mine up in the 55000 range very early in the beta process because I was having connection problems. It turned out that the ports in the 8900 range were fine, but I've never changed mine back.

          Comment


            #6
            Can we have this post as sticky?
            Why?

            It would be a good start for anyone choosing which board to use before anyone spent their money on boards which don't connect.

            If my findings are correct turns out that the UNOs run out of memory like petez69 says. I bought 2 genuine UNO boards from different venders and both behave the same (they will not connect) after trying to force them for 2 days!

            The genuine Mega and the Freetronics EtherMega are both sweet boards which I have tested for days on end with the beta plugin even without a reconnect event.

            I hope this helps someone else.


            Eman.
            TinkerLand : Life's Choices,"No One Size Fits All"

            Comment

            Working...
            X