Announcement

Collapse
No announcement yet.

Ethernet Connection issues?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Ethernet Connection issues?

    I have had some intermittent connection issues with Ethernet and have finally come to some conclusions I thought I would share.

    I am currently running 4 boards, all with Ethernet shields, 3 boards are Mega 2560 and one is an Uno. I have had very intermittent connectivity issues with one of my boards and a vexing hung input on another. One board that never gave me issues was the Uno I had in test with an RGB shield. The other one that never presented a problem was a Mega I had in test with OneWire devices and an I/O shield. To be fair the Mega in test, rarely had any inputs changes, it just sat there connected and never gave a problem. The Uno was actively tested but also never gave a problem. I purchased a lort of boards, some genuine Arduino and others from Chinese eBay sellers or Sainsmart. My Ethernet shields were mostly Chinese Arduino "compatible" with two genuine Arduinos on hand. One of the genuine Arduinos was on the Uno and the other was on the shelf.

    I started trying to cure the hung input problem. This particular board was fed by three microswitches from three of my hydronic zone valves. The confusing thing is that only one input would hang. When the DHW (Domestic Hot Water) valve closed and the microswitch opened, frequently the Arduino input would still show low. The only cure was to disconnect/reconnect the board. There were two identical inputs from identical zone valves that would never hang. There were also 6 more of these valves on a second Arduino and none of them would hang either. I changed the microswitch on the off chance that it was noisy or leaky. No Joy. Then I changed out the Mega and Ethernet shield. Noting that it was a compatible Arduino, I replaced it with a Genuine Mega R3. Still no joy, but now when the input hung, my reset events would disconnect the board but it would never reconnect without a manual reset. I changed the Ethernet cable - no joy. Realizing that I had used one of the "compatible" Chinese Ethernet shields, I opted to replace it with a Genuine Arduino shield. Not only did the connection issues go away, but I also have not had a hung input for the DHW valve since the change. It has been three days. I have no idea what an Ethernet shield could have to do with the hanging input, but since the connectivity was completely unstable I suppose errors could happen in communication between the board and plug-in. Before the changes, it was happening with every cycle of the hot water, usually twice daily. That was my real troublesome production board 2.

    Production board 1 would not give me problems, but it did generate frequent disconnect errors in the log. I changed it to a genuine Arduino Mega and a genuine Arduino Ethernet shield. In three days not a single connection error in the log.

    I have been fighting these intermittent problems for quite a few months. While three days doesn't confirm beyond a shadow of doubt, it is longer than I have gone in months.

    While I cannot prove anything about the Mega boards, I believe I have proven that the Arduino R3 Ethernet Shields are more reliable than the Wiznet clones from China.

    I think for me to count on reliable operation, I am going to stick with genuine Arduino boards and Ethernet shields. From my experience, at the very least, I would highly recommend sticking with the genuine product for the Ethernet shields.

    #2
    How is it with the disconnects ?
    Never any anymore, even with chinese clone boards or did you changed them to genuine boards as well ?
    Because i have gone to ethernet for stability, atleast that's what i hoped it would bring.
    But it gives me only trouble, for instance i run a light with some motion detectors.

    When a door opens, light goes on, when motion detector 1 and 2 do not see any motion anymore after X min the light will turn off.

    Because at first i thought the event i made was wrong, every X minutes when motion detector 1 and 2 say close it tries to set the on/off relay for the lights to off , even when it is off.
    This caused a flood in the log.

    But i see the board disconnect sometimes and after a while no reconnect.
    Since this is 200km away from home this can only be reset by sending a text message to my gsm switch to turn the power off and on for the arduino.

    I think i have to try this solution also because this has to run without problems.

    Vince

    Comment


      #3
      That was about a year and a half ago. Since then I have had 0 disconnect problems. I am still using genuine Arduino Ethernet (POE) shields and Mega 2560 boards in for my 3 production boards. They have been rock solid. For my test board in the workshop I have rolled some clone boards and shields in and out of use. I have thrown away 3 clone Ethernet shields that randomly would drop connections frequently. I have 1 or 2 that seem reliable. The clone mega boards seem generally fine, but one clearly had a couple of pins that would be randomly erratic.

      Since the post above, Greig has done a tremendous amount of work on the plug-in so it might be more forgiving of the flakey clone Ethernet shields, but in my production environment I am sticking with genuine devices, because I know they are reliable and have been reliable. I have designed the system architecture and events to (hopefully) keep a board or connection failure from causing any real problems, but for the small amount of cost difference I think I will stick with the genuine devices. My production environment with 2 boards in the basement and one in the garage has not had even a hiccup in over a year.
      Last edited by randy; February 20, 2016, 08:16 PM. Reason: Typo and clarification

      Comment


        #4
        I was also having random disconnects with a Mega 2560/wiznet clone - the plugin was usually good about reconnecting but would fail 1 time out of 10. Then I added a couple analog inputs and my problem with disconnects has disappeared. I think the reason for this is that the analog inputs report back to homeseer every 15 seconds, while the digitial inputs would very infrequently report back (only when I used them). It worked for me, ymmv.

        Comment


          #5
          Should have done that, because i was planning to connect a LDR to the board just for fun.
          Didn't do it.... and the location is 200Km away from home so it will take a few days before i can do it and check if al is working.
          Still it is to much of a guess because the drive is 4 hours, to and back.
          So a genuine shield will be then the cheapest solution because if it doesn't work i have to drive back.

          For now i have every 30 min set an event that the board reset's itself.
          Hope this will solve it for now.

          Thanks for the info both, and at my own home like you say Randy.
          It has to be stable, i am going to use it to control literally my whole home.
          all power sockets are switched by pulse relays and most sensors so a bit of stability is what i need.

          I could only find the new ethershield 2 boards with the w5500 network chips.
          It is even pretty hard to find legit/genuine boards i must add, i have emailed 2 company's to be sure it is.

          Comment


            #6
            Hi Vincenttor

            I've had some interesting issues with network boards myself. I happened to travel interstate yesterday and jsut before I left the toaster dropped a cct breaker in the house. Last night I found one of my boards didnt re-connect so I had to call my wife remove power and restart it.

            Randy has used POE which does make sense, if the network drops it looses the power. I've found that if the power stays up on some boards and the network restarts then it doesnt reconnect so POE sounds like a better sollution.

            On ebay you will find POE boards, you jsut have to look at the image of the device closely and make sure it has the POE holes across the board. Not sure if I will go POE myself however I'm going to play with the output of the plugin that shows the board not connecting and use it to reset the board.

            Again you only seem to find these things when you are FAR from teh device. Every time I go away on business something goes wrong (Electrically) :-)

            Good luck with your endeavors, will be interesting to see how you decide to make your system bulletproof :-)

            Pete
            HS 2.2.0.11

            Comment


              #7
              Haha yes that is exactly the thing what happens when you are in a hotel or holiday or whatever.
              Runs perfect for times when you are there and then suddenly.

              Well the thing that i thought was working is reset the board every X time.
              Still this resulted in the end in disconnects.
              I do have a gsm switch that i now use to take of the power from the arduino and turn it on again.
              When i do this i see almost immediately the arduino reconnecting to homeseer.
              I have been using a same gms relay switch in France at my parents house to turn on my radio tower so i can use the radio and rotate it.
              Reset the switch/modem/power etc etc and it has never let me down.
              It is a necessary thing in your system if you ask me when there is such a distance because when the computer crashed your done.

              I have bought this version : http://www.aliexpress.com/item/1-pcs...829598955.html

              But, i just search on the item and found this......
              I have paid 40 usd more for a plastic box..... ahha damn, but well thats life.
              Going to order one right away for my own home as well.
              http://www.aliexpress.com/item/Free-...597989003.html

              And there is a iphone and android app as well (free)
              It is pretty simple, one relay can switch on by calling, it recognizes the numbers you set and then it respond
              the other relays you can control by text messages
              This is what the app does, its just a layer that contains the standard messages, OUT=0100000 but then visible with a button instead of what i have been doing for years by typing the message myself.


              For the Ethernet shield, i can't take the risk of trying to hook up the analoge component and see if it stays working.
              The older original shield with a w5100 on it is difficult to obtain and when specially ordered they charge 70 euro for one piece.
              The new model, called Arduino Ethershield 2 with the newer w5500 chip is 20 euro.
              The store i called after mailing 3 assured me that it was a original one.
              So i have bought one of these and hope that this solves my disconnects.

              Comment


                #8
                Well i have a genuine board i hope , called the ethernet 2 shield with a w5500 chip.
                Had to change like said the ethernet libraries to :


                Code:
                #include <SPI.h>       
                #include <Ethernet2.h>
                #include <EthernetUdp2.h>
                Instead of :
                Code:
                #include <SPI.h>       
                #include <Ethernet.h>
                #include <EthernetUdp.h>
                Right away got a connection and now i have it idle at the moment because i have not much to connect right now.
                Probably going to connect a pir in the living room to simulate and monitor the logs for a while before i will change it.
                Also switched to the beta version.

                Comment


                  #9
                  Hi Mate

                  Did you get the unit from e-bay and how much was it ?

                  I bought one of these to try instead of piggy-backing it onto the mega expansion board, might make it neater in the cabinet. Hasnt arrived as yet..
                  Attached Files
                  HS 2.2.0.11

                  Comment


                    #10
                    Well i just checked the log and it seems quite stable, but there are no input signals yet connected to the board.
                    Since yesterday night/morning i had food poisoning, so didn't really feel like connecting that while sitting on the toilet haha.
                    But i just got a bit better so will connect it tomorrow and report how it goes.

                    This is the board i have bought.


                    https://www.kiwi-electronics.nl/ardu...earch=ethernet

                    The small inputs you see on the board for the pins that are a little it skew on the board, if thats the word.
                    This is for the POE module, i did found the original modules as well, but i also found modules on aliexpress, not sure how stable these are but it might be worth a try if you want to go POE

                    Comment


                      #11
                      Originally posted by Vincenttor View Post
                      Well i just checked the log and it seems quite stable, but there are no input signals yet connected to the board.
                      Since yesterday night/morning i had food poisoning, so didn't really feel like connecting that while sitting on the toilet haha.
                      But i just got a bit better so will connect it tomorrow and report how it goes.

                      This is the board i have bought.


                      https://www.kiwi-electronics.nl/ardu...earch=ethernet

                      The small inputs you see on the board for the pins that are a little it skew on the board, if thats the word.
                      This is for the POE module, i did found the original modules as well, but i also found modules on aliexpress, not sure how stable these are but it might be worth a try if you want to go POE
                      If you decide to get POE modules, you might hunt for 5V instead of 12V versions, the analog regulator on your Arduino boards will thank you. They get very hot with 12V supply.

                      Comment


                        #12
                        Thanks for the tip,
                        I saw them actually for 5v 2A and some for 3.3v.
                        I never run the arduino on more then 5v since the last time I tested the output pin on the arduino also gave 9v or something.
                        Maybe a faulty one but that made me decide to keep it at 5v.
                        Ruined some sensors then that got 9v instead of 5v.

                        Comment


                          #13
                          What do the additional pins on the board do ?
                          HS 2.2.0.11

                          Comment


                            #14
                            Originally posted by petez69 View Post
                            What do the additional pins on the board do ?
                            In trying to answer your question I ran across the following on the arduino.org website:
                            "The Shield also includes a reset controller, to ensure that the W5500 Ethernet module is properly reset on power-up. Previous revisions of the Shield were not compatible with the Mega and needed to be manually reset after power-up."

                            That is something I have never read before and may explain the reconnection issues you are having and might be a good reason to move the the revision 2 board. I don't know why I'm not having the problem, unless the POE causes everything to reset upon Ethernet connection. I'm thinking I may want to move to the version 2 boards down the road. I could move the POE modules from my old boards to the version 2 boards.


                            With regard to the additional plugs, it looks like they are just access to some of the input, output and serial data pins, along with +5V - convenient for things like OneWire devices. .
                            .
                            Attached Files

                            Comment


                              #15
                              Hi Randy

                              Yes I had a google and found similar especially the reference to the Mega and resets...Interesting :-) Might try and find a local source...

                              Pete
                              HS 2.2.0.11

                              Comment

                              Working...
                              X