Announcement

Collapse
No announcement yet.

Arduino Plugin For Linux (Beta)

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • enigmatheatre
    replied
    No problems. Have fun....

    Greig.

    Sent from my SM-G950F using Tapatalk

    Leave a comment:


  • honda123
    replied
    Yes! Thank you! It works perfectly now! I had been trying to get this to work for weeks. Had to redownload the ino file onto the board since it said something about version mismatch but after I did that it worked like a gem. Thanks again

    Leave a comment:


  • enigmatheatre
    replied
    On your system go to the updater (plugin manager). This is the page where you install, enable and disable the plugins. On that page scroll to the bottom and expand Additional Interfaces then scroll to the bottom of that section and you will see a beta section that if you expand it there will be a version of the Arduino plugin. Click on the check box next to it then scroll up to the top of the list where there will be an option to install it.

    Greig.

    Sent from my SM-G950F using Tapatalk

    Leave a comment:


  • honda123
    replied
    I'm sorry I do not understand, I am fairly new to this forum. What page am I scrolling down to the bottom section on? The link I previously posted had links to all of the updated versions but none of the links would open anything or install anything.

    Leave a comment:


  • enigmatheatre
    replied
    The Beta is in the updater. Just scroll down to the bottom section and install from there.

    Greig.

    Sent from my SM-G950F using Tapatalk

    Leave a comment:


  • honda123
    replied
    Is there a default firewall on the hometroller? I will take a look and see if it has one. I tried downloading the beta version updates from this thread: https://forums.homeseer.com/forum/an...a-version-info
    but none of the links worked. Do you have the beta version that I can download or is there another place to get it?

    Thanks,

    Mike

    Leave a comment:


  • enigmatheatre
    replied
    Originally posted by honda123 View Post
    It's says I am not allowed to upload an ino file so here it is a txt. Thanks for the speedy reply!
    OK got it but see nothing wrong, Is there a firewall or AV that could be blocking it? Can you try the Beta version as there are many connection changes.

    Greig.

    Leave a comment:


  • enigmatheatre
    replied
    Originally posted by honda123 View Post
    It's says I am not allowed to upload an ino file so here it is a txt. Thanks for the speedy reply!

    I am not seeing it, Please send it to my email that you will get by clicking Enigmatheatre at the top of the plugin or in the help file.

    Greig.

    Leave a comment:


  • honda123
    replied
    It's says I am not allowed to upload an ino file so here it is a txt. Thanks for the speedy reply!
    Attached Files

    Leave a comment:


  • enigmatheatre
    replied
    Originally posted by honda123 View Post
    Hello,

    I have a HomeTroller-SEL running Lubuntu and I am trying to get the Arduino Plug-In working. I have imputed all of the correct information for MAC address and IP Address. I am using an Arduino UNO with an authentic Arduino ethernet shield 2. It uses the Ethernet2 library so I checked off the box beside ethernet shield V2. I can ping both the Arduino and the controller and receive responses. The Arduino code downloads to the board with no problems, just the deprecated version responses because I'm on the old version of Arduino that was requested. However when I try to connect the Arduino in the plug-in, I never get connection. I have had connection in the past for less than 10 seconds and then it drops it and will not come back. I have attached the debug code for one of the connection attempts. The debug screen said it was trying to connect, then awaiting response and then it said it failed connection. That is when I stopped the Debugger. If anyone has any idea why I can't connect, please let me know.

    Thanks,

    Mike
    Mike,

    Looking at the debug the board is not seeing the HomeTroller for some reason. Can you send me the Sketch you uploaded on to the board so I can check it is set up properly.

    Greig.

    Leave a comment:


  • honda123
    replied
    Hello,

    I have a HomeTroller-SEL running Lubuntu and I am trying to get the Arduino Plug-In working. I have imputed all of the correct information for MAC address and IP Address. I am using an Arduino UNO with an authentic Arduino ethernet shield 2. It uses the Ethernet2 library so I checked off the box beside ethernet shield V2. I can ping both the Arduino and the controller and receive responses. The Arduino code downloads to the board with no problems, just the deprecated version responses because I'm on the old version of Arduino that was requested. However when I try to connect the Arduino in the plug-in, I never get connection. I have had connection in the past for less than 10 seconds and then it drops it and will not come back. I have attached the debug code for one of the connection attempts. The debug screen said it was trying to connect, then awaiting response and then it said it failed connection. That is when I stopped the Debugger. If anyone has any idea why I can't connect, please let me know.

    Thanks,

    Mike
    Attached Files

    Leave a comment:


  • MattL0
    replied
    rpradeenigmatheatre Thanks.

    i see the same thing with other plugin.
    I will use this thread to show it to hst sorry for this.
    Attached Files
    Last edited by MattL0; October 28th, 2018, 02:38 PM.

    Leave a comment:


  • rprade
    replied
    Originally posted by MattLau View Post
    why are there two arduino plugin in the updater ? i am on linux
    1.0.0.148 is the current beta. 1.0.0.131 is the current release.

    Leave a comment:


  • enigmatheatre
    replied
    Originally posted by MattLau View Post
    why are there two arduino plugin in the updater ? i am on linux
    Good question. I will have to contact the HS Team to fix this one.

    Greig.

    Sent from my SM-G950F using Tapatalk

    Leave a comment:


  • MattL0
    replied
    why are there two arduino plugin in the updater ? i am on linux
    Attached Files

    Leave a comment:

Working...
X