Announcement

Collapse
No announcement yet.

Arduino irrigation controller

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Arduino irrigation controller

    I'm curious if anyone has built an irrigation controller on arduino using this plugin. I run HS3 on Linux as a VM which eliminates my ability to use irrigation controllers that use an RS232 connection (I'm sure others can pass RS232 over USB to a VM but I'd rather not go down that path).

    I've never used or owned an arduino but am thinking this could be the project to get started.

    I'm thinking of an Arduino mega, ethernet shield and either a relay shield or separate relay board to manage my 8 sprinkler zones.

    Anything I'm missing as to why this wouldn't work?

    #2
    Smart irrigation hardware is typically designed so that the processor doing the scheduling control is independent of the processor/timer that is able to actually control the relay/valve. This provides a monitoring capability to assure a valve does not remained in the controlled ON state too long. In your situation this model would be achieved with the arduino providing the monitoring and HS providing commands to control the scheduling. While you do not need this architecture, it does provide a degree of protection. If you use the arduino only as a conduit to overcome RS232 constraints then you have no irrigation valve-on protection. There are other irrigation controllers based upon Ethernet rather than RS232 interface such as Etherrain and OpenSprinkler and in this case there exists out-of-the box solutions that work with HS.

    Comment


      #3
      I have multiple Rain8 serial irrigation controllers, and connect to them using virtualized HS, via a Moxa serial server. It works great with mcsSprinklers. You can pick up a surplus serial server on eBay for dirt cheap.

      Comment


        #4
        Yes this can be done. See Here

        Greig.
        Zwave = Z-Stick, 3xHSM100� 7xACT ZDM230, 1xEverspring SM103, 2xACT HomePro ZRP210.
        X10 = CM12U, 2xAM12, 1xAW10, 1 x TM13U, 1xMS13, 2xHR10, 2xSS13
        Other Hardware = ADI Ocelot + secu16, Global Cache GC100, RFXtrx433, 3 x Foscams.
        Plugings = RFXcom, ActiveBackup, Applied Digital Ocelot, BLDeviceMatrix, BLGarbage, BLLAN, Current Cost, Global Cache GC100,HSTouch Android, HSTouch Server, HSTouch Server Unlimited, NetCAM, PowerTrigger, SageWebcamXP, SqueezeBox, X10 CM11A/CM12U.
        Scripts =
        Various

        Comment


          #5
          Originally posted by denisl View Post
          I'm curious if anyone has built an irrigation controller on arduino using this plugin. I run HS3 on Linux as a VM which eliminates my ability to use irrigation controllers that use an RS232 connection (I'm sure others can pass RS232 over USB to a VM but I'd rather not go down that path).

          I've never used or owned an arduino but am thinking this could be the project to get started.

          I'm thinking of an Arduino mega, ethernet shield and either a relay shield or separate relay board to manage my 8 sprinkler zones.

          Anything I'm missing as to why this wouldn't work?
          Michael McSharry brings up a good point about most irrigation controllers being somewhat autonomous. That is why I stuck with my Etherrain 8 that I installed before I began fiddling with Arduinos.

          That said, there is no reason you couldn't use an Arduino as the controller and if I was doing it from scratch I would consider it. HomeSeer has become so reliable as is the Arduino plug-in, I wouldn't hesitate to trust it to control the valves. I would use optically coupled relays like the post Greig linked above, making sure they are configured to be "active high" on the Arduino pins. I would also wire the 24-volt valve control through a relay controlled by the "alive" pin on the Arduino. That way a loss of the power supply to the Arduino or it no longer communicating with HomeSeer would shut down the irrigation valves.

          With HomeSeer an the Arduinos, you have a very reliable system as long as your hardware is good - both the server running HomeSeer and the Arduino components.

          But just as the Russian proverb President Reagan was fond of repeating "doveryai no proveryai" (trust but verify), I build a lot of redundancy into my Arduino configurations, just in case the hardware or software fails me.

          Comment


            #6
            The "alive pin" is a very valuable resource !

            Randy, while you might be reading this, have question regarding failsafe. I've got a mega and etherten connected to HS. I've enabled the auto-connect feature, if I reboot HS or power down and re-power the arduinos everything is happy however if I pull the ethernet connection on the arduino(s) and re-connect it doesnt come back "on-line" as far as the arduino status goes.

            Not sure "why is it so"...?

            Pete
            HS 2.2.0.11

            Comment


              #7
              Hmm, appears I found another post that asked the same question. It appears its something to do with the clone boards...

              Think I might code up a "nano" to keep its eye on the "alive pin" and have it "reset" the W5100 board after a set time if it doesnt see HS....not elegant but it will do the trick :-)

              Pete
              HS 2.2.0.11

              Comment


                #8
                Originally posted by petez69 View Post
                The "alive pin" is a very valuable resource !

                Randy, while you might be reading this, have question regarding failsafe. I've got a mega and etherten connected to HS. I've enabled the auto-connect feature, if I reboot HS or power down and re-power the arduinos everything is happy however if I pull the ethernet connection on the arduino(s) and re-connect it doesnt come back "on-line" as far as the arduino status goes.

                Not sure "why is it so"...?

                Pete
                I'll check mine tomorrow. They have always reconnected immediately, but I haven't tested it since well before 1.0.0.85. I'll post back here.

                Comment


                  #9
                  Originally posted by rprade View Post
                  I'll check mine tomorrow. They have always reconnected immediately, but I haven't tested it since well before 1.0.0.85. I'll post back here.
                  Thanks Randy..

                  I sure wouldnt call the "etherten" a clone or cheap board, cost me an arm and a leg :-) Its a freetronics unit.

                  Thanks for having a look yourself, be interested to see what you find...as I posted above, if I have to I'll simulate a reset button press on the network card if needed....

                  Pete
                  HS 2.2.0.11

                  Comment


                    #10
                    Originally posted by petez69 View Post
                    Hmm, appears I found another post that asked the same question. It appears its something to do with the clone boards...

                    Think I might code up a "nano" to keep its eye on the "alive pin" and have it "reset" the W5100 board after a set time if it doesnt see HS....not elegant but it will do the trick :-)

                    Pete
                    That does sound like what was happening with one of mine when I was using a Chinese mega with a Chinese Ethernet shield. I will still test it with my current boards. It may not be a completely valid test since mine are POE, meaning that disconnecting the Ethernet also removes power.

                    Comment


                      #11
                      Originally posted by rprade View Post
                      That does sound like what was happening with one of mine when I was using a Chinese mega with a Chinese Ethernet shield. I will still test it with my current boards. It may not be a completely valid test since mine are POE, meaning that disconnecting the Ethernet also removes power.
                      Randy, thats actually a good idea using "true" POE....you wont have one without the other :-)

                      Pete
                      HS 2.2.0.11

                      Comment


                        #12
                        trying to understand how to use the alive pin
                        how would one do this....

                        >> I would also wire the 24-volt valve control through a relay controlled by the "alive" pin on the Arduino. That way a loss of the power supply to the Arduino or it no longer communicating with HomeSeer would shut down the irrigation valves.

                        Paul.

                        Comment


                          #13
                          could someone please explain how the above is done
                          i have 3 12 volt valves I would like to use for my sprinkler system this season.
                          paul

                          Comment


                            #14
                            Originally posted by sirbooker View Post
                            could someone please explain how the above is done
                            i have 3 12 volt valves I would like to use for my sprinkler system this season.
                            paul
                            What do you need to know and are you using this to control the valves or just have the 24v as a cut off?

                            Have you looked at this

                            You would need a relay for each valve and one for the cut off connected to the alive pin connected to the board. I suggest a mega with ethernet shield if you don't have one.

                            Greig.
                            Zwave = Z-Stick, 3xHSM100� 7xACT ZDM230, 1xEverspring SM103, 2xACT HomePro ZRP210.
                            X10 = CM12U, 2xAM12, 1xAW10, 1 x TM13U, 1xMS13, 2xHR10, 2xSS13
                            Other Hardware = ADI Ocelot + secu16, Global Cache GC100, RFXtrx433, 3 x Foscams.
                            Plugings = RFXcom, ActiveBackup, Applied Digital Ocelot, BLDeviceMatrix, BLGarbage, BLLAN, Current Cost, Global Cache GC100,HSTouch Android, HSTouch Server, HSTouch Server Unlimited, NetCAM, PowerTrigger, SageWebcamXP, SqueezeBox, X10 CM11A/CM12U.
                            Scripts =
                            Various

                            Comment


                              #15
                              Greig thanks for the quick reply

                              i currently have a 12 volt valve connected to a relay that is connected to a nodmcu (output 1 pin:d2 )
                              the alive pin is D3 which is not showing in homeseer.
                              everything is working good at the moment but
                              would like to use the alive pin for safety.
                              just trying to understand how to use the alive pin
                              Paul.

                              Comment

                              Working...
                              X